Bug Hunting Session
Bug 35727 - ucb.UniversalContentBroker::com::sun::star::ucb::XContentProviderManager fails
Summary: ucb.UniversalContentBroker::com::sun::star::ucb::XContentProviderManager fails
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Björn Michaelsen
URL:
Whiteboard: unoapitest
Keywords:
Depends on:
Blocks: subsequenttest-failures
  Show dependency treegraph
 
Reported: 2011-03-27 15:03 UTC by Björn Michaelsen
Modified: 2011-12-24 04:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2011-03-27 15:03:39 UTC
The unoapi test ucb.UniversalContentBroker::com::sun::star::ucb::XContentProviderManager fails
in ucb. To reproduce, remove the test from the blacklist at:
 ucb/qa/unoapi/knownissues.xcl
and run:
 cd smoketestoo_native && build --all
 cd ucb && make -sr subsequentcheck
Comment 1 Rainer Bielefeld Retired 2011-03-27 22:58:18 UTC
May be the test is wrong ;-)

What consequences might that have for use of LibO?
Comment 2 Björn Michaelsen 2011-03-29 10:42:32 UTC
Well, if the test is wrong then that is the bug obviously. This is why it needs to be investigated. ;)

ucb is the basis for lots of load/save operations, anything at odd here can lead to unfortunate surprises.

Also it means that we behave different from that other office, which is likely unintended and also might lead to breaking extensions.
Comment 4 Björn Michaelsen 2011-12-24 04:27:28 UTC
closing