Download it now!
Bug 35748 - spelling and grammar checker uses deleted characters when showing changes
Summary: spelling and grammar checker uses deleted characters when showing changes
Status: RESOLVED DUPLICATE of bug 36540
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-28 09:58 UTC by toddrme2178
Modified: 2014-02-06 13:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description toddrme2178 2011-03-28 09:58:13 UTC
The "multiple spaces" grammar error includes removed spaces in tracked changes.

To reproduce:

1. Make a string of text with spaces
2. Turn on tracking changes
3. Delete one of the space, then hit the space bar

The change tracking will show the added and removed space, but the grammar checker will report this at two spaces.  It impossible to fix the grammar problem since any attempt to do so is tracked by the change tracker.
Comment 1 toddrme2178 2011-04-04 10:45:30 UTC
It looks like it is not just spaces, changes are used when computing any spelling or grammar error.  For instance if you write a word, delete it, then write it again, it is shown as being a duplicate word even though one of the words doesn't actually "exist".  If you type some random characters in the middle of a word then delete them, the word is shown as being a spelling error even though the "real" word is spelled correctly.

So perhaps this should be changed to "spelling and grammar checker uses deleted characters when viewing changes", or something like that.

When combined with bug 35746, which makes it hard to accept or reject changes when there are spelling or grammar errors, it makes it very hard to work with changes since they are counted as spelling or grammar errors but you can't right-click to accept or reject the change in order to fix the problem.
Comment 2 Björn Michaelsen 2011-12-23 11:49:19 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Florian Reisinger 2012-08-14 14:01:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:02:55 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:07:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:09:35 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Olivier R. 2012-08-15 10:32:38 UTC
Confirmed.
I reopen this issue.

Deleted text shouldn’t be sent to the grammar checker.
Comment 8 Kumāra 2013-09-23 08:26:43 UTC
(In reply to comment #7)
> Confirmed.
> I reopen this issue.
> 
> Deleted text shouldn’t be sent to the grammar checker.

Is this bug still valid for you? Can you check if Bug 36540 is describing the same issue? If so, please mark this as duplicate of that.
Comment 9 Marcin Miłkowski 2014-02-06 13:17:51 UTC

*** This bug has been marked as a duplicate of bug 36540 ***