Download it now!
Bug 35860 - Writer thinks that all pages of .doc file with mixed album/portrait pages have portrait orientation
Summary: Writer thinks that all pages of .doc file with mixed album/portrait pages hav...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2011-04-01 02:42 UTC by Jerf
Modified: 2012-08-31 10:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example (12.50 KB, application/msword)
2012-08-24 14:56 UTC, Urmas
Details
the same file saved as pdf using msWord 2007 (4.30 KB, application/pdf)
2012-08-27 09:27 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jerf 2011-04-01 02:42:14 UTC
If in a .doc file made by MS Word there are some of pages with portrait orientation and some other ones with album orientation, LibreOffice writer thinks that _every_ page has portrait orientation, which screws up all those pages which had album orientation.
Note that for some reason OpenOffice Writer 3.3.0 handles this correctly.
Comment 1 Björn Michaelsen 2011-12-23 11:47:49 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-01-05 01:39:01 UTC
not reproducible in LibO 3.5.0 beta 1
my be You have document with specific problem. Please attach file with this problem.
Comment 3 Florian Reisinger 2012-08-14 14:00:53 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:02:00 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:06:41 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:08:43 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Zsolt 2012-08-14 22:34:24 UTC
It would be nice if someone could confirm that this bug still exists or is fixed, since it was auto invalidated.
Comment 8 Florian Reisinger 2012-08-24 13:54:48 UTC
Sorry for the two comments, but this needs needinfo status...

Please attach a testcase (The document you talked of...)
Comment 9 Urmas 2012-08-24 14:56:22 UTC
Created attachment 66068 [details]
Example
Comment 10 Urmas 2012-08-24 14:56:49 UTC
A simple Word document.
Comment 11 Florian Reisinger 2012-08-24 15:03:14 UTC
Coulöd you please try it with LibO 3.6 IMHO it is working here on Windows...
Comment 12 Roman Eisele 2012-08-24 15:08:41 UTC
(In reply to comment #10)
> A simple Word document.

@Urmas:
Thank you very much for the sample .doc file!

However: what are your results?

If I open your sample .doc file, all LibreOffice versions I have tested show the same results (all tests done on MacOS X 10.6.8 Intel):
  LibreOffice 3.3.0
  LibreOffice 3.4.6
  LibreOffice 3.5.6.2
  LibreOffice 3.6.1.1
all show
  1) a portrait page ("Page 1")
  2) a portrait page ("Page 2")
  3) a landscape/album page ("Album page")
  4) a portrait page ("Page 3")

Is this right (then the bug is not reproducible, just as Florian said -- comment #11, cf. already comment #2)?
Or is this wrong?
Or are the results different on Linux?

Thank you for clarification!
Comment 13 sasha.libreoffice 2012-08-27 09:27:15 UTC
Created attachment 66168 [details]
the same file saved as pdf using msWord 2007
Comment 14 sasha.libreoffice 2012-08-27 09:30:25 UTC
in 3.6.0 on Linux it opens wrong, regression (Windows not tested)
But in 3.6.1 may be fixed, not tested yet
Comment 15 Florian Reisinger 2012-08-27 11:15:53 UTC
Seting status to new due to last comment. Working here on Windows 7 x64 LO 3.6.0.4
Comment 16 sasha.libreoffice 2012-08-31 06:56:00 UTC
in 3.6.1 on Fedora 64 bit works correctly. Changing to WFM