Download it now!
Bug 35911 - Lock multimedia volume key of keyboard
Summary: Lock multimedia volume key of keyboard
Status: RESOLVED DUPLICATE of bug 32664
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-02 11:46 UTC by flamaros.xavier
Modified: 2011-12-22 05:50 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description flamaros.xavier 2011-04-02 11:46:52 UTC
I am using a Logitech G110 keyboard and when a Libre office application have focus my multimedia sound volume keystroke don't works. Other multimedia sound like stop, play/pause,... works fine.

Libre office applications don't need catch any multimedia event, Windows will manage it perfectly.

I am using Windows Seven.
Comment 1 Jan Holesovsky 2011-04-07 10:29:17 UTC
Can you please somehow find out the exact keycode of the key in question?  We obviously do not have the keyboard to test ourselves :-(
Comment 2 flamaros.xavier 2011-04-07 14:19:18 UTC
(In reply to comment #1)
> Can you please somehow find out the exact keycode of the key in question?  We
> obviously do not have the keyboard to test ourselves :-(

Here is my test code :

LRESULT	CALLBACK FrameWndProc(HWND hWnd, UINT message, WPARAM wParam, LPARAM lParam)
{
	switch (message)
	{
	case WM_KEYDOWN:
	case WM_KEYUP:
	{
		int code = wParam;
		break;
	}
}

Resulting key codes (wParam values) :
 - volume up      => 175
 - volume down    => 174
 - play/pause     => 179
 - stop           => 178
 - previous track => 177
 - next track     => 176
 - mute volume    => 173

I find this later :
http://msdn.microsoft.com/en-us/library/dd375731%28v=vs.85%29.aspx

There is some defines like VK_VOLUME_UP

And lParam isn't an interesting value in your case :
http://msdn.microsoft.com/en-us/library/ms646281%28v=vs.85%29.aspx


Good luck.
Comment 3 Anonymous Helper 2011-04-11 16:10:42 UTC

*** This bug has been marked as a duplicate of bug 32664 ***
Comment 4 Björn Michaelsen 2011-12-22 05:36:35 UTC
Remove infoprovider from closed and resolved bugs.
Comment 5 Björn Michaelsen 2011-12-22 05:50:40 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.