Bug Hunting Session
Bug 35981 - datapilot column filter not works
Summary: datapilot column filter not works
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86 (IA32) All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-05 01:40 UTC by ercolinux
Modified: 2011-12-13 19:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test spreadsheet (318.91 KB, application/zip)
2011-04-05 03:33 UTC, ercolinux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ercolinux 2011-04-05 01:40:11 UTC
The datapilot module don't works as expected when open an excel spreadsheet with a pivot table: when try to filter using the first record on a column (is not relevant which column or the sorting method) is possible to exclude that record but not to select it again.
If is clicked the "select all" then it works again.
As workaround I've find that flagging "Identify categories" make it works as expected, but when I save the spreadsheet in xls format I lost that setting.
I've found this problem on almost 3 different spreadshets in xls format, and is full reproducible both on Linux and on Windows.
I can't attach a copy of one of the file due to relevant and private datas on them
Comment 1 ercolinux 2011-04-05 03:33:24 UTC
Created attachment 45270 [details]
test spreadsheet
Comment 2 Jan Holesovsky 2011-04-14 04:20:58 UTC
ercolinux: Can you please try with the 3.4 beta if it still appears broken there?  Thank you!
Comment 3 ercolinux 2011-04-14 05:40:18 UTC
In 3.4 beta the datapilot works perfectly.
Well done
Comment 4 Kohei Yoshida 2011-04-15 06:59:58 UTC
Closing as fixed in 3.4.
Comment 5 ercolinux 2011-04-29 03:57:54 UTC
In 3.4 beta3 I've again the some problem (up to beta 2 it works).
Comment 6 andis.lazdins 2011-07-01 08:12:12 UTC
It seems to be solved in 3.4.1
Comment 7 Kohei Yoshida 2011-12-13 19:04:07 UTC
I'm glad to have finally fixed this!

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7352c717a307c46f0f1825375597fbe44b816ba5

The fix will be in 3.5.