Download it now!
Bug 36100 - EDITING : Edit > Cut also should show blinking border around cells
Summary: EDITING : Edit > Cut also should show blinking border around cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-09 03:29 UTC by pierre-yves samyn
Modified: 2011-11-07 20:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2011-04-09 03:29:26 UTC
Hello

My environment: XP Pro SP 3 - Libo 3.3.2
Reproduced on Vista and XP SP 3 family - Libo 3.3.2

1) Edit> Cut (or Ctrl + X or Shift + Del) does not display the blinking border which symbolizes the manipulation.

Besides the inconsistency with the copy, now similar "to excel", this absence is particularly troublesome with Shift + Delete for reasons "historic".

In previous versions this shortcut allowed  fast deletion  (without display selection dialog = alternative to the button Backspace).

Reproducing the problem:

Select one or more cells containing something (text, number, formula...)

Press Shift + Del, the content is removed (OK), the range is selected (OK)

Press Enter: the deleted content is restored ... what is normal with the new paste mode but *seems* abnormal because of the abscence of the blinking border.

Best regards
Comment 1 Rainer Bielefeld Retired 2011-04-30 02:28:37 UTC
Reported effect "missing dotted frame" is [Reproducible] with "LibreOffice 3.4Beta3  – WIN7  Home Premium  (64bit) English UI [DEV300m103 (Build:3)]". I also would expect that <cntrl+x> should create the same dotted frame around the cell contents putted to the clipboard as <cntrl+c> does.
LibO behavior for <cntrl+x> differs from the one in EXCEL:
- EXCEL: LEAVES the contents in old cell until clipboard will be pasted anywhere.
         So the dotted frame is required to know that  <cntrl+x> has been done
- LibO: DELETES old cell contents immediately after having put it to clipboard
        So the dotted frame is not necessarily required to know that 
        <cntrl+x> has been done.

I'm tending to think that it would be the better solution to see the frame, but I also could respect the current behavior as the intended behavior.

@pierre-yves samyn:
- can you contribute
  -- a help text or specification concerning frame
  -- experience from other spreadsheets than Eexcel

@Kohei:
Can you please have a look and may be leave a comment?
Comment 2 pierre-yves samyn 2011-04-30 03:36:33 UTC
OK with Rainer : 

"LibO DELETES old cell contents immediately after having put it to clipboard
So the dotted frame is not necessarily required to know that <cntrl+x> has been done."

BUT, the dotted frame is essential to know that the "cut" is still in progress because the next  <Enter>  will paste the cell cut in the current cell.

Furthermore note that the Enter key is assigned by default to move the selection down (Tools> Options> Calc> General). I do not use it but some people do... They must be warned that the next <Enter> will paste

Except Excel I do not know another spreadsheet using this dotted frame. Ms-Works does not use it.

I never liked this function, I prefer the one used previously (exclusive use of the clipboard). I suppose it is unfortunately too late to "go back" ... and so, IMHO the dotted frame is essential for the reason mentioned above ("cut in progess"
Comment 3 Rainer Bielefeld Retired 2011-05-09 21:43:41 UTC
I also think that showing the border would be more consequent and useful.
Comment 4 Kohei Yoshida 2011-05-09 21:48:15 UTC
Agreed.  I'll take it.
Comment 5 Markus Mohrhard 2011-11-07 20:03:53 UTC
pushed a fix in master for the 3-5 release