Bug 36339 - data ranges corrupted on a chart when any data changes in data range cells
Summary: data ranges corrupted on a chart when any data changes in data range cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
: 36731 44885 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-18 02:14 UTC by cunio
Modified: 2013-11-24 19:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
spreadsheet file (18.72 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-04-26 11:28 UTC, cunio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cunio 2011-04-18 02:14:59 UTC
1) write some data to two columns
2) produce x-y graph based on the data
3) save file
4) change any data in the cells selected as data range
5) nothing changes on the chart
6) click on the chart
7) all the data disappear from the chart, data ranges chart dialog box is corrupted - no way to correct the ranges
Comment 1 Kohei Yoshida 2011-04-18 13:36:56 UTC
Can you attach the document with the actual data used?  I can't reproduce this.
Comment 2 Kohei Yoshida 2011-04-18 15:02:42 UTC
Just so that we have this on the record, I've received a test document from the reporter privately because of the confidential nature of the document.

I still can't reproduce this, but it may be because I'm using the English version.  This may be locale-specific...
Comment 3 Kohei Yoshida 2011-04-18 15:06:22 UTC
I'll keep this in the meantime.
Comment 4 cunio 2011-04-26 11:28:22 UTC
Created attachment 46095 [details]
spreadsheet file
Comment 5 cunio 2011-04-26 11:29:20 UTC
I have been testing it in LO3.4 beta2,
The problem still persists.

To reproduce the problem:
1) create a new spreadsheet
2) write some data into two columns
3) produce x-y graph based on the data
4) save the file and close the spreadsheet
5) reopen the spreadsheet 
6) double-click on the chart to edit it - all the data from the chart will disappear - data ranges dialogbox contains some rubbish.

I'm attaching the test file with two charts - destroyed one and another one may be destroyed by oneself just by double-click on it.
Comment 6 cunio 2011-05-01 13:52:36 UTC
LO 3.4.beta 2 checked - problem still persists.
Comment 7 cunio 2011-05-01 13:53:22 UTC
LO 3.4.beta 3 checked - problem still persists.
Comment 8 cunio 2011-05-07 14:50:51 UTC
Bug is still here in LO 3.4. beta 4
Comment 9 Kohei Yoshida 2011-05-10 14:21:02 UTC
Ok.  Now I reproduced it.  I'll look into this.
Comment 10 Kohei Yoshida 2011-05-10 21:12:56 UTC
(In reply to comment #9)
> Ok.  Now I reproduced it.  I'll look into this.

Actually, when I said I reproduced it, I just opened your attached document and double-clicked the chart and saw it corrupted.  However, following your steps to create a new document with a chart, I won't be able to reproduce it...
Comment 11 Kohei Yoshida 2011-05-10 21:43:32 UTC
Did you use the Sun report builder to create those charts?  The mime type of your charts both specify that their creator is the Sun report builder.
Comment 12 Kohei Yoshida 2011-05-10 21:49:30 UTC
Also...

(In reply to comment #5)
> 
> To reproduce the problem:
> 1) create a new spreadsheet
> 2) write some data into two columns
> 3) produce x-y graph based on the data

Can you describe in very good details how you "produced x-y graph based on the data"?  I did create mine via Insert - Chart.  Did you do the same?
Comment 13 Kohei Yoshida 2011-05-11 08:33:38 UTC
I'll put this on hold for now while waiting for further information from the reporter.

Code pointer for future investigation:

In

embeddedobj/source/general/xcreator.cxx:
UNOEmbeddedObjectCreator::createInstanceInitFromEntry()

m_aConfigHelper.GetFactoryNameByMediaType fails to return the embed factory service name from the application/vnd.sun.xml.report.chart media type, which ended up trashing the chart object upon activation.
Comment 14 Kohei Yoshida 2011-05-11 11:03:02 UTC
*** Bug 36731 has been marked as a duplicate of this bug. ***
Comment 15 cunio 2011-05-15 09:20:25 UTC
LibreOffice 3.4 beta 5 - bug is still here,

Here you have a screencast showing how to reproduce the bug:

http://vimeo.com/23756741
Comment 16 Regina Henschel 2011-05-15 11:21:53 UTC
I can reproduce it.
1. Mark the data range.
2. Click on Chart-icon in Standard-toolbar.
3. Choose XY-Chart, subtype "Points and Lines" and !!! check "Smooth lines".
Save, close and reload. The chart has lost its data range.

I use LO 3.4.0 Beta 5 on WinXp.
Comment 17 Kohei Yoshida 2011-05-16 08:35:29 UTC
Can anybody who can reproduce this try it again with Java disabled?

To disable Java, go to

Tools -> Options -> LibreOffice -> Java and uncheck "Use a Java runtime environment".

I'm wondering if this is caused by one of the extensions we ship with (which I don't use in my development build).
Comment 18 Regina Henschel 2011-05-16 08:49:03 UTC
The error remains, when I uncheck "Use a Java runtime environment".
Comment 19 Kohei Yoshida 2011-05-16 10:57:30 UTC
I can finally reproduce this.

I re-built this time with Sun's report builder extension enabled.  Now it gets reproduced with 100% success rate.

I'll look into this.
Comment 20 cunio 2011-05-16 11:44:19 UTC
Kohei,

Good news. BTW, Oracle's report builder extension is installed and enabled by default. I even have no "disable" button in extension manager to switch it off when running as a plain user.
Comment 21 Kohei Yoshida 2011-05-16 19:28:09 UTC
Just posted the detail of my findings on the mailing list:

http://lists.freedesktop.org/archives/libreoffice/2011-May/012040.html

soliciting feedback on how to fix this bug.
Comment 22 Alex Thurgood 2011-05-17 01:04:21 UTC
Hi Kohei,

How about reverting the commit that caused this to no longer work in the first place ?

It worked fine in 3.3, now it doesn't in 3.4b. So what happened in between ? OOom103 integration ? Changes in the Calc chart stuff ?

Please do not remove the ORB extension from the provided builds, at least not until a drop-in replacement can be found and works.

Alex
Comment 23 cunio 2011-05-20 02:41:29 UTC
LO 3.4 rc1 - short test shows that now it works.

I've no intention to test it any further, I stay with LO 3.3 because of some other problems - like https://bugs.freedesktop.org/show_bug.cgi?id=37230

Thanks
Comment 24 cunio 2011-05-20 02:42:19 UTC
I'm closing the bug :)
Comment 25 tester8 2012-01-25 02:52:13 UTC
cunio@poczta.onet.pl

This bug affects not just you. Reopen for now.
Comment 26 tester8 2012-01-25 02:53:20 UTC
*** Bug 44885 has been marked as a duplicate of this bug. ***
Comment 27 tester8 2012-01-25 03:04:54 UTC
Really sorry. My mistake. It is fixed.
Comment 28 Friedmann Bruno 2012-01-25 04:07:43 UTC
It is not for the whole 3.4 (bug under 3.4.5) branch, only perhaps in the future 3.5 which is not released.

3.4 it's the only one final users can use, with the status ready for enterprise :-(

But I will not fight for that, it's too late once we loose customers.