Download it now!
Bug 36731 - Chart disappers when you double-click to edit
Summary: Chart disappers when you double-click to edit
Status: RESOLVED DUPLICATE of bug 36339
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 23:54 UTC by Jean-Baptiste Faure
Modified: 2014-03-08 13:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example of chart that is removed when edited (13.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-04-30 23:54 UTC, Jean-Baptiste Faure
Details
this file works for me. (21.61 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-01 01:18 UTC, GerardF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2011-04-30 23:54:54 UTC
Created attachment 46208 [details]
example of chart that is removed when edited

Steps to reproduce:
- open the attached test speadsheet
- double-click on the chart to edit
=> the curve has been removed

Same bug with file created by previous versions of LibO.
Tested with LibO 3.4.0 beta-3 FR and EN under Ubuntu 10.04 x86_64.

JBF
Comment 1 GerardF 2011-05-01 01:18:21 UTC
Created attachment 46211 [details]
this file works for me.

Strange behavior.
I'm reproducing the bug with 3.4 Beta3 running on Windows Vista with your attachment, but i open a file made on a previous version of LibO and i don't have this bug.
It is a bar chart (not curve) made for English forum with a Age Pyramid.
Comment 2 GerardF 2011-05-01 01:40:06 UTC
More Infos :

I've made few more test on Windows Vista :

Opening test_graph and editing the chart with Libo 3.3.2, the chart also disappers.

Creating the same chart with 3.3.2 and editing with 3.4 Beta3 works fine for me.

So i think it is an OS issue.
Comment 3 Petr Mladek 2011-05-11 08:52:35 UTC
Kohei, could you please have a look?

It happened also with LO-3.3, so it is an old bug => it can't block the release => slightly lowering severity
Comment 4 Kohei Yoshida 2011-05-11 08:55:36 UTC
Same issue as Bug 36339, and basically no clue what's going unless someone can tell me how those charts were created in the first place.
Comment 5 Kohei Yoshida 2011-05-11 11:03:02 UTC

*** This bug has been marked as a duplicate of bug 36339 ***
Comment 6 Commit Notification 2014-03-08 13:37:09 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=79ed9ebb6ed64a10928ad3a10924708c312703a3

fix OOXML validation error, related fdo#36731



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.