Bug 36433 - Allow to disable autostart when opening pps files
Summary: Allow to disable autostart when opening pps files
Status: RESOLVED DUPLICATE of bug 45233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
(earliest affected)
Hardware: All All
: low enhancement
Assignee: Not Assigned
QA Contact:
Depends on:
Reported: 2011-04-20 11:08 UTC by fabianhm
Modified: 2012-08-14 18:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description fabianhm 2011-04-20 11:08:20 UTC
Allow to disable autostart when opening pps files is required in some instances. (that is being able to open a pps as if it were a ppt or open a pps in edit mode rather than presentation mode).
Like when user desires to modify a presentation he/she is receiving before see it in presentation mode.
And if a presentation is opened directly from a browser, ESCAPE should change presentation mode for edit mode instead of closing the file.
Comment 1 E PROST 2011-05-07 11:01:01 UTC
Another use case: when a pps is attached to a mail, it is often desirable to be able to have an overall look at the slides, going easily back and forth, ... This is only possible in "edit mode".

As of now, this requires to save the file on disk, rename it to .ppt, open, delete when done.

This is not user-friendly nor easy for "standard users".

Btw, for Windows, I have read that some people advise to use the "ftype" command to launch soffice.exe instead of simpress.exe when opening pps file: on WXP, this does not work, pps files are still opened in presentation mode, not edit mode.

Tested on WXP + LO 3.3

> assoc .pps

> ftype OpenOffice.org.Pps
OpenOffice.org.Pps="C:\Program Files\LibreOffice 3\program\soffice.exe" -o "%1"

Comment 2 eric f 2011-07-01 20:25:00 UTC
I vote for getting an option to ignore the slideshow because of the .pps extension. Most of the time .pps are sent by email (and so badly designed with the useless animations), so it's not user-friendly to have to save the file, rename it to .ppt and then launch it from the file explorer or from command-line.
Comment 3 Björn Michaelsen 2011-12-23 12:04:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Nuno J. Silva 2012-02-09 13:10:57 UTC
Confirmed (as requested) with 
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Running on Windows NT 5.1 SP3 x86

Also reproducible with 
LibreOffice 3.4.5 
OOO340m1 (Build:502)
Running on Gentoo GNU/Linux amd64


LibreOffice 3.4.3 
OOO340m1 (Build:302)
Running on Gentoo GNU/Linux amd64

I think the best way to sort this out would be adding an option, e.g. "libreoffice --start-slideshow", and use that when setting the default file type associations in the various systems users for some reason expect .pps to start in slideshow mode.

Now, please provide something easier than having to grep through all the filter names to find out what filter name should be used to open .pps as .ppt...
Comment 5 Rob Snelders 2012-05-28 08:22:40 UTC

*** This bug has been marked as a duplicate of bug 45233 ***