Bug Hunting Session
Bug 45233 - Impossible to edit ppsx - auto presentations from Powerpoint
Summary: Impossible to edit ppsx - auto presentations from Powerpoint
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Linux (All)
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:4.2.0 target:4.1.2
Keywords:
: 33723 36433 40069 45504 56765 61772 68542 88190 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-01-25 08:42 UTC by Cor Nouws
Modified: 2015-02-16 12:58 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-01-25 08:42:25 UTC
- presentation with ppsx extension
- rename to pptx
- open
  > still opens in presentation mode
  > unable to edit


I have received and ppsx presentation.
Analogue to pps it will open automatically in presentation mode.

Now the trick with pps was (what I understood) that one can simply rename that to ppt, so that it can be opened and edited.
However, renaming ppsx to pptx does not do that trick.
Comment 1 Cor Nouws 2012-01-25 08:43:54 UTC
btw: checked in LO 3.3.x and 3.4.x
Same there.
So prolly something that hasn't been implemented yet in the filter ?
Comment 2 bradley 2012-03-12 05:39:31 UTC
Same here. 
Checked in 3.5.0.
Comment 3 Rob Snelders 2012-05-28 08:22:20 UTC
*** Bug 45504 has been marked as a duplicate of this bug. ***
Comment 4 Rob Snelders 2012-05-28 08:22:40 UTC
*** Bug 36433 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2012-11-29 20:21:52 UTC
 bug 49873 is a duplicate too
Comment 6 Cor Nouws 2012-11-29 20:54:28 UTC
Looks as if the behaviour is improved.
In any case:
 - I take a .pps file.
 - rename to .ppt 
 > it opens fine in 3.6.3 and 4.0Alpha1

Can the others in cc pls check and give their results :-)
thanks
Comment 7 Jorendc 2012-11-29 21:17:07 UTC
Tested with Ubuntu 12.10 Dutch; LibreOffice 3.6.2.2 (Build-id: 360m1(Build:2)).

I created a simple .pps file and saved it to my desktop: double click on it -> autoplay and can't edit it.

Then I renamed the file to a .ppt file: double click -> editor. That's the correct behavior.

When I save a new test file to .ppsx: double click on it -> NO autoplay. The editor window appears. This is a bug?

When I rename the .ppsx file to a .ppt file I get the following error (translated): The file 'test.ppt' is damaged and can't be opened. LibreOffice can try to repair the file. The damaging could be the result of a manipulation of the document or the structural damage of the document during the data transmission. Bla Bla Bla. Must LibreOffice repair the file?

When I click on yes I got the message (translated): Incompatible version. The file has got the wrong version.

Same happens when I download another .ppsx file from another bug (just random search on freedesktop. For example the attached file of https://bugs.freedesktop.org/show_bug.cgi?id=56765)

Kind regards,
Joren
Comment 8 Jorendc 2012-11-29 21:19:56 UTC
Addition information:
The .ppsx file download from https://bugs.freedesktop.org/show_bug.cgi?id=56765 starts correct with autoplay (=not editable). When I rename that file to .ppt, the same error occur as I described in comment 7.
Comment 9 Jorendc 2012-11-29 21:32:05 UTC
I opened a new bug https://bugs.freedesktop.org/show_bug.cgi?id=57703 (.ppsx file created with LibreOffice doesn't Autoplay)
Comment 10 Samuel Mehrbrodt (CIB) 2013-04-25 16:03:07 UTC
*** Bug 33723 has been marked as a duplicate of this bug. ***
Comment 11 Cor Nouws 2013-05-28 21:26:02 UTC
(why are some reporters so modest that they don't add bugs to MAB's ...)
Comment 12 mathieu.westphal 2013-07-06 11:03:01 UTC
A simple work around is to use the -convert-to option of libre office.

libreoffice -convert-to ppt doc.ppsx

give you a doc.ppt fully editable
Comment 13 Samuel Mehrbrodt (CIB) 2013-07-06 14:29:18 UTC
I'm sponsoring this: http://www.freedomsponsors.org/core/issue/294/impossible-to-edit-ppsx-and-pps-auto-presentations-from-powerpoint

Please consider throwing some money in.
Comment 14 Petr Mladek 2013-07-08 09:45:53 UTC
Comment #1 states that it probably newer worked => removing the regression keyword and bibisectrequest flag. Also I move it to 3.6 MABs which are the olders supported.

Note that it is MAB only if the problem is in the filter detection. If we need to do some UI or another bigger changes, we should remove it from MABs and track it a feature request.
Comment 15 Cor Nouws 2013-07-08 12:14:26 UTC
Hi Peter,
As per comment #6 and comment #7 the opening/editing of a pps by renaming to ppt does work again. 
So the regression part (what was in the summary with " AND pps " ) indeed is solved. Changing summary accoringly (should have done that before..)
.
I guess it's  problem of the filter, so that valids for MAB listing.
Comment 16 Samuel Mehrbrodt (CIB) 2013-07-11 10:17:35 UTC
I published a patch on Gerrit: https://gerrit.libreoffice.org/4827

I removed the Code that closed Impress after closing the Presentation. So it is now possible to edit these presentations, even without renaming etc.
Comment 17 Samuel Mehrbrodt (CIB) 2013-07-11 10:18:00 UTC
*** Bug 40069 has been marked as a duplicate of this bug. ***
Comment 18 Samuel Mehrbrodt (CIB) 2013-07-12 14:12:24 UTC
*** Bug 56765 has been marked as a duplicate of this bug. ***
Comment 19 Petr Mladek 2013-07-15 15:12:58 UTC
I add an usability guy into CC.

I am not sure if we really want to keep the document opened for edition on closing. I guess that the autoplay files are used by speakers that do not want to be interrupted by the LO UI at all.

Another solution would be to fix the opening more:

  + use autoplay only for files that are opened using the command line or by clicking the document 
     on the desktop. It means the default action => autoplay for this file type

  + use edit mode when you open the presentation using the "File/Open" dialog in running office.
     It means that you are already in the LibreOffice editor mode and you probably want to edit it.

See also http://www.dailygyan.com/2008/04/how-to-edit-powerpoint-show-pps-or-ppsx.html
Comment 20 Samuel Mehrbrodt (CIB) 2013-07-17 16:06:17 UTC
I submitted a new patch which has this behavior:

If the presentation is played until the end, Impress will be closed.
If the presentation is cancelled (ESC or Context Menu), the editor window is shown and you can edit the presentation.
Comment 21 Johnny_M 2013-07-17 22:29:21 UTC
(In reply to comment #20)
> I submitted a new patch which has this behavior:
> 
> If the presentation is played until the end, Impress will be closed.
> If the presentation is cancelled (ESC or Context Menu), the editor window is
> shown and you can edit the presentation.

Thank you very much! But, to prevent confusion with people used to MS PowerPoint, I personally would prefer the behavior described in the comment 19. I.e.:

- When I double-click a PPS(X) in Win explorer, I want it to "play back" the presentation and close at the end or if I cancel it preliminarily with ESC, etc. (E.g. if I opened a wrong presentation.)

- When I need to edit a PPS(X), I open it from within LO.

Thank you!
Comment 22 Commit Notification 2013-07-29 11:57:32 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8608fddf09bc243af63f3721443f518138f9be0

fdo#45233 Allow editing pps/ppsx Autoplay Presentations



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2013-08-13 14:23:50 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=38f11fdb08249a6cf7140ee74016cd69f28e289a&h=libreoffice-4-1

fdo#45233 Allow editing pps/ppsx Autoplay Presentations


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 ign_christian 2013-08-26 02:32:00 UTC
*** Bug 68542 has been marked as a duplicate of this bug. ***
Comment 25 ign_christian 2013-08-26 02:32:24 UTC
*** Bug 61772 has been marked as a duplicate of this bug. ***
Comment 26 Alex Thurgood 2015-01-09 14:51:50 UTC
*** Bug 88190 has been marked as a duplicate of this bug. ***
Comment 27 Matthew Francis 2015-02-16 12:58:12 UTC
*** Bug 88190 has been marked as a duplicate of this bug. ***