Bug Hunting Session
Bug 88190 - FILEOPEN Can't Edit .PPS Files
Summary: FILEOPEN Can't Edit .PPS Files
Status: RESOLVED DUPLICATE of bug 45233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-08 04:04 UTC by Mansour
Modified: 2015-02-16 12:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mansour 2015-01-08 04:04:01 UTC
PowerPoint files with extension .pps are supposed to directly open in Slide Show mode. LibreOffice correctly opens .pps files in slide show mode, but when the user presses Esc key to exit the slide show, LibreOffice doesn't exit the slide show and go to the editing mode as one would expect. Instead, it completely closes the file! This behavior prevents the user from editing pps or converting them to LibreOffice format. The user must rename the .pps files to .ppt in order to be able to open and edit them.

To reproduce:

1. Open a .pps presentation in LibreOffice.
2. The program opens in Slide Show mode.
3. Press Esc key to exit Slide Show and retune to editing mode.
4. The program fails to go to the editing mode and closes the opened .pps completely.

To overcome this bug:

1. Rename .pps to .ppt
2. Open in LibreOffice.

Thank you.
Comment 1 Alex Thurgood 2015-01-09 14:44:43 UTC
Duplicate, just need to find the original report
Comment 2 Alex Thurgood 2015-01-09 14:51:50 UTC

*** This bug has been marked as a duplicate of bug 45233 ***
Comment 3 Alex Thurgood 2015-01-09 14:59:27 UTC
Testing with ppsx file from bug 56765 shows that pressing Esc key when presentation is in progress opens the presentation in Edit mode, but LO subsequently crashes. Will try and get a trace.

Confirming
Comment 4 Alex Thurgood 2015-01-09 15:00:17 UTC
Rgression, as this was previously fixed
Comment 5 Alex Thurgood 2015-01-09 17:49:49 UTC
Unfortunately, attempting to debug with lldb has not got me much further. When the presentation causes the window to close after pressing Esc, lldb doesn't regadin control, so I can't input any commands, and LO keeps running. All I see when I shut down LO is the following :

warn:sal.osl:84970:1:sal/osl/all/debugbase.cxx:116: unexpected number of N9slideshow8internal8BaseNodeE: 2; Expected: 0
warn:legacy.osl:84970:1:unotools/source/config/configmgr.cxx:166: OSL_ASSERT: items_.empty()
Comment 6 Matthew Francis 2015-01-25 14:21:09 UTC
Adding Whiteboard:bibisectRequest

Whoever attempts this, be careful that this appears to have been fixed/broken more than once. We're looking for the most recent breakage
Comment 7 Matthew Francis 2015-02-16 12:58:12 UTC
In fact on further investigation this has never worked as requested.

Bug 45233 introduced a context menu to go to the editor ("Edit Presentation"), but didn't do anything to the behaviour of pressing Escape. It is also suggested in bug 45233 comment 21 that the current behaviour of closing on Escape is what Powerpoint does.

I don't reproduce any crash on 4.4.0.3/OSX,Linux, and if there is one that's a separate issue.


To edit a .pps, just use the mouse context menu - Edit Presentation

*** This bug has been marked as a duplicate of bug 45233 ***