Bug Hunting Session
Bug 56765 - LibreOffice Impress cannot import and show this .ppsx presentation with all features
Summary: LibreOffice Impress cannot import and show this .ppsx presentation with all f...
Status: RESOLVED DUPLICATE of bug 45233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-05 10:45 UTC by Răzvan Sandu
Modified: 2013-12-17 13:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Testcase file - Microsoft .ppsx presentation (564.89 KB, application/vnd.openxmlformats-officedocument.presentationml.slideshow)
2012-11-05 10:45 UTC, Răzvan Sandu
Details
strace log when opening testcase file (712.41 KB, application/x-bzip2)
2013-02-24 05:50 UTC, Bentley Oakes
Details
PDF print result from PPV14 (180.72 KB, application/pdf)
2013-07-11 12:26 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Răzvan Sandu 2012-11-05 10:45:59 UTC
Created attachment 69554 [details]
Testcase file - Microsoft .ppsx presentation

Hello,

The attached .ppsx presentation cannot be imported and opened in LibreOffice 3.6.3 with all features (no matter wahat platform).

Please open it in Microsoft Office 2007 or 2010 and compare results.

The attached file may be used as a testcase.

Version: Version 3.6.2.2 (Build ID: 360m1(Build:2))
Comment 1 Bentley Oakes 2013-02-24 05:50:12 UTC
Created attachment 75436 [details]
strace log when opening testcase file
Comment 2 Bentley Oakes 2013-02-24 05:53:48 UTC
I reproduced this bug on lodev4.0_4.0.1.0-1_amd64. Ubuntu 12.10 with Unity.

When opening this file in Impress, after one second or so it automatically goes into fullscreen/presentation mode. If ESC is pressed, Impress will immediately close.
Comment 3 Samuel Mehrbrodt (CIB) 2013-07-10 20:00:19 UTC
Is the problem that you cannot edit it or that some things are not displayed as in MS Office?
Comment 4 Răzvan Sandu 2013-07-11 07:03:43 UTC
Hello,

One can neither see nor edit the content (or a part of it).

As for dynamic or multimedia content (such as animations in the file or background music included in it), it is a whole mess.

Please open the testcase file above ("Testcase file - Microsoft .ppsx presentation") în native MS Office 2010 AND LibreOffice and compare results.

Thanks a lot,
Răzvan
Comment 5 ign_christian 2013-07-11 07:12:25 UTC
Seems like duplicate to Bug 45233
Comment 6 Samuel Mehrbrodt (CIB) 2013-07-11 09:07:27 UTC
Hi Răzvan,

I can see most of the Presentation in LibreOffice 4.0.
Please try again with the newest LibreOffice version.
Also, could you upload a PDF of the original Presentation? I don't have MS Office here.

@ign_christian
If it's about editing the presentation, it is a duplicate. But if it's about wrongly displayed content, it's not.
Comment 7 ign_christian 2013-07-11 12:26:09 UTC
Created attachment 82336 [details]
PDF print result from PPV14

Hi Samuel, I think Răzvan reported many bugs here:
- can't edit -> Bug 45233
- no sound -> Bug 50342
- some contents different (please see attached file) -> I haven't searched for possible duplicates
Comment 8 ign_christian 2013-07-11 12:28:42 UTC
Sorry I forgot to mention that I've tested with LO 4.0.4.2 (Win7 32bit)
Comment 9 Samuel Mehrbrodt (CIB) 2013-07-12 08:46:41 UTC
Hm I don't think this report is useful to developers then.

It would be better to open a bug for each error you see in the Presentation with _one_ Slide showing the error.

Christian, should we close this bug as INVALID?
Comment 10 ign_christian 2013-07-12 09:10:11 UTC
Perhaps just mark as duplicate to one of related bug reported? 
Sample file attached might be a good test case.
Comment 11 Samuel Mehrbrodt (CIB) 2013-07-12 14:12:24 UTC
Răzvan, please open a separate bug for each problem you see in your presentation as mentioned in Comment 9.
This bug report is too general and of no use, so I'm closing it.

*** This bug has been marked as a duplicate of bug 45233 ***