Bug Hunting Session
Bug 40069 - FILEOPEN: Particular.pps does not loose autostart after rename to Particular.ppt
Summary: FILEOPEN: Particular.pps does not loose autostart after rename to Particular.ppt
Status: RESOLVED DUPLICATE of bug 45233
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-13 23:22 UTC by Fiable.biz
Modified: 2013-07-11 10:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PPS document, cannot enter edit mode (99.00 KB, application/vnd.ms-powerpoint)
2011-08-15 02:00 UTC, Jeffrey
Details
Test kit, see Comment 4 (24.21 KB, application/zip)
2011-08-18 20:46 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fiable.biz 2011-08-13 23:22:39 UTC
When I open a *.pps document, its starts automatically in slide show mode, and I can't edit it. If I press "escape" or right-click and choose "End show", then the file gets closed. If I change the exension to ".ppt", then Presentation doesn't start automatically in slide show and I can edit it.
This bug had been described for OpenOffice.org 3 there:
https://qa.mandriva.com/show_bug.cgi?id=61554
Comment 1 Jeffrey 2011-08-15 02:00:19 UTC
Created attachment 50218 [details]
PPS document, cannot enter edit mode

Confirmed on LibreOffice 3.4  340m1(Build:103) for OpenSuse Linux.

I have had this problem as well, after I accidentally saved a file under .pps. It can be very frustrating. So the first time you save it (under save as) the file is ok. You have access to edit mode in impress while under the name of .pps. But after you close the document and try to open the .pps file again, you will automatically enter view presentation mode. Try on the attached document.

Thanks.
Comment 2 Rainer Bielefeld Retired 2011-08-16 23:46:23 UTC
[Reproducible] with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]" 

That's the suchness of a .pps: It starts immediately with the presentation.
It was a bug in OOo (Issue#52755 - .pps files should open in presentation mode as with PowerPoint) that presentation did not start immediately. A separate "Impress Runner extension" is required for OOo. The issue still is unfixed for OOo, so With OOo 3.3.1 and OOo 3.3 I (only) can open Jeffrey's sample in edit mode and have to start it manually.

It seems we have (at least) 2 problems here.

a) I can not stop .pps reaching edit mode directly from slide show.
When I create a single slide Presentation.ppt with LibO and rename it to Presentation.pps (in WIN Explorer, it will autostart in LibO as expected, and I can stop it with <esc> or <-> as expected, and the slide show will not only stop, but also the document will be closed. 
That might be intended. 
It's not a problem, I simply have to rename the document back to Presentation.ppt and that can be edited.
That rename trick also works with a Presentation.ods saved as Presentation.pps. Renaming works, Presentation.ppt can be edited with LibO.
That rename trick also works with a Presentation.ppt (created with LibO saved as Presentation.pps. Renaming works, Presentation.ppt can be edited with LibO.

But a backdoor to get the edit mode directly would be nice. I do not know whether that is possible with Powerpoint.

b) With Jeffrey's sample document the rename trick does NOT work, 67.ppt will still start automatically the slide show.

Here we should limit investigations to problem "b", please see modified Subject. For the missing "backdoor" I will submit a separate enhancement request.

@Jeffrey:
Any idea concerning that problem "b"? Can you reproduce my observations concerning renaming?
Comment 3 Rainer Bielefeld Retired 2011-08-17 00:51:43 UTC
Strange! I wanted to create a test kit with some documents to reproduce my results from Comment 2, and now I can nno longer open my documents renamed from .ppt to .pps and back to .ppt. 

That might be the result from having running parallel some OOo and LibO instances, I sometimes observe interferences. 

I will have to do some further investigation later after PC reboot
Comment 4 Rainer Bielefeld Retired 2011-08-18 20:43:10 UTC
New attempt with "LibreOffice 3.4.3 RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:301)]" 

1. Created and saved mytest343.odp and closed
   from LibO file dialog: opens in edit mode
   dobuleclick WIN Exp.: opens in edit mode
2. Saved from LibO as mytest343.ppt and closed
   from LibO file dialog: opens in edit mode
   rightclick WIN Exp.: opens in presentatioon Mode,  IMHO that's wrong
3. Saved mytest343.ppt from LibO as mytest343.pps and closed
   from LibO file dialog: opens in presentation mode
   rightclick WIN Exp.: opens in presentation mode
4. Rename  mytest343.pps in Win Explorer to mytest343 - Kopie.ppt 
   from LibO file dialog: opens in presentation mode,   IMHO that's wrong
   rightclick WIN Exp.: opens in presentation mode,    IMHO that's wrong
10. closed all documents
12. Tried again to open  mytest343.ppt
   from LibO file dialog: opens in presentation mode,   IMHO that's wrong
   rightclick WIN Exp.: opens in presentation mode,    IMHO that's wrong
   Compare with result from step 2!
20. Exit LibO, try mytest343.ppt
    rightclick WIN Exp.: opens in presentation mode,    IMHO that's wrong
    
    Exiting exits LibO  -  Start to LibO Start Center
22. open mytest343.ppt
    from LibO file dialog: opens in presentation mode,   IMHO that's wrong
    
That's terrible, since step 4 my LibO lost ability to edit .ppt, so -> Major
I did not try whether reboot helps.

Until a confirmation of that effect I hesitate to modify Subject line due to my latest results.
Comment 5 Rainer Bielefeld Retired 2011-08-18 20:46:58 UTC
Created attachment 50366 [details]
Test kit, see Comment 4

@Radek:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 6 Björn Michaelsen 2011-12-23 13:25:42 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 7 euug3576.mini 2012-03-24 23:22:24 UTC
After renaming a ppsx to pptx I was able to get it to open in edit mode by

1. unzipping
2. editing [Content_Types].xml to replace application/vnd.openxmlformats-officedocument.presentationml.slideshow.main+xml with application/vnd.openxmlformats-officedocument.presentationml.presentation.main+xml
3. re-zipping
Comment 8 ign_christian 2013-06-05 16:03:44 UTC
This bug has not been touched by for a long time. 
Just confirming, is this bug still ASSIGNED?
Comment 9 Samuel Mehrbrodt (CIB) 2013-07-11 10:18:00 UTC
The problem is the same as in Bug 45233, so I mark this as duplicate.

*** This bug has been marked as a duplicate of bug 45233 ***