Download it now!
Bug 36457 - 64-bit deb package does not install "dependency problems prevent configuration"
Summary: 64-bit deb package does not install "dependency problems prevent configuration"
Status: CLOSED DUPLICATE of bug 36551
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-21 06:12 UTC by Susan Cragin
Modified: 2011-04-24 14:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LO installation terminal log into empty /opt file (27.18 KB, text/x-log)
2011-04-21 06:12 UTC, Susan Cragin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Susan Cragin 2011-04-21 06:12:48 UTC
Created attachment 45915 [details]
LO installation terminal log into empty /opt file

The current 3.4.0-103 amd-64 version does not install correctly with deb packages. 

I did this twice, once trying to over-write my last installation, and again after removing the /opt/libreoffice folder. 

I'm no expert, but I believe the permissions may be set wrong.
Comment 1 Susan Cragin 2011-04-22 03:59:36 UTC
I think I've found the problem. 
Depends: libobasis3.4-core01 but it is not installable

Lintian check results for /home/susan/Downloads/DEBS/libobasis3.4-core01_3.4.0-103_amd64.deb:
E: libobasis3.4-core01: maintainer-address-missing The Document Foundation
Comment 2 Christian Lohmaier 2011-04-24 14:53:57 UTC
not a permission problem, but a matter of a packaging bug. For the time being, you have to manually uninstall version 3.3.x of LibreOffice before installing the 3.4beta version. Removing the /opt/libreoffice directory without uninstalling the libreoffice3.3 packages is not enough, as the installation process consults its database, and not just the on-disk files.

You cannot have 3.3.2 and 3.4.0beta installed alongside each other (at least not using the default installation method, you would have to manually extract the packages to a different target installation)

See bug 36551 for details

*** This bug has been marked as a duplicate of bug 36551 ***
Comment 3 Christian Lohmaier 2011-04-24 14:54:27 UTC
closing duplicate.