Download it now!
Bug 36539 - Option to disable/enable AutoCorrect with single click
Summary: Option to disable/enable AutoCorrect with single click
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-24 03:30 UTC by Ihar Filipau
Modified: 2014-01-26 14:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ihar Filipau 2011-04-24 03:30:00 UTC
For writing tech documentation, as well as undisturbed touch-typing, I generally disable almost all of the AutoCorrect options.

The problem arises when I want to enable them all again, for example, because I want the options for my current task or my PC is used by another user. Since there are many of the options, it becomes a chore going through several tabs and picking and selecting the options I might need.

To accommodate both the scenarios - writing without auto-correct and writing with auto-correct - I propose to add a global switch to enable/disable auto-correct. (E.g. in GUI of the "AutoCorrect Options..." dialog, before the language label/combobox.)
Comment 1 Björn Michaelsen 2011-12-23 12:02:34 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Ihar Filipau 2011-12-24 05:51:36 UTC
3.5.0b2, Windows x86, the issue is still present.

Changing status to NEW as per the spambot instructions.
Comment 3 manj_k 2011-12-26 06:26:45 UTC
The current possibilities:

Usually, you can switch on/off 'AutoCorrect' via
menu 'Format > AutoCorrect > While Typing'.

You might apply a shortcut key via
Tools > Customize > Keyboard
Category: Format
Function: While Typing

You might add a command to a toolbar via
Tools > Customize > Toolbars > ... > Add...
Category: Format
Commands: While Typing
You might apply an icon for the command via
Tools > Customize > Toolbars > ... > Modify > Change Icon...

Sample:
http://dl.dropbox.com/u/19264180/LibO/switch_autocorrect.png
;)
Comment 4 Ihar Filipau 2011-12-26 07:17:28 UTC
> Usually, you can switch on/off 'AutoCorrect' via menu 'Format > AutoCorrect > While Typing'.

manj_k, that seems to be it. I did a short test and the toggle seem to do what I want.

More info I have found on: http://help.libreoffice.org/Writer/Turning_Off_AutoCorrect - but it is not linked to any 'Help' button from the 'AutoCorrect Options...' dialog. To guess the option existence I should have opened the 'Format' menu, but alas I pretty much always use the right-click (or application button) pop-up menu, which is almost exact duplicate of the 'Format' menu.

My major gripe is that the toggle lacks description. 'Customize' dialog as before lacks a search/filter function (for 'Keyboard tab' and 'Toolbars tab > Toolbar Content > Add... > Add Commands' dialog), something I have complained already about in OO.o 1.x times. Description + search function would have given me a chance to find it on my own.

Otherwise, as the issue reported by me is resolved, I'm closing the ticket with RESOLVED.
Comment 5 manj_k 2012-05-08 05:17:44 UTC
Closed