Bug Hunting Session
Bug 36545 - Crash when selecting target after inserting hyperlink to database document (.odb)
Summary: Crash when selecting target after inserting hyperlink to database document (....
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-24 11:01 UTC by pierre-yves samyn
Modified: 2011-12-23 13:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot before crash (16.67 KB, image/png)
2011-04-24 11:01 UTC, pierre-yves samyn
Details
apple stacktrace for crash after inserting hyperlink to ODB document and then choosing target (50.85 KB, text/plain)
2011-05-07 09:23 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2011-04-24 11:01:09 UTC
Created attachment 46026 [details]
Screenshot before crash

Hello

My environment: XP SP3 Libo 3.3.2 - 330m19 (Build: 202)

Reproducible crash, Steps to Reproduce:

1. Create a new document (writer, calc ...)
2. Insert > Hyperlink
3. Choose the item document (not Internet, Mail&News or New document)
4. Enter the path to an existing database file (.odb) (hsql)
5. Click on the button : "Target in document" 
6. Crash

Expected Results: 

- Either displaying potential target objects of a link
- Either a message "can not open this file"

Same crash with OOo 3.2.1 & 3.3.0 RC10 

A search of OOo Issues gives this old resolved in principle:
http://openoffice.org/bugzilla/show_bug.cgi?id=71549

Best regards
Comment 1 Alex Thurgood 2011-05-06 05:08:21 UTC
Hi Pierre-Yves,

I can not confirm with either 3.3.2 or 3.4.0b3 on Mac OSX, the insert of the link to the file works without crashing. Could you try with the latest beta for Windows and see if you still have the problem ? Perhaps this is a Windows specific problem ?


Thanks,

Alex
Comment 2 Alex Thurgood 2011-05-06 05:08:51 UTC
More info required.

Alex
Comment 3 pierre-yves samyn 2011-05-07 02:45:02 UTC
Hello Alex

Thank you for your answer and your tests.

I tested the latest pre-release available yet, buildid=300m103(Build:4) and i got the same problem (with XP).

I insist that the crash occurs after clicking on the the button : "Target in document" 

I'm curious: could you specify which objects potentially target of a link are displayed in the window (forms, reports, queries, tables) ?


Nota : This crash has been reproduced (discuss@fr.libreoffice.org) by others with XP, Windows 7

So you may be right, perhaps this is a Windows specific problem ?
Comment 4 Alex Thurgood 2011-05-07 09:19:37 UTC
Hi Pierre-Yves,

Ah, OK, I misunderstood, I just inserted a link to the ODB document, without choosing a target.

When I choose a target, I get an error message in a dialog that says "Can not open document", then a small pause before the cursor switches to the famous Mac "beach ball" indicating a hung app, then LibO crashes, and Apple trace manager appears.

I am enclosing stacktrace and confirming.

This should be added to the list of most annoying bugs for the 3.4 release.

Alex
Comment 5 Alex Thurgood 2011-05-07 09:23:01 UTC
Created attachment 46425 [details]
apple stacktrace for crash after inserting hyperlink to ODB document and then choosing target
Comment 6 Alex Thurgood 2011-05-07 09:23:53 UTC
I will need to test this on beta4, but haven't had time to download yet.

Alex
Comment 7 Alex Thurgood 2011-05-07 09:26:32 UTC
Changing platform to all.

Alex
Comment 8 Alex Thurgood 2011-05-07 09:32:21 UTC
Note that this also causes the following apps to crash :

- NeoOffice 3.1.2 patch7
- OpenOffice.org 3.2.1
- OOo-dev 3.4.0 beta1


Alex
Comment 9 Alex Thurgood 2011-05-09 05:45:24 UTC
Confirming also on 3.4b4.

Alex
Comment 10 Alex Thurgood 2011-05-09 05:48:04 UTC
Corrected bug title.

Alex
Comment 11 Noel Power 2011-05-09 06:15:17 UTC
reproduced it on xp too, btw same in OOo m106
Comment 12 Alex Thurgood 2011-06-04 01:24:58 UTC
There are some ongoing tests on the French user list with respect to similar buggy behaviour, and it may be that this bug will extend to more than just inserting links to ODB files, but any file in general. If they are confirmed, I will adjust the title accordingly.


Alex
Comment 13 ribotb 2011-06-04 01:31:10 UTC
I reproduced the bug with Windows 7.

Bernard
Comment 14 Jean-Baptiste Faure 2011-06-04 11:20:11 UTC
(In reply to comment #12)
> There are some ongoing tests on the French user list with respect to similar
> buggy behaviour, and it may be that this bug will extend to more than just
> inserting links to ODB files, but any file in general. If they are confirmed, I
> will adjust the title accordingly.
> 
> 
> Alex

Hi Alex,

The problem discussed on [fr-discuss] does not occur on XP, vista and seven only.

Long life to LibreOffice. JBF
Comment 15 ribotb 2011-06-05 01:33:48 UTC
Hi, Jean-Baptiste

I don't agree, the problem occurs also under Windows XP. Already exists with LibO331.

Bernard
Comment 16 Rainer Bielefeld Retired 2011-06-12 00:35:02 UTC
I modified Status to Assigned due to facts.
Comment 17 Don't use this account, use tml@iki.fi 2011-06-12 01:07:34 UTC
I modified Status to New due to facts.
Comment 18 Jan Holesovsky 2011-07-01 02:12:27 UTC
Fixed, and sent a patch to the mailing list for review.
Comment 19 Björn Michaelsen 2011-12-23 13:26:07 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.