Bug 36584 - UI FORMULAEDITOR: no influence of toolbar button 'Formula cursor'
Summary: UI FORMULAEDITOR: no influence of toolbar button 'Formula cursor'
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.2 RC2
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2011-04-25 06:57 UTC by Rainer Bielefeld Retired
Modified: 2017-10-17 23:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-04-25 06:57:19 UTC
With "LibreOffice 3.4Beta2  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:1)]" I can't see any influence of the "Formula cursor" toolbar button due to <http://help.libreoffice.org/Math/Formula_Cursor>. I tried formula in WRITER document and also independent Formula document.

Steps to reproduce:
0. Start LibO
1. Open new Math document form Start Center
2. Type "A = B + C" into command pane (pane at the bottom of the Window)
   "A = B + C" appears in command pane and also in document body, Cursor
   flashes at the end of the formula in the command pane
3. Click Formula Cursor button (button becomes "active" view)
   expected: formula cursor appears in formula in the text body behind "C"
   actual: nothing, also if you click somewhere else into the formula in the
           command pane. Formula cursor will not appear

11. Click somewhere into the formula in the document body
    as expected, formula cursor appears at the click
12. Click Formula Cursor button (button becomes "inactive" view)
    expected: formula cursor disappears in formula in the text body
    actual: nothing, also if you click somewhere else into the formula in the
           command pane. Formula cursor will not appear

I did not find any reaction to changing button status
Comment 1 Regina Henschel 2011-04-26 10:11:07 UTC
Do you have checked "Enabled experimental features"? Then you get the new way to directly edit a formula in the object frame.
Comment 2 Rainer Bielefeld Retired 2011-04-26 11:06:39 UTC
Yes! And now I tested with unchecked 'experimental features'. Then the button will enable the dotted rectangle border around the formula parts as I know them from OOo.

So the problem seems to be:
With enabled "experimental features" the button seems to be useless and should not be shown.

@Regina:
Can you reproduce my observations?
Comment 3 Regina Henschel 2011-04-26 12:34:49 UTC
Yes, I observe the same. It should be solved together with the new kind of formula editing.
Comment 4 Rainer Bielefeld Retired 2011-04-27 01:15:27 UTC
@Jonas:
Can you please check?
Comment 5 Jonas Finnemann Jensen 2011-04-28 03:35:14 UTC
I don't think there's anything we can use the "Formula cursor"-toolbar-button for in visual editing mode. It should probably be removed or turned in to a tri-state button for switch between all three modes...

Anyway, thanks for reporting... It's one of those things that needs to be cleaned up... Which I plan to start doing when I'm done with my bachelor project :)
Comment 6 Jonas Finnemann Jensen 2013-08-15 16:46:25 UTC
Unassigning myself... as I haven't been working on the formula editor for a long time.

Sorry I didn't get around to do this earlier.
Comment 7 Thomas Hackert 2014-03-08 18:02:38 UTC
Hello Rainer, *,
I can confirm this issue with LO Version: 4.2.2.1 Build-ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f with installed Germanophone lang- as well as helppack under Debian Testing i386, so I changed platform to "All" ... ;) I have activaed experimental features – as Regina has recommended in comment #1, but this does not change anything ... :(
Sorry for the inconvenience
Thomas.
Comment 8 Marina Latini (CIB) 2014-04-23 10:47:01 UTC
Confirmed for LibO installed from downloaded .deb packages with Italian language.
Version: 4.2.4.1 x86_64
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515
OS:  Ubuntu 13.10 x86_64 saucy

The formula cursor doesn't works when experimental features are enabled. In this case, the cursor doesn't jump to the corresponding area and the portion of the formula isn't marked with a thin border when the formula cursor is active.
When experimental features are disabled, the formula cursor works fine.
Comment 9 Marina Latini (CIB) 2014-05-25 21:26:22 UTC
Confirmed with LibO installed from downloaded .deb packages with Italian language and fresh user profile.
Version:  4.3.0.0.beta1 x86_64
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f
OS:  Ubuntu 13.10 x86_64 saucy

The cursor doesn't jump to the corresponding area and the portion of the formula isn't marked with a thin border when the formula cursor is active.
When experimental features are disabled, the formula cursor works fine.
Comment 10 Julien Nabet 2014-12-05 13:55:30 UTC
Michael: commenting the line 178 if block here seems to solve this problem:
178         if (IsInlineEditEnabled()) {
179             pViewShell->GetDoc()->GetCursor().MoveTo(this, aPos, !rMEvt.IsShift());
180             return;
181         }
182         const SmNode *pNode = 0;
183         // if it was clicked inside the formula then get the appropriate node
(see http://opengrok.libreoffice.org/xref/core/starmath/source/view.cxx#178)

However, I must recognize I don't know what's the purpose/how does work InlineEdit part.
Noticing http://cgit.freedesktop.org/libreoffice/core/commit/?id=37ef1e8c958abc81bb87c2c12f35c885d27fead0, I thought you might have some thoughts.
Comment 11 Julien Nabet 2014-12-05 13:56:54 UTC
eg of bt which helped me to find the quoted part code:
#0  SmViewShell::IsInlineEditEnabled (this=0x27dd3c0) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:2056
#1  0x00002aaac869bc71 in SmGraphicWindow::IsInlineEditEnabled (this=0x27dd430) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:227
#2  0x00002aaac869c04f in SmGraphicWindow::ShowCursor (this=0x27dd430, bShow=true) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:305
#3  0x00002aaac869c2e3 in SmGraphicWindow::SetCursor (this=0x27dd430, rRect=Rectangle = {...}) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:354
#4  0x00002aaac869c211 in SmGraphicWindow::SetCursor (this=0x27dd430, pNode=0x2ba1130) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:337
#5  0x00002aaac869bab2 in SmGraphicWindow::MouseButtonDown (this=0x27dd430, rMEvt=...) at /home/julien/compile-libreoffice/libreoffice/starmath/source/view.cxx:200
#6  0x00002aaab19996bd in ImplHandleMouseEvent (pWindow=0x25b6550, nSVEvent=MOUSEBUTTONDOWN, bMouseLeave=false, nX=900, nY=326, nMsgTime=25685388, nCode=1, 
    nMode=(SIMPLECLICK | SELECT)) at /home/julien/compile-libreoffice/libreoffice/vcl/source/window/winproc.cxx:734
Comment 12 Julien Nabet 2014-12-05 14:29:59 UTC
I did more tests but it's more complicated than I thought.
The quoted patch just displays the cursor in the bottom pane, it doesn't help for the surrounding rectangle around a part of the formula in main window
But perhaps the code pointers may help.
Comment 13 Michael Meeks 2015-10-09 09:15:07 UTC
Heh - really we need to solve the last in-line editing problems here; such as undo/redo (how hard can it be ;-) and get that enabled by default so we don't have these conditionals (I guess). It should be easy enough to disable / remove that button in experimental mode though I guess =) patches appreciated.
Comment 14 QA Administrators 2016-11-08 11:04:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.6 or 5.2.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20161108