Download it now!
Bug 36597 - Allow engineering notation for number format
Summary: Allow engineering notation for number format
Status: RESOLVED DUPLICATE of bug 30716
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 17:36 UTC by morten_lp
Modified: 2011-05-05 23:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description morten_lp 2011-04-25 17:36:03 UTC
Thank you guys for a really good package. I hope that this bug report will make it even better.

The format: ??0E+00 "mol"

I use this format to describe milli- micro- nano- and pico-mol.

Thus I need to have shown the E+00 part in steps of 3 (-9, -6, -3, 0, 3, 6, 9)

Example:

I want:
40E-09 mol = 40 nano mol

I don't want:
400E-10 mol

This type of format works fine in the last three editions of MS Excel and it would really make a difference for many users of Libra Office working with science since it enables working with the actual numbers without risking the clasical mistakes when multiplying e.g. 1.7 milli gram with 7.4 micro mol/g.
Comment 1 Rainer Bielefeld Retired 2011-04-25 22:00:20 UTC
I see this one as a DUP of
"Bug 30716 - Engineering Notation"

@morten_lp@hotmail.com:
Can you contribute well founded reasons why this one should be handled as a separate issue?
Comment 2 morten_lp 2011-04-26 04:08:38 UTC
From a user perspective it is very important to have a level of control over how very large or very small numbers are displayed in a spread sheet. Otherwise we might as well just write up such calculations in a word processor and use the old-fashioned calculator on the side.

This issue is crucial for maintaining and broadening a well educated user base.




> From: bugzilla-daemon@freedesktop.org
> To: morten_lp@hotmail.com
> Subject: [Bug 36597] Allow engineering notation for number format
> Date: Mon, 25 Apr 2011 22:00:20 -0700
> 
> https://bugs.freedesktop.org/show_bug.cgi?id=36597
> 
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Summary|Scientific format of        |Allow engineering notation
>                    |numbers                     |for number format
>            Platform|x86-64 (AMD64)              |All
>          OS/Version|Windows (All)               |All
>            Severity|major                       |enhancement
>            Priority|medium                      |high
>                  CC|                            |LibreOffice@bielefeldundbus
>                    |                            |s.de
> 
> --- Comment #1 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> 2011-04-25 22:00:20 PDT ---
> I see this one as a DUP of
> "Bug 30716 - Engineering Notation"
> 
> @morten_lp@hotmail.com:
> Can you contribute well founded reasons why this one should be handled as a
> separate issue?
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 3 Rainer Bielefeld Retired 2011-05-05 23:53:09 UTC
No new information concerning DUP question.

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here. 
And please stop such useless citing of mail contents!

*** This bug has been marked as a duplicate of bug 30716 ***