Download it now!
Bug 36663 - Wrong english string used for Calc UI (VCL)
Summary: Wrong english string used for Calc UI (VCL)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: Other All
: low minor
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-28 15:48 UTC by Olivier Hallot
Modified: 2011-05-01 16:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2011-04-28 15:48:35 UTC
In menu

Insert - Name - Define, the dialog box has a "More" button.

After clicking the button, the button label should be labeled "Less".

The two string are:
SV_BUTTONTEXT_LESS
SV_BUTTONTEXT_MORE

in vcl     source\src\btntext.src

But these two strings are "More" in english.

The english string SV_BUTTONTEXT_LESS should be changed to "Less"

This small error had propagated into many languages.

The same string above is used in the DataPilot layout dialog. May be other places too.
Comment 1 Rainer Bielefeld Retired 2011-04-28 23:26:52 UTC
[Reproducible] with "LibreOffice 3.3.2  – WIN7  Home Premium  (64bit) English UI [OOO330m19 (Build:202 / tag 3.3.2.2)]"

Seems to be a more general problem with all such dialogs (Also visible in "Define Range" and may be others)

French UI shows the same Problem with button name "Plus"
In Spanish UI it's completely wired:
- with invisible additional settings button shows "Opciones" (ok)
- with visible additional settings  button shows "Más" instead of "Menos"

So also Localization is affected?

In German UI it's ok, there the button is called "Zusätze" (Something like "Additional Settings", here no different button name is required.

@Cáolan:
Your area?
Comment 2 Andras Timar 2011-04-28 23:30:05 UTC
According to git blame SV_BUTTONTEXT_LESS has been "More" since 2005... I wonder if it was intentional or just a mistake that nobody has fixed.

Anyway, I fixed it in master now.
Comment 3 Rainer Bielefeld Retired 2011-04-28 23:55:35 UTC
Too fast for me ;-)
A good solution might be how it works with dialog in menu "Find & Replace" (CALC), there the button shows "More Options" / "Fewer Options". This one is also ok for French, Spanish and German UI.