Download it now!
Bug 36672 - Align text to the bottom of a footer
Summary: Align text to the bottom of a footer
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2011-04-29 05:53 UTC by toddrme2178
Modified: 2017-07-18 16:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description toddrme2178 2011-04-29 05:53:37 UTC
Currently it is possible to very accurately set the top edge of a footer, and thus the top edge of the text in the footer.  However, it is often necessary to set the distance of the text from the bottom of the page.  There is currently no way to do this automatically in the footer.  So it would be very useful if there was an option to set the vertical alignment of the text in a footer, so that you can set the text to automatically align to the bottom edge of the footer.

Alternatively (or additionally), this option could be in the frame settings.
Comment 1 Björn Michaelsen 2011-12-23 12:07:18 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:04:24 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:05:14 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:09:41 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:11:40 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-09-04 07:58:00 UTC
> Alternatively (or additionally), this option could be in the frame settings.
IMHO should used table with one cell instead of frame. There present needed alignment.
Comment 7 Thomas Lendo 2017-06-04 22:08:46 UTC
Reopen it as unconfirmed. Closing it only due to a Bugzilla internal change and missing reaction of bug opener is too harsh. It's worth discussing about more alignment features in headers/footers.
Comment 8 Heiko Tietze 2017-06-05 08:11:52 UTC
What setting should be done relative to the footer? Do you mean page style > footer > height (don't get the point with align to footer) or paragraph style > indents (makes no sense at all)?
Comment 9 Thomas Lendo 2017-06-08 22:08:19 UTC
I would suggest a new option in Format > Page > Header/Footer or Page Style:XYZ > Header/Footer. It should be available for header AND footer because for both it has advantages.

It only needs the possibility to choose the alignment of the header/footer content:
* top
* bottom

If "top" is selected (it's pre-selected and matches the behavior today) then the content of the header/footer is aligned to the upper edge of the header/footer area (=aligned to page border for header and to text body for footer). If "bottom" is selected then the content is aligned to the lower edge (=aligned to page border for footer and to text body for header).
Comment 10 Thomas Lendo 2017-06-22 19:26:20 UTC
Excerpt of a conversation with Heiko:

Thomas:
If you have a footer with height of 2.5 cm and you only write a single line of text then the text will be aligned at the top of the footer area. With this new feature the text also could be aligned at the bottom. All other settings will remain unchanged.

Heiko:
That's the point. Text style of a footer doesn't provide that, so it must be calculated internally. There must be a transparent mapping on th values in the dialog. ... In principle the idea is plausible but the use case is that th height of the footer will be adapted to its content. Similar to "Fit to height" in text boxes.

So, if it's not really doable in Writer code, please close this bug. Otherwise give it a try.
Comment 11 Heiko Tietze 2017-07-18 12:16:01 UTC
I wonder if the header/footer area has this property in the ODF or if it's only available for tables as comment 6 suggests. Regina, what's your take? (Please close as WONTFIX if valign is not possible.)
Comment 12 Regina Henschel 2017-07-18 16:18:58 UTC
Vertical alignment is available for text in a table cell (20.386.2) and for a frame. It is neither available for paragraphs nor for a table as entire unit. There exists no request in the OASIS Issue tracker for a vertical alignment.

For now you can use table cells inside footer and put the content inside the cells.