Bug Hunting Session
Bug 36688 - Borders for sheet headers and footers don't get printed
Summary: Borders for sheet headers and footers don't get printed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4.2
Keywords: regression
: 37030 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-29 10:42 UTC by SURCOUF
Modified: 2011-08-10 16:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots of sample file (184.22 KB, application/vnd.oasis.opendocument.graphics)
2011-04-29 10:42 UTC, SURCOUF
Details
test document (7.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-18 03:02 UTC, Cédric Bosdonnat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SURCOUF 2011-04-29 10:42:21 UTC
Created attachment 46162 [details]
Screenshots of sample file

Hello,

Just installed LibO3.4 Beta 3. Since LibO3.4 Beta 1, a bug concerning CALC PRINTING has been solved thanks to Mr YOSHIDA. Meanwhile, I discovered the placing a boundary line under header and another one over footer was causing the bug. When removed, CALC stopped to crash.

Yet I noticed that another bug has appeard. When placed, the boundary lines do not appear in print preview. I tried the same file under OOo3.4 Beta1, the lines are there. (see attached file)

Hope that this can help.

Bunty
Comment 1 SURCOUF 2011-05-06 23:51:36 UTC
Just installed Beta4. The problem is still there

May be this will be solved till the final release.

Bunty
Comment 2 Noel Power 2011-05-09 04:34:42 UTC
which version of OOo are you using, is there some special way to get the lines in the the footer/header to appear ( even in OOo3.3.0 I didn't manager to get them displayed in the preview ) - but
Comment 3 SURCOUF 2011-05-09 06:45:32 UTC
(In reply to comment #2)
> which version of OOo are you using, is there some special way to get the lines
> in the the footer/header to appear ( even in OOo3.3.0 I didn't manager to get
> them displayed in the preview ) - but

I'm using the OOo3.4.0 Beta1.
The precedure to reproduce this bug under a CALC file is:

- Format
- Page
- Footer or Header

You get a window to apply border lines.

A file created under LibO with border lines will give an awaited display result under OOo yet not under LibO. The reverse is the same. A OOo file will not display the border line under LibO.

Hope that my help will be usefull.

Bunty
Comment 4 Noel Power 2011-05-10 06:31:22 UTC
ok, I didn't notice the tab for borders I was just looking at the header/footer stuff.

yes now I notice is that borders ( when you apply them ) neither appear in the preview or in the printed document ( used work afaics in lo 331 ) therefore setting as regression
Comment 5 Kohei Yoshida 2011-05-10 08:24:35 UTC
CC'ing Cedric.  Cedric, does this happen to be related to the border type enhancement you did?
Comment 6 Rainer Bielefeld Retired 2011-05-15 08:24:54 UTC
I modified Status due to facts.

Still any question for SURCOUF?
Comment 7 Cédric Bosdonnat 2011-05-18 03:02:20 UTC
mine
Comment 8 Cédric Bosdonnat 2011-05-18 03:02:57 UTC
Created attachment 46852 [details]
test document
Comment 9 SURCOUF 2011-07-01 08:50:41 UTC
Hello,

Just installed LibO3.4.1 final version. The bug has reappeard for it seemed to be fixed in the RC2 version. Since the RC3, the line is no more there. Same in the final stable version.

Bunty
Comment 10 Kohei Yoshida 2011-07-07 09:29:03 UTC
Apparently this is now mine to look into...
Comment 11 Kohei Yoshida 2011-07-07 09:30:33 UTC
We also need to be aware of Bug 38590 when fixing this bug, to make sure *not* to re-introduce it.
Comment 12 Kohei Yoshida 2011-07-14 08:49:48 UTC
Better summary & target.  I had hard time locating this bug report because of the bad summary.
Comment 13 Kohei Yoshida 2011-07-14 12:42:48 UTC
Fixed on master:

http://cgit.freedesktop.org/libreoffice/calc/commit/?id=cdb8cf074c8536aa3ea30102bcb9b34feda21833

and a request for review to push this to the 3.4.2 branch sent to the mailing list.
Comment 15 Caolán McNamara 2011-08-10 16:06:13 UTC
*** Bug 37030 has been marked as a duplicate of this bug. ***
Comment 16 Caolán McNamara 2011-08-10 16:07:26 UTC
note, this fixes some crashes as well