Download it now!
Bug 36719 - Editing a pivot table linked to non-existent database crashes Calc in various places.
Summary: Editing a pivot table linked to non-existent database crashes Calc in various...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4.1
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-30 11:04 UTC by Thomas Hackert
Modified: 2013-11-24 19:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Error log from OpenJDK (87.26 KB, text/plain)
2011-04-30 11:04 UTC, Thomas Hackert
Details
crash stack for Comment 2 (18.84 KB, text/x-log)
2011-05-26 02:09 UTC, Yifan Jiang
Details
snapshot of causing crash area mentioned in Comment 2 (15.42 KB, image/png)
2011-05-26 02:12 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2011-04-30 11:04:05 UTC
Created attachment 46197 [details]
Error log from OpenJDK

Hello all,
I hope, I got the right component and all ... ;) If not, feel free to change it. Thanks in advance :)

Do the following:
1. Start Calc
2. Choose "Date - Pivot Table - Create (in the Germanophone version on Debian Testing AMD64 the menu entry is called "Daten - Datenpilot - Erstellen")
3.  Choose "In LibreOffice registered data source" (in my version "In LibreOffice angemeldete Datenquelle") and press "OK"
4. Choose "Database" "Bibliography", "Data source" "biblio" under "Selection" (Auswahl) and press enter.

LO immediately crashes ... :( If I start LO from Konsole under KDE, I get the following
<quote>
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007ff8b7456c2b, pid=3594, tid=140706789226240
#
# JRE version: 6.0_18-b18
# Java VM: OpenJDK 64-Bit Server VM (16.0-b13 mixed mode linux-amd64 )
# Derivative: IcedTea6 1.8.7
# Distribution: Debian GNU/Linux unstable (sid), package 6b18-1.8.7-2
# Problematic frame:
# C  [libsclx.so+0x309c2b]  _ZNK17ScSheetSourceDesc14GetSourceRangeEv+0x1b
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid3594.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
#

[error occurred during error reporting , id 0xb]
</quote>
If you need any further info, feel free to ask ... ;) I will attach the mentioned hs_err_pid3594.log afterwards.
HTH
Thomas.
Comment 1 Yifan Jiang 2011-05-26 02:01:39 UTC
Hi thackert,

Would you also help attach your backtrace:

http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29

Thanks!
Comment 2 Yifan Jiang 2011-05-26 02:07:33 UTC
I met crash only after some subsequent operations:

The Pivot table can be created successfully, but when clicking the 'sorting list' area ( see attached picture ) in pivot table will cause Calc crash.

Not sure it is the same problem of reported. But still thanks Kohei to have a review :)
Comment 3 Yifan Jiang 2011-05-26 02:09:55 UTC
Created attachment 47181 [details]
crash stack  for Comment 2
Comment 4 Yifan Jiang 2011-05-26 02:12:11 UTC
Created attachment 47183 [details]
snapshot of causing crash area mentioned in Comment 2
Comment 5 Yifan Jiang 2011-05-26 02:19:53 UTC
Forgot to mention the build I was using: 3.4 rc1 /SLED 11 sp1 i586.

And I didn't see the problem on 3.3.1.2 Novell build. Probably a regression.
Comment 6 Thomas Hackert 2011-05-26 10:00:00 UTC
Hello Yifan,
thank you for your interest in this bug :)
I have tried to reproduce this bug on my system (Debian Testing AMD64) with
<quote>
LibreOffice 3.4.0 
OOO340m1 (Build:12)
</quote>
, but cannot reproduce it anymore. So it seems, that this bug is fixed (thanks to everyone involved :) ). And so I am not able to produce a backtrace, sorry ... :(
HTH
Thomas.
P.S.: Should I set this issue to "RESOLVED"?
Comment 7 Kohei Yoshida 2011-06-02 07:49:03 UTC
Assuming that the crash on field popup window is still present, I'd like to look into this for 3.4.1.
Comment 8 Kohei Yoshida 2011-06-10 08:32:26 UTC
So, I've already fixed the original crasher in another bug I think.  But it's still a bit unstable when you open a document with pivot table to a non-existing database.  I need to look into this.
Comment 9 Kohei Yoshida 2011-06-10 08:33:47 UTC
Changing the title.
Comment 10 Kohei Yoshida 2011-06-10 10:17:21 UTC
Fix on master (though I accidentally used wrong bugzilla ID...)

http://cgit.freedesktop.org/libreoffice/calc/commit/?id=949b196ec7ebd465ee0f3006f665e4240b3b3ace

I'll send a request for review to the list shortly.
Comment 11 Kohei Yoshida 2011-06-10 13:03:27 UTC
This is now fixed in 3.4.1.