Bug Hunting Session
Bug 36733 - Can't open files with no access permissions for user, but for group
Summary: Can't open files with no access permissions for user, but for group
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Muthu
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-01 01:54 UTC by Alexander Skwar
Modified: 2011-07-07 01:49 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Error message shown when trying to open file and file perms of tmp file (64.41 KB, image/png)
2011-05-01 01:54 UTC, Alexander Skwar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Skwar 2011-05-01 01:54:33 UTC
Created attachment 46213 [details]
Error message shown when trying to open file and file perms of tmp file

I've got the following file:

MacBook-Pro:db alex$ ls -la 
total 32
drwxr-xr-x   3 alex    staff    102  1 Mai 10:47 .
drwx------  19 alex    staff    646  1 Mai 10:43 ..
----rw-r--   1 nobody  wir    13140  1 Mai 10:46 064.ods

When I try to open this file with LibreOffice 3.3.2 on OSX 10.6.4, I get an error message (see attached screenshot). It states, that it can't access some tmp file. This tmp file has these permissions:

MacBook-Pro:db alex$ ls -la /Users/alex/Library/Application\ Support/LibreOffice/3/user/temp/svnj4.tmp/svnjf.tmp 
--w-r--r--  1 alex  wir  13140  1 Mai 10:46 /Users/alex/Library/Application Support/LibreOffice/3/user/temp/svnj4.tmp/svnjf.tmp

As you can see there, the svnjf.tmp file has 0244 permissions and thus reading isn't allowed. My original 064.ods file has 0064 permissions and access is granted, because my user "alex" is part of the group "wir".

When the file is copied to the tmp dir, the group permissions are wrong (they are now only "r" but should be "rw") and also the user perms are wrong (they are now only "r", but should be "rw" - or the user owner shouldn't be changed and kept at the original, which would allow the group perms to take effect).
Comment 1 Muthu 2011-05-05 02:56:16 UTC
Confirmed. Picking this one.
Comment 2 Alexander Skwar 2011-05-05 03:01:22 UTC
The error occurs in the exact same way also on Linux. So it's something "*nix" specific, I'd assume. Don't know how to replicate something like this on Windows.

But because it also happens on Linux, changing OS to ALL.
Comment 4 Muthu 2011-07-07 01:49:20 UTC
Marking this fixed.