Bug Hunting Session
Bug 36747 - Relationally link Save As formats and Default File Formats lists
Summary: Relationally link Save As formats and Default File Formats lists
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Gian Domenico Ceccarini
URL:
Whiteboard: target:5.5.0 target:6.0.0
Keywords: difficultyBeginner, easyHack, skillUI, topicUI
Depends on:
Blocks:
 
Reported: 2011-05-01 09:56 UTC by Jared
Modified: 2017-07-26 16:04 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
dialog from Options window showing format list (78.16 KB, image/png)
2013-06-18 16:07 UTC, Jared
Details
dialog from Save As window showing format list (74.55 KB, image/png)
2013-06-18 16:07 UTC, Jared
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jared 2011-05-01 09:56:11 UTC
It would improve consistency and clear understanding/learning for users to have the lists formatted and presented to them when choosing a default file format in Load/Save Options as well as the Save As format list.

Right now the Save As format list offers the actual extension (e.g. .odt, .doc, .rtf) while the Default Format list does not display the file extension.
Comment 1 Björn Michaelsen 2011-12-23 12:07:19 UTC Comment hidden (obsolete)
Comment 2 Jared 2011-12-29 12:03:40 UTC
This is still an issue in LODev-3.5Beta2 for Win32.

The file format extensions still do not appear in the "Load/Save Options" but do appear in the "Save As type" list.
Comment 3 ign_christian 2013-06-18 05:53:25 UTC
I think it's been implemented now. I'm using LO 4.0.4.2 (Win7 32bit)

Please REOPENED if that UI on latest stable release still doesn't fit your need (also provide detailed explanation & screenshot if possible)
Comment 4 Jared 2013-06-18 16:07:13 UTC
Created attachment 81016 [details]
dialog from Options window showing format list
Comment 5 Jared 2013-06-18 16:07:52 UTC
Created attachment 81017 [details]
dialog from Save As window showing format list

LO-Dev 4.0b2
Comment 6 Jared 2013-06-18 16:11:33 UTC
(In reply to comment #3)
> I think it's been implemented now. I'm using LO 4.0.4.2 (Win7 32bit)
> 
> Please REOPENED if that UI on latest stable release still doesn't fit your
> need (also provide detailed explanation & screenshot if possible)

What I'm looking for is the file format list to have a continuity between the two lists.  I've attached screenshots here from LO-Dev 4.0b2 I'm using on Win8_x64.

The dialog in the Options does not display the format extensions, yet the Save As dialog does, and the order between the two is not the same.  I think we can provide clarity better for the user by making the the lists _exactly_ the same.

Does that make sense?  Please let me know if you need more explanation, or if there is a reason for this I'm missing--thanks.
Comment 7 ign_christian 2013-06-19 02:51:03 UTC
> The dialog in the Options does not display the format extensions, yet the
> Save As dialog does, and the order between the two is not the same.  I think
> we can provide clarity better for the user by making the the lists _exactly_
> the same.

Oo..I understand now. You have requested file format/extensions to be shown on:
Menu: Tools > Options > Load/Save (General) > Always save as

Also as a better clarity you want that lists ordered exactly the same as 'Save As' dialog box.

I think those should be an enhancement request
Comment 8 Joel Madero 2014-11-04 03:24:08 UTC
Never independently confirmed by QA team - moving to UNCONFIRMED.
Comment 9 Robinson Tryon (qubit) 2014-12-21 23:08:24 UTC
(In reply to ign_christian from comment #7)
> Oo..I understand now. You have requested file format/extensions to be shown
> on:
> Menu: Tools > Options > Load/Save (General) > Always save as

Good idea.

> Also as a better clarity you want that lists ordered exactly the same as
> 'Save As' dialog box.

Consistency, consistency, consistency.
I'm a big fan :-)

> 
> I think those should be an enhancement request

And I think the status should be 'NEW'.

This seems related to UX and good design/layout, so I'll toss it over there.
Comment 10 Heiko Tietze 2016-07-22 11:17:11 UTC
To clarify what is requested:

For the sake of consistency the list of formats under (now) Tools > Options > Load/Save General should have the same look and feel as the format list in file dialogs. That means 'ODF Text Document' should become 'ODF Text Document (.odt)' and the order of items has to get harmonized.

This is clearly an EASYHACK. NEEDINFO for the codepointers.
Comment 11 jani 2016-07-23 07:43:59 UTC
(In reply to Heiko Tietze from comment #10)
> To clarify what is requested:
> 
> For the sake of consistency the list of formats under (now) Tools > Options
> > Load/Save General should have the same look and feel as the format list in
> file dialogs. That means 'ODF Text Document' should become 'ODF Text
> Document (.odt)' and the order of items has to get harmonized.
> 
> This is clearly an EASYHACK. NEEDINFO for the 

This search will catch all places where "ODF Text Document" is used, however it does not seem to find the menu in question

http://opengrok.libreoffice.org/search?q=%22ODF+Text+Document%22&project=core&defs=&refs=&path=&hist=
Comment 12 jani 2016-07-23 07:44:08 UTC Comment hidden (obsolete)
Comment 13 Xisco Faulí 2016-09-15 15:26:49 UTC
Removing keyword 'needsDevEval' as this bug is an easyHack
Comment 14 jani 2016-11-25 06:47:05 UTC
A polite ping still working on this bug ?
Comment 15 Gian Domenico Ceccarini 2016-12-01 10:19:10 UTC
I modify the files under /filter/source/config/fragments/filters/, for example modifying the file called 'writer8.xcu'.
http://opengrok.libreoffice.org/search?q=%22ODF+Text+Document%22&project=core&defs=&refs=&path=&hist
I changed the string
<value xml:lang="en-US">ODF Text Document</value>
in
<value xml:lang="en-US">ODF Text Document (.odf)</value>
and so on for all type of files extension.

It worked! If I went to 'Tools->Option->Load/Save->General', I can saw correctly the name of the type and the extention (ex: "ODF Text Document (.odf)").
But whene I open the normal 'Save As' UI I found the double extension on my pulldown menu (ex:"ODF Text Document (.odf) (.odf)").

Does anyone can help me to find the right way?
Comment 16 Fakabbir amin 2017-01-24 15:48:38 UTC
I have solved the issue but due to some issue with my laptop will only be able to submit the patch after 28th Jan. Hence I assigned it to myself.
Comment 17 Fakabbir amin 2017-02-07 12:11:36 UTC
Still working on it. 
Progress till date:
Added manual recognizing 
Doing right now
Will be adding automatic reorganizing.
Comment 18 Fakabbir amin 2017-03-07 09:36:54 UTC
A long way to do that:
https://gerrit.libreoffice.org/#/c/33655/
Making status NEW again.
Comment 19 Miklos Vajna 2017-05-28 16:44:41 UTC
Code pointers:

sfx2/source/dialog/filtergrouping.cxx:897, sfx2::appendFiltersForSave() shows how to get the UI name and the extension of an SfxFilter

sfx2/source/dialog/filtergrouping.cxx:1150, sfx2::addExtension() can create a string with both the filter name and the extension included, would be good to not duplicate that. It is probably necessary to change the reference parameter there to be an optional pointer instead, to be general.

sfx2/source/bastyp/fltfnc.cxx:171, SfxFilterContainer::GetFilter4FilterName() can give you an SfxFilter just based on the internal (unique) filter name.

I think based on those it should be put together a patch to provide extensions next to filters in the dialog.
Comment 20 Miklos Vajna 2017-05-28 16:45:56 UTC
Assigned state without assignee, let's fix that. :-)
Comment 21 Commit Notification 2017-05-29 12:43:51 UTC
Gian Domenico Ceccarini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ccd8f402a79cbb43aa5bae7a11d3fcae92971c75

tdf#36747 Add extension in Tools > Options > Load / Save > General

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Xisco Faulí 2017-06-29 02:37:47 UTC Comment hidden (obsolete)
Comment 23 Commit Notification 2017-07-26 05:54:39 UTC
James Raykowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=343d40206a929969e1755b073edae91cc4bd9751

tdf#36747 add sort to match format list in file dialogs

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Jared 2017-07-26 16:04:06 UTC
Thanks so much for your work addressing this!