Bug Hunting Session
Bug 36752 - EDITING: Writer crashes with Graphite smart fonts in Table of Contents
Summary: EDITING: Writer crashes with Graphite smart fonts in Table of Contents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 34420
  Show dependency treegraph
 
Reported: 2011-05-01 14:25 UTC by gleppert
Modified: 2011-06-22 21:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice crash due to graphite fonts in TOC (21.49 KB, application/vnd.oasis.opendocument.text)
2011-05-01 14:25 UTC, gleppert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-05-01 14:25:07 UTC
Created attachment 46232 [details]
LibreOffice crash due to graphite fonts in TOC

Attached document uses Graphite fonts in the Table of Contents. Performing a certain action always results in a crash of Writer.

Steps to reproduce the crash:
* Please open attached file
* Click with the mouse in the word "Introduction" in the table of contents
* Press F11 in order to get the window to edit the templates
* The template of the top level in the TOC is called "Inhaltsverzeichnis 1" (TableOfContents1). Please perform a right mouse click on this template in the template window and click on "edit".
* Please click on the tab "Schrifteffekte" (font effects)
* Click on "Cancel" in order to close the dialog.
* Writer will immediately crash

Reproducible: Always

System: System: Ubuntu 10.10/Gnome 2, LibreOffice 3.3.2. PPA, Intel 32-Bit. German language environment
Comment 1 Muthu 2011-05-02 23:57:08 UTC
Seems like a graphite problem....
for me: clicking on the 'Introduction' itself causes a crash...

one for cedric? 

Part of bt:
#0  0x00007ffff35e0a17 in (anonymous namespace)::direct_run(bool, void* const*, unsigned char const*, int*, graphite2::Slot**&, graphite2::SlotMap*) ()
   from /ext2/muthu/ooo/libo/install/program/../basis-link/program/libvcllx.so
#1  0x00007ffff35e16a0 in graphite2::vm::Machine::run(void* const*, unsigned char const*, graphite2::Slot**&, graphite2::vm::Machine::status_t&) ()
   from /ext2/muthu/ooo/libo/install/program/../basis-link/program/libvcllx.so
#2  0x00007ffff35dff15 in graphite2::Pass::testConstraint(graphite2::Rule const&, graphite2::vm::Machine&) const ()
....
Comment 2 gleppert 2011-05-21 12:23:24 UTC
I tried this issue with LibreOffice 3.4rc1 and it seems to be solved. No problem here anymore.

@Muthu: Do you still encounter the crash in 3.4rc1? If not, you can close the bug.
Comment 3 Rainer Bielefeld Retired 2011-06-22 21:56:23 UTC
Closing due to Comment 2 and Muthu's inacivity.
Please feel free to reopen this bug if you find out that the problem still exists with the current LibreOffice 3.4.1 or later.