Download it now!
Bug 36820 - PDFEXPORT with option "Tagged PDF" crashes WRITER documents
Summary: PDFEXPORT with option "Tagged PDF" crashes WRITER documents
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-03 21:57 UTC by Rainer Bielefeld Retired
Modified: 2011-06-09 02:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-03 21:57:45 UTC
During further tests conderning 
Bug 34093 - Partial PDFEXPORT of particular Master Documents breaks hyperlinks 
my "LibreOffice 3.4Beta3  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:3)]" crashes when I use  "Tagged PDF". It's only reproducible iwht complex big documents, I will try to find a manageable sample document.
Comment 1 Rainer Bielefeld Retired 2011-05-03 22:33:45 UTC
For me it's reproducible with sample for 
Bug 34093 - Partial PDFEXPORT of particular Master Documents breaks hyperlinks 

Steps to reproduce:
0. download and unpack test kit from Bug 34093
1. Open Dokudateien_30\MasterSampleAE.odm
2. Menu 'File > Printer Settings > Options': 
   Contents: first 3 checked
   Pages: left / right checked
   comments: no
3. Menu 'File > Export to PDF > Pages=3-20, JPG85%, 300dpi', further settings:
   General: Tagged PDF, export bookmarks
   Initial view: Pages, Zoom=Standard, 
   UI: Show document title, all bookmarks
   Links: Check 1,3, first radio botton
   Security: all unused
   <export>
4. In file dialog type a name if necessary to save .pdf in the same folder 
   like MasterSampleAE.odm
   LibO will hang after a short moment and has to be terminated by OS
Comment 2 Rainer Bielefeld Retired 2011-05-04 01:07:02 UTC
The problem is not limited to such complex documents, also quite normal documents with 20 pages show the crash. May be in the evening I will find the time to find out what details in the documents cause the crash.
Comment 3 Rainer Bielefeld Retired 2011-05-04 10:11:38 UTC
Steps to reproduce:
1. Open new WRITER document from start center
2. Insert 4 manual page breaks to have an empty 5 paes doument
3. Meneu 'File > Export as PDF'
   General: Checked JPG 85%, Resolution 300dpi, Tagged PDF, Export Bookmarks
4. Pages 2-4
   <Export>
  After a short moment LibO will no longer respond and will have to be 
  terminated with WIN Task Manager

During my tests the problem only occured when I exported a part of the document, export of complete document worked fine.

It seems that CALC is not affected, so component WRITER
Comment 4 Muthu 2011-05-05 01:35:27 UTC
One for cedric?
Comment 5 gleppert 2011-05-05 09:20:36 UTC
Tested Rainer's description step by step on my computer. Here, I cannot confirm the bug.

System: Ubuntu 10.10/Gnome2, LibreOffice 3.3.2 PPA, German language environment, Intel 32-Bit
Comment 6 Rainer Bielefeld Retired 2011-05-10 11:14:06 UTC
Not only a slip, same problem on a laptop with "LibreOffice 3.4Beta4  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:4)]"
Comment 7 Cor Nouws 2011-05-10 11:28:03 UTC
cannot reproduce it on Ubuntu 11.04
Comment 8 Cor Nouws 2011-05-10 11:29:04 UTC
(In reply to comment #7)
> cannot reproduce it on Ubuntu 11.04

Hmm, have to look for another document I see now .. apologies
Comment 9 Cor Nouws 2011-05-10 11:32:04 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > cannot reproduce it on Ubuntu 11.04
> 
> Hmm, have to look for another document I see now .. apologies

Also with a document as described in comment#3, I cannot reproduce it.
Comment 10 Michael Meeks 2011-05-17 22:29:13 UTC
Hmm - this is also Valgrind clean on Linux - so, presumably some odd Windows specific snafu. Perhaps Tor can reproduce it (?) :-)
Comment 11 manj_k 2011-05-18 14:58:42 UTC
[Snapshot 2011-05-16 - LibreOffice 3.4.0 OOO340m1 (Build:5) on WinXP 32b]

Not reproducible (as described in comment #3).
Export as PDF (pages 2-4) works well.
Comment 12 Frédéric Vuillod 2011-05-25 02:38:37 UTC
I can reproduce the crash with a 5 blank pages document and export as PDF pages 2-4

OOO340m1 (Build:11) Windows 7 32bit
Comment 13 Rainer Bielefeld Retired 2011-05-25 04:12:49 UTC
Might be related to WIN and very particular system or LibO settings?

NEW due to Comment 12

@Frédéric Vuillod
Than you for testing!
Comment 14 Cédric Bosdonnat 2011-06-09 01:00:41 UTC
Tor, it's a windows-only bug. Could you have a look at it?
Comment 15 Don't use this account, use tml@iki.fi 2011-06-09 01:32:32 UTC
Can reproduce with Rainer's simple instructions in comment #3, thanks. Will debug.
Comment 16 Don't use this account, use tml@iki.fi 2011-06-09 01:34:54 UTC
Stack trace at crash:

 	swmi.dll!std::_Tree<std::_Tmap_traits<void const *,long,std::less<void const *>,std::allocator<std::pair<void const * const,long> >,0> >::const_iterator::operator*()  Line 264	C++
 	swmi.dll!SwTaggedPDFHelper::CheckReopenTag()  Line 384 + 0x8 bytes	C++
 	swmi.dll!SwTaggedPDFHelper::BeginBlockStructureElements()  Line 1017 + 0xb bytes	C++
 	swmi.dll!SwTaggedPDFHelper::SwTaggedPDFHelper(const Num_Info * pNumInfo=0x00000000, const Frm_Info * pFrmInfo=0x00cfca00, const Por_Info * pPorInfo=0x00000000, OutputDevice & rOut={...})  Line 299 + 0x8 bytes	C++
 	swmi.dll!SwLayoutFrm::Paint(const SwRect & rRect={...}, const SwPrintData * const __formal=0x00000000)  Line 3151 + 0x19 bytes	C++
 	swmi.dll!SwRootFrm::Paint(const SwRect & rRect={...}, const SwPrintData * const pPrintData=0x0592a760)  Line 2954	C++
 	swmi.dll!ViewShell::PrintOrPDFExport(OutputDevice * pOutDev=0x0596c960, const SwPrintData & rPrintData={...}, long nRenderer=0x00000001)  Line 537	C++
 	swmi.dll!SwXTextDocument::render(long nRenderer=0x00000001, const com::sun::star::uno::Any & rSelection=0x00cfd140 <"com.sun.star.lang.XComponent">, const com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> & rxOptions=0x00cfd1a4 {size=0x00000006})  Line 2957	C++
Comment 17 Don't use this account, use tml@iki.fi 2011-06-09 02:05:00 UTC
Seems to be fixed by http://cgit.freedesktop.org/libreoffice/writer/commit/?id=ddb616ebaa1564b9c7d189b603ce7d49f9a5e712 , review pending for the 3-4 branch.