Bug 36843 - Address Datasource wizard does nothing / doesn't function
Summary: Address Datasource wizard does nothing / doesn't function
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-04 07:41 UTC by Alex Thurgood
Modified: 2012-01-29 05:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2011-05-04 07:41:04 UTC
Tried to assign a datasource as the default Address source via the wizard availabla through File > Wizards > Address Datasource.

Result :
Nothing happens.

Expected:
Datasource assignment dialog should appear and allow user to choose the default datasource to be set for the address book.

Regression compared to LO 3.3.2



Alex
Comment 1 Alex Thurgood 2011-05-04 07:42:00 UTC
Adding regression keyword

Alex
Comment 2 Alex Thurgood 2011-05-04 07:42:37 UTC
Nominating as stopper for 3.4 release
Comment 3 Alex Thurgood 2011-05-04 08:00:54 UTC
BTW, this works in OOo-dev 3.4.0

Alex
Comment 4 Björn Michaelsen 2011-12-23 12:06:05 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Rainer Bielefeld Retired 2011-12-24 00:24:09 UTC
@Alex:
Can we close this one?
Comment 6 Rainer Bielefeld Retired 2012-01-08 10:47:10 UTC
Closed due to comment 3 / no answer comment 4
Comment 7 tommy27 2012-01-08 12:17:19 UTC
hi Rainer.
why did u close this issue?

comment 3 said it works in OOo 3.4 not in LibO 3.4
Comment 8 Alex Thurgood 2012-01-08 13:45:55 UTC
Reopening. 
Until it can be confirmed that this does work on MacOsx which, last time I checked, it didnt.
Since I haven't had a chance to test on a recent build.
Comment 9 Rainer Bielefeld Retired 2012-01-08 21:21:34 UTC
(In reply to comment #7)
> comment 3 said it works in OOo 3.4 not in LibO 3.4

Oops, my mystake!
Comment 10 Alex Thurgood 2012-01-28 08:15:14 UTC
This now seems to work OK 3.5RC2 on Mac OSX, so closing issue as resolved fixed.


Alex
Comment 11 Alex Thurgood 2012-01-28 08:16:13 UTC
Forgot to add that I also tested on Linux 32bit and it worked there too.

Alex
Comment 12 Alex Thurgood 2012-01-29 05:58:15 UTC
Setting to WFM because we don't know which fix actually corrected the bug.

Alex