Bug 36907 - Extremely slow after installation
Summary: Extremely slow after installation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86 (IA32) Mac OS X (All)
: high critical
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-06 06:11 UTC by Italo Vignoli
Modified: 2011-05-17 07:30 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Italo Vignoli 2011-05-06 06:11:58 UTC
The first time you launch LO 3.4 Beta 3 the software is extremely slow, and it does not show the splash and the welcome screen but after a long while opens only the menu bar (giving the user the feeling that is not working). If you close the software and relaunch it a second (and all the subsequent) time, the speed and the behavior are correct (splash and welcome screen are displayed correctly).
Comment 1 Petr Mladek 2011-05-09 05:00:57 UTC
Italo, I see that you have added and removed it from the list of most annoying bugs #35673.

Was it by intention?
Are you able to reproduce the bug?
Do you see it only on MAC?
Comment 2 Alex Thurgood 2011-05-09 06:19:52 UTC
@Thorsten :

(In reply to comment #1)
> Italo, I see that you have added and removed it from the list of most annoying
> bugs #35673.
> 
> Was it by intention?
> Are you able to reproduce the bug?
> Do you see it only on MAC?

I have just noticed this with b4 on Mac OSX 10.6.7 after a clean install. In fact, I thought initially that the launch had stalled, the progress bar came up, got about a third of the way along, then disappeared, and LibO "seemed" to restart, redisplaying the progress bar, with progress jumping from 0 to mid-way and then to completion - very strange. The app did start in the end, although it is a bit confusing and I could understand why people might think it hadn't started.

Alex
Comment 3 Alex Thurgood 2011-05-09 06:30:15 UTC
I don't recall it disappearing from the dock though, so it must only be the progress bar that appears to be restarted...

Alex
Comment 4 Italo Vignoli 2011-05-09 08:03:29 UTC
I am actually installing beta 4 for Mac, to see if the problem is still there. With beta 3 for Mac the problem was easy to reproduce, as it happened after every installation.
I have not changed the status of the bug, though (filing a bug is already a HUGE task for a tech illiterate). As a general rule, when I file a bug it means that the problem is easy to see (otherwise I would not have seen it, and thought it was a feature), but should be double checked.
I don't know about other platforms. I am using Linux, but I am not able to install software if it is not in a repository (and betas, as far as I know, are not in repositories). I am not using Windows.
Comment 5 Petr Mladek 2011-05-09 12:13:53 UTC
Italo, do you see the same when you stop LO, remove user configuration and start it again?

It might be related to http://cgit.freedesktop.org/libreoffice/components/commit/?h=libreoffice-3-4&id=f6b3c7c837eec9f79e76c8e8587d9f635ff82203

LO register new extensions during the first start. The above commit added many dictionaries as extensions, ... In fact, I am not sure if it is a good idea to distribute all dictionaries (40MB) with the main installation set.
Comment 6 Italo Vignoli 2011-05-09 13:22:30 UTC
Yes, the problem happens again after each clean install. In my opinion, installing all these dictionaries without making the user aware is definitely not a good idea, because it is impossible to personalize the installation as in Windows (and it is quite annoying to go through the personalization process even in Windows).
Comment 7 Michael Meeks 2011-05-10 03:26:29 UTC
Andras - does that commit start to install all dictionaries for all locales ? rather than some sensibly limited subset ? if so, what is the thinking there ? can we revert that - or is this part of some master plan ?
Comment 8 Andras Timar 2011-05-10 03:52:08 UTC
(In reply to comment #7)
> Andras - does that commit start to install all dictionaries for all locales ?

No, it does not "start". It's only a side effect on Mac. On Windows we have been installing all dictionaries for all languages for a while.

> rather than some sensibly limited subset ? if so, what is the thinking there ?
> can we revert that - or is this part of some master plan ?

In fact I did not think of Mac. :( On Windows my commit had no effect. On Linux people can select what packages they want to install. I've never tried Mac. Is the setup not configurable on Mac?
Comment 9 Italo Vignoli 2011-05-10 05:59:24 UTC
Basic installation in MacOS is not configurable at all, and dictionaries cannot be uninstalled. Of the software I have installed, only MS Office can be personalized during install (and has a completely different procedure). You drag the icon on the Application folder, and the software is installed after a few seconds. Some other software have a longer process as they request to approve the license (for instance, NeoOffice) but they cannot be configured as well.
Comment 10 Petr Mladek 2011-05-12 10:23:36 UTC
It happens only during the first start. It is not visible on Linux and Windows, so it should not block the 3.4.0 release => lovering the severity a bit
Comment 11 Italo Vignoli 2011-05-12 10:41:20 UTC
I agree, but we should clearly tell Mac users about the weird behavior during the first start (according to the configuration of the Mac, the splash and the welcome screen show randomly, and the process might even hang resulting in LibreOffice never starting, although from the second launch on the behavior is normal and the speed is quite good).

We should solve, though, the fact that there are many useless dictionaries installed, which might be confusing for the basic user (when you choose the language of the document, the window is populated with all the dictionaries installed, and it looks weird to get selections like Zulu for people who are not proficient even in their native language).
Comment 12 Don't use this account, use tml@iki.fi 2011-05-12 16:40:55 UTC
Well, the fact is that there are a lot of languages out there, and I thought the Document Foundation was supposed to be language-neutral? Should we now start judging that some languages are "silly" and "exotic" and their dictionaries need not be included, even if somebody is contributing a such dictionary?

If it is the list of languaes to choose the document language from that annoys you, isn't the right solution then instead to enhance the UI, so that a must shorter list of most recently used languages is shown separately?
Comment 13 Italo Vignoli 2011-05-12 17:00:21 UTC
Sorry, I have made a wrong example, and I did not intend to discriminate any language (being a native speaker of a niche language). I would like to have a software that installs only the English dictionary, and let the user decide which other dictionaries he wants to install. I prefer to have a small installer than to have many useless dictionaries (for my needs, as I write only in English and Italian). As I understand that Italian is useful only for a limited number of people, I prefer to install it myself.
Comment 14 Don't use this account, use tml@iki.fi 2011-05-12 17:36:12 UTC
Ah, but isn't thinking English would be more important against the "The Next Decade Manifesto", http://wiki.documentfoundation.org/TDF/Next_Decade_Manifesto : "WE REJECT [...] the creeping domination of computer desktops by a single language forcing people to learn a foreign language before they can express themselves electronically"?

So are we back then at the discussion that we should offer separate and equal valued installers/packages/bundles/whatever for each and every UI language, and for each and every dictionary?
Comment 15 Italo Vignoli 2011-05-12 18:12:52 UTC
If I can personalize the installation as it happens in Windows or I can decide which languages to install as it happens in Linux (using the packages in the repositories), I would not object about the packaging. But on Macintosh you cannot personalize the installation or get rid of the useless dictionaries, and you end up having dozens of dictionaries installed which are never going to be used.

Being a basic user, I definitely prefer the option of deciding myself the dictionaries that I want to install, in order to have a better control of my setup.

By the way, LibreOffice 3.4 on Mac installs only dictionaries and does not install any other extension (as it was happening with LibreOffice 3.3.2).
Comment 16 Thorsten Behrens (CIB) 2011-05-17 07:30:58 UTC
Should be fixed for the next 3.4 build