Download it now!
Bug 36974 - Use Ctrl+H for "Find & Replace"
Summary: Use Ctrl+H for "Find & Replace"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Jan Holesovsky
URL:
Whiteboard: target:3.4.6 target:3.5.0 target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-08 11:39 UTC by Jeremy Bicha
Modified: 2012-05-09 10:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Bicha 2011-05-08 11:39:34 UTC
Ctrl+H is the standard keyboard shortcut for "Find & Replace".

https://office2010.microsoft.com/en-us/word-help/keyboard-shortcuts-for-microsoft-word-HP010370109.aspx

http://windows.microsoft.com/en-US/Windows7/Keyboard-shortcuts (WordPad)

http://developer.gnome.org/hig-book/stable/input-keyboard.html.en#standard-shortcuts

There are two exceptions I've found: KDE uses Ctrl+R for some reason and it appears like Mac generally uses a unified Find/Find & Replace so they just use Cmd+F.

http://developer.kde.org/documentation/standards/kde/style/keys/shortcuts.html

http://support.apple.com/kb/ht1343
Comment 1 Noel Power 2011-05-09 11:57:45 UTC
assigning to kendy to assess
Comment 2 Rainer Bielefeld Retired 2012-04-11 05:44:58 UTC
It seems that that has been introduced in between (at least I see that shortcut in "LibreOffice 3.5.2.2 English UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) 
and
 parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-08 00:03:52)

But Help is wrong, I find:
Ctrl+F  --  Calls the Find & Replace dialog.
should be:
Ctrl+H  --  Calls the Find & Replace dialog.

for me it's not very intuitive that <Ctrl+Shift+F> remained "Searches for the last entered search term".

In German UI the  Find & Replace shortcut is completely missing, and the same mistake in Help

On French UI the  Find & Replace works, but wrong description in Help (I believe Help will be wrong in all Languages).

@David:
Can you please repair Help?
Comment 3 Korrawit Pruegsanusak 2012-05-09 01:02:18 UTC
(In reply to comment #2)
> It seems that that has been introduced in between (at least I see that shortcut
> in "LibreOffice 3.5.2.2 English UI/Locale [Build-ID:
> 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) 
> and
>  parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium
> (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox:
> Win-x86@6-fast pull time 2012-04-08 00:03:52)

I confirm that on 3.5.3.1 Windows XP, Ctrl+H triggers Find & Replace dialog.

> But Help is wrong, I find:
> Ctrl+F  --  Calls the Find & Replace dialog.
> should be:
> Ctrl+H  --  Calls the Find & Replace dialog.

Fixed.
Comment 4 Not Assigned 2012-05-09 01:08:48 UTC
Korrawit Pruegsanusak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=d8784f784341a01acb5714e208ee6f91021370ca

fdo#36974: Ctrl+H triggers Find and Replace dialog
Comment 5 Korrawit Pruegsanusak 2012-05-09 01:17:04 UTC
For a record, Andras Timar's commit change Ctrl+Alt+F to Ctrl+H since 2011-09-14.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a75cb232c41b9f895e27dd85532ff624f85181de
Comment 6 Korrawit Pruegsanusak 2012-05-09 05:01:12 UTC
Also in libreoffice-3-4: http://cgit.freedesktop.org/libreoffice/libs-core/commit/?h=libreoffice-3-4&id=3bb279c73e0034c7c50e5561de82c681a2f3b3b9 => in 3.4.6 RC1

Comment 5, in master before libreoffice-3-5 branching => in 3.5.* since first release and in 3.6 too.
Comment 7 Not Assigned 2012-05-09 09:18:14 UTC
Korrawit Pruegsanusak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e81c1f4b97088e19078400a938ff8ea4a94f03a1

fdo#36974: Last Ctrl+F to Ctrl+H change for Find & Replace dialog
Comment 8 Korrawit Pruegsanusak 2012-05-09 10:11:37 UTC
(In reply to comment #2)
> for me it's not very intuitive that <Ctrl+Shift+F> remained "Searches for the
> last entered search term".

IMHO the best place to talk about this is libreoffice-ux-advise@lists.freedesktop.org

> In German UI the  Find & Replace shortcut is completely missing, and the same
> mistake in Help

If it's still reproducible, I think you know what to do ;)

> On French UI the  Find & Replace works, but wrong description in Help (I
> believe Help will be wrong in all Languages).

Yes, it is wrong in all languages, and it will be correct in (at least) 3.6 if translators do their jobs.