Bug 37001 - Update license text on libo site
Summary: Update license text on libo site
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: sophie
URL:
Whiteboard:
Keywords:
: 33680 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-09 03:12 UTC by Thorsten Behrens (CIB)
Modified: 2011-05-24 04:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Draft html version (461.96 KB, text/html)
2011-05-09 03:12 UTC, Thorsten Behrens (CIB)
Details
Plain text version (418.38 KB, text/plain)
2011-05-09 03:13 UTC, Thorsten Behrens (CIB)
Details
re-edited license file (60.28 KB, application/vnd.oasis.opendocument.text)
2011-05-11 13:00 UTC, Andras Timar
Details
New License document (112.17 KB, application/vnd.oasis.opendocument.text)
2011-05-21 10:00 UTC, Andras Timar
Details
Proof readed document (109.81 KB, application/vnd.oasis.opendocument.text)
2011-05-22 05:47 UTC, sophie
Details
THIRDPARTYLICENSEREADME.html (521.57 KB, text/html)
2011-05-22 12:13 UTC, Andras Timar
Details
license.txt (348.95 KB, text/plain)
2011-05-22 12:17 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Behrens (CIB) 2011-05-09 03:12:25 UTC
Created attachment 46471 [details]
Draft html version

The download contains other potentially differently-licensed stuff, first draft html version attached.
Comment 1 Thorsten Behrens (CIB) 2011-05-09 03:13:13 UTC
Created attachment 46472 [details]
Plain text version

Plain text version, if that should be easier
Comment 2 Noel Power 2011-05-10 02:56:22 UTC
sohie for you? ( if not then of course please re-assign back to the list )
Comment 3 sophie 2011-05-10 10:14:39 UTC
ok, I take it, thanks - Sophie
Comment 4 Andras Timar 2011-05-11 02:32:20 UTC
There are problems with the contents, not only the formatting.

I opened a bug a while ago:
https://bugs.freedesktop.org/show_bug.cgi?id=33680
I think this bug is duplicate of that. I started to work on it, Sophie. Can we work together? I can send you a new draft soon. Or I can finish my work, and you review it. Whatever is more convenient.
Comment 5 Andras Timar 2011-05-11 13:00:15 UTC
Created attachment 46616 [details]
re-edited license file

I was thinking about this structure.
Comment 6 sophie 2011-05-11 22:04:21 UTC
(In reply to comment #5)
> Created an attachment (id=46616) [details]
> re-edited license file
> 
> I was thinking about this structure.

Thanks for your work on it, just review it and it's good for me, clean and clear :) It seems we still miss information about Artwork or do you avoid it intentionally? Sophie
Comment 7 Andras Timar 2011-05-15 14:40:29 UTC
(In reply to comment #6)
> Thanks for your work on it, just review it and it's good for me, clean and
> clear :) It seems we still miss information about Artwork or do you avoid it
> intentionally? Sophie

I'm aware of KDE Crystal theme icons. If you know about more, I'll add them.
Comment 8 Andras Timar 2011-05-21 09:59:08 UTC
ChangeLog:

Original LICENSE.odt contains the following but LibreOffice does not contain them:
Anti-Grain Geometry (agg), Bitstream Vera Fonts, Charis SIL v.4, GPC (general polygon clipper), libegg, libmspack, NeoLight, Network Audio System (NAS), PortAudio, PostgreSQL Database Management System, regexp, Sablotron, XT. -> removed

Original LICENSE.odt does not contain the following but LibreOffice contains them:
Apache Commons, Apache Jakarta Tomcat, Deja Vu font, flute, gdiplus, Gentium font, graphite, hunspell, hyphen, libwpg, libwps, Linux Biolinum G font, Linux Libertine G font, lucene, mdds, mysqlcppconn , mythes, Pentaho Reporting Flow Engine, Pixman, Raptor, Rasqal, Redland, W3C Simple API for CSS (SAC), xsltml -> added

Original LICENSE.odt does not contain copyright notices and licenses for all dictionaries -> added

Original LICENSE.odt does not contain copyright notices and licenses for 3rd party extensions -> added
Comment 9 Andras Timar 2011-05-21 10:00:32 UTC
Created attachment 46976 [details]
New License document

@sophi: Can you please review. It would be fantastic, if we could include this into 3.4.
Comment 10 Andras Timar 2011-05-21 10:43:59 UTC
*** Bug 33680 has been marked as a duplicate of this bug. ***
Comment 11 sophie 2011-05-22 05:47:05 UTC
Created attachment 47000 [details]
Proof readed document
Comment 12 Andras Timar 2011-05-22 12:13:37 UTC
Created attachment 47013 [details]
THIRDPARTYLICENSEREADME.html
Comment 13 Andras Timar 2011-05-22 12:17:36 UTC
Created attachment 47014 [details]
license.txt 

Proofread odt should replace readlicense_oo\odt\LICENSE.odt
THIRDPARTYLICENSEREADME.html should go to readlicense_oo\html\
license.txt should go to readlicense_oo\txt\
Comment 14 Korrawit Pruegsanusak 2011-05-23 10:51:24 UTC
May I have some suggestions?

1. The plain text version should not contain 'Jump to ...', because it cannot jump! But how to make the user navigate to the relevant license? Let they Ctrl+F?

2. Some 'Jump to ...' ends with dot, some not. I think it shouldn't.

3. Encoding defined in .txt is incorrect(?) I download to my Ubuntu 10.10 GNOME 2.32.0 and gedit says that
  Could not open the file [path-to-file]
  gedit has not been able to detect the character encoding.
  ...
Anyone with this problem?

Also, encoding in .html is incorrect. Notice the names Dabaros in Extensions > Barcode > Copyright @ ... (line 2335 in txt)[*] and other questionmark-ed symbol.
So, both .html and .txt file should use utf-8 encoding, IMHO. What do you think?

4. Some texts are in bigger fonts, some smaller; some monospace, some serif. Do these necessary? Could we change most of them (with some exceptions) to one size and one font for consistency? If so, what are exceptions?

If you agree with me, I can help :-)

[*] Is the original use "Copyright @ ..", not "Copyright (c) ..."? I can't find it.
Comment 15 Andras Timar 2011-05-23 11:26:51 UTC
(In reply to comment #14)
> May I have some suggestions?

Many thanks for your comments. I was in a rush to finish this by 3.4.0, but it seems I was late, so we have to time make it better. It is still way better than the old version. :)

1. First of all we should consider if we need txt version at all. I think ODT would be enough, even HTML is not necessary. But this change would need too many changes in code, so it's impossible for 3.4.x.

2. I agree, I'll make them uniform.

3. Encoding was windows-1250, should be utf-8. Copyright @ is a typo. HTML should be in utf-8, too.

4. See the original ODT, it looks the best. HTML export looks somewhat worse. I can fine-tune the HTML stylesheet, if we decide that we keep HTML format, too.
Comment 16 Michael Meeks 2011-05-24 02:23:34 UTC
Interesting - in the past Sophie & others had strongly resisted any explanatory English text apart from the licenses itself. Personally I think (since the licenses are necessarily English) that is a mistake and I love the new structure.

We should get this into 3.4 - but Andras - it would -really- help if this was a git commit on master that we could just cherry-pick; can you get it there fast ?

I assume we have review / approval from Sophie, Andras, and Myself - one more and we can get it into 3.4 - but I'd prefer to review a commit.
Comment 17 Andras Timar 2011-05-24 03:11:29 UTC
> I assume we have review / approval from Sophie, Andras, and Myself - one more
> and we can get it into 3.4 - but I'd prefer to review a commit.


http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=fde37c1a38273e7a90bb6d26cd1c948e8fe63783
Comment 18 Korrawit Pruegsanusak 2011-05-24 03:49:57 UTC
Do I come too late?

I've noticed that Sophie has changed a ` (grave accent) to ' (apostrophe) in Page 9 (`FTL.TXT' to 'FTL.TXT') in ODT
But I have found that there are many `` (2 grave accents consecutively, not double grave) left in the file. Such as ``AS IS''

Anyway, I've found that, for example, GPLv3 use this convention too. Such as `show c'

Does this a formal and international convention? If not, will we change it to apostrophe?
Comment 19 Andras Timar 2011-05-24 04:01:13 UTC
(In reply to comment #18)
Your suggetions from Comment 14 have been implemented in the commit. Can you please take the files from cgit (see the commit link above), those are the latest versions. 

I agree that licenses are not masterpieces of typography. Most of them were in plain ASCII originally, therefore grave accent was used instead of starting curly quote (apostrophe) and so on. If you have time, you can improve these documents, we will review your work and commit your patches.