Bug Hunting Session
Bug 37003 - FILEOPEN particular .odt with formula object crashes
Summary: FILEOPEN particular .odt with formula object crashes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: medium major
Assignee: Cédric Bosdonnat
URL:
Whiteboard: target:3.5.0
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-09 03:59 UTC by bellgardt
Modified: 2011-12-01 11:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file for formula crash (40.81 KB, application/vnd.oasis.opendocument.text)
2011-05-09 04:02 UTC, bellgardt
Details
MacOS X crash log for bug 37003, LibreOffice 3.4.4 (46.18 KB, text/plain)
2011-12-01 10:47 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bellgardt 2011-05-09 03:59:45 UTC
After double clicking on a formula object writer crashes (see sample file). In the sample file only the formulas (2) and (27) are concerned. The document came originally form MS-Word but was maintained for a long time without problems by OOo up to Version 2.4.3
Comment 1 bellgardt 2011-05-09 04:02:05 UTC
Created attachment 46473 [details]
Sample file for formula crash
Comment 2 Rainer Bielefeld Retired 2011-05-19 08:38:06 UTC
[Reproducible] with reporter's sample document (I opened it from WIN Explorer by double click) and "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:5)]". LibO crashes immediately, before the document will have been opened.

OOo 3.1.1 opens sample document without problems.

Crash remains after I saved Document from OOo 3.1.1.

Crash vanished after I had deleted all Math objects from document.

bellgardt@iftc.uni-hannover.de:
What WIN did you use?
Comment 3 Rainer Bielefeld Retired 2011-05-19 08:44:23 UTC
Formulas 2 and 27 also cause problems with OOo 3.1.1. I was able to edit formula 1, but not 2, 27.

Currently I can't see that many users might be affected, so Prio Critical -> Major
Comment 4 bellgardt 2011-05-20 03:24:14 UTC
(In reply to comment #2)
> [Reproducible] with reporter's sample document (I opened it from WIN Explorer
> by double click) and "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit)
> German UI [DEV300m103 (Build:5)]". LibO crashes immediately, before the
> document will have been opened.
> 
> OOo 3.1.1 opens sample document without problems.
> 
> Crash remains after I saved Document from OOo 3.1.1.
> 
> Crash vanished after I had deleted all Math objects from document.
> 
> bellgardt@iftc.uni-hannover.de:
> What WIN did you use?

My system is Windows Vista Home premium SP2
Comment 5 tester8 2011-07-03 10:11:26 UTC
Reproduced with

LO 3.4.1 (OOO340m1 (Build:101))
Ubuntu 10.04.2 x86
Linux 2.6.32-32-generic Russian UI

Crashs after attempt to editing formulae (2) or (27).
Comment 6 Rainer Bielefeld Retired 2011-11-09 23:05:13 UTC
@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 7 Roman Eisele 2011-12-01 10:46:29 UTC
Bug reproducible with LibreOffice 3.4.4 with German langpack installed running on MacOS X 10.6.8 German. Just opening the document and double-clicking on formula (2) or (27) causes LibreOffice to crash. I will attach the MacOS X crash-log file -- maybe it helps figuring out what causes the crash ...

BUT no longer reproducible with current master:
LibO-dev 3.5.0 
Build ID: 549f928-b211287-090bcba-45cf606
build date 2011-12-01
no langpack installed
running on MacOS X 10.6.8 German.
With the current master build, everything works for me as expected (double-clicking the formular allows editing it, no crash).

Therefore, it looks like this bug was fixed in between on master ...

@ bellgardt@iftc.uni-hannover.de:
Could you please test your original document again with a recent master build to see if the problem is really fixed on master? This would be very interesting ...
Comment 8 Roman Eisele 2011-12-01 10:47:43 UTC
Created attachment 54030 [details]
MacOS X crash log for bug 37003, LibreOffice 3.4.4
Comment 9 Rainer Bielefeld Retired 2011-12-01 11:01:32 UTC
No longer  with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) GERMAN UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe - 111130)

@reporter / all
please feel free to rreopen if bug reappears in Master.