Bug Hunting Session
Bug 37008 - Staroffice-Import-filters <= 5.0 unavailable
Summary: Staroffice-Import-filters <= 5.0 unavailable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta4
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-05-09 04:31 UTC by Johannes Weberhofer
Modified: 2016-07-12 18:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sampl SDW file from /git/libo/clone/testing/testautomation/writer/optional/input/export/sdw (100.91 KB, application/x-starwriter)
2011-05-09 09:25 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Weberhofer 2011-05-09 04:31:45 UTC
Similar to Bug 33135, there are no import-filters available for the OSX version.
Comment 1 Alex Thurgood 2011-05-09 05:59:37 UTC
My understanding was that the binfilter read capability was still there, just the write functionality had been removed ?


Alex
Comment 2 Alex Thurgood 2011-05-09 06:06:06 UTC
I can not confirm with beta4 on Mac OSX 10.6.7. If I start LibO, press Cmd-O and then look at the list of available filters instead of just *.* in the dropdown menu, I can see all the OOo 1.x format filters. 


Or is it that they just don't work for you ?


Alex
Comment 3 Alex Thurgood 2011-05-09 06:11:15 UTC
I have just tested sxc import and it works for me on beta4. You should, if you haven't done so already, delete or rename your /Users/Library/Application Support/LibreOffice folder, and then restart LibO b4 to see if that makes a difference.


Alex
Comment 4 Alex Thurgood 2011-05-09 06:12:51 UTC
setting as WFM, please re-open if you believe this to be incorrect, or have other information to add.
Comment 5 Alex Thurgood 2011-05-09 06:31:11 UTC
FWIW, I also tried several SXD and SXW files, which imported fine.

Alex
Comment 6 Alex Thurgood 2011-05-09 06:31:57 UTC
closing, WFM.
Comment 7 Johannes Weberhofer 2011-05-09 08:36:45 UTC
I see OO1 .sxw and .sxd filters, but I do not see Staroffice .scd and .sdw Filters
Comment 8 Alex Thurgood 2011-05-09 09:12:31 UTC
Confirming with respect to SDC format. This is also a regression compared to 3.3.2 which opens SDC (StarOffice 5) fine. Need to try and find a SDW file.


Alex
Comment 9 Alex Thurgood 2011-05-09 09:14:38 UTC
If you try and open a SDC file from the Finder, LibO tries to open the file (probably inspecting file contents), but fails and then displays the ASCII import filter dialog. If you cancel this, then the user is asked to choose a filter, but of course the correct one is not available in the list.


Alex
Comment 10 Alex Thurgood 2011-05-09 09:15:58 UTC
Changing title of bug to reflect updated information.

Alex
Comment 11 Alex Thurgood 2011-05-09 09:21:38 UTC
Which other formats do not work ? All of the filters <= StarOffice 5.0 ?


Alex
Comment 12 Alex Thurgood 2011-05-09 09:25:11 UTC
Created attachment 46487 [details]
Sampl SDW file from /git/libo/clone/testing/testautomation/writer/optional/input/export/sdw
Comment 13 Alex Thurgood 2011-05-09 09:26:08 UTC
Nominating for 3.4 most annoying bug.

Alex
Comment 14 Alex Thurgood 2011-05-09 09:38:07 UTC
Changed title again, I have now tested StarOffice 3, 4 and 5, and template files. None of them will open in beta4, whereas they all open in 3.3.2.


Alex
Comment 15 Andras Timar 2011-05-09 10:07:26 UTC
Same on Windows. Binfilter is missing.
Comment 16 Thorsten Behrens (CIB) 2011-05-10 02:11:39 UTC
Meh, sorry, build config changed w/o me realizing - updated builder config, watch out for the next mac daily, that should have it.
Comment 17 Thorsten Behrens (CIB) 2011-05-10 02:13:45 UTC
Andras, I suggest to have a separate bug for win32 - as the fix is not the same.
Comment 18 Thorsten Behrens (CIB) 2011-05-10 15:42:56 UTC
Alex, you may want to look at this build: http://dev-builds.libreoffice.org/daily/Mac_OSX_10.6.0_gcc-4.0.1_%28x86%29/libreoffice-3-4/current/ (haven't had the time to verify yet).
Comment 19 Johannes Weberhofer 2011-05-10 21:29:02 UTC
Thank yoo, it works nicely now. Shall I still open a bug for windows?
Comment 20 Thorsten Behrens (CIB) 2011-05-11 00:25:59 UTC
yes please, and assign it to fridrich.strba@bluewin.ch