Download it now!
Bug 37012 - DOCX import: Header/Footer, page number missing
Summary: DOCX import: Header/Footer, page number missing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2011-05-09 05:48 UTC by Tobias Burnus
Modified: 2012-05-03 03:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test .docx (23.91 KB, application/vnd.openxmlformats-officedocument.wordprocessing)
2011-05-09 05:48 UTC, Tobias Burnus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2011-05-09 05:48:38 UTC
Created attachment 46479 [details]
Test .docx

Compared with the display under Word 2003+OOX extension, LibreOffice 3.4b3 has:

- No page number (Word shows it in the middle of the footer)
- No header/footer on the second page (Word shows the same header/footer as on page 1 also after the section break)

Regarding the second issue: seemingly, Word uses the "default" type (file header2.xml/footer2.xml) for all pages.

In Document.xml:

<w:sectPr w:rsidR="00DD70C3" w:rsidRPr="00C01F69" w:rsidSect="008552FC">
  <w:headerReference w:type="even" r:id="rId7"/>
  <w:headerReference w:type="default" r:id="rId8"/>
  <w:headerReference w:type="first" r:id="rId11"/>
  <w:footerReference w:type="even" r:id="rId9"/>
  <w:footerReference w:type="default" r:id="rId10"/>
  <w:footerReference w:type="first" r:id="rId12"/>

_rels/document.xml.rels has:

<Relationship Id="rId7"  Type=".../header" Target="header1.xml"/>
<Relationship Id="rId8"  Type=".../header" Target="header2.xml"/>
<Relationship Id="rId11" Type=".../header" Target="header3.xml"/>
<Relationship Id="rId9"  Type=".../footer" Target="footer1.xml"/>
<Relationship Id="rId10" Type=".../footer" Target="footer2.xml"/>
<Relationship Id="rId12" Type=".../footer" Target="footer3.xml"/>
Comment 1 Noel Power 2011-05-10 04:39:17 UTC
(In reply to comment #0)
> Created an attachment (id=46479) [details]

> Regarding the second issue: seemingly, Word uses the "default" type (file
> header2.xml/footer2.xml) for all pages.

if there is a second issue then please please use a separate bug. It just makes things very much less confusing
Comment 2 Björn Michaelsen 2011-12-23 12:02:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Björn Michaelsen 2011-12-23 17:01:24 UTC
needinfo keyword redundant by needinfo status.
Comment 4 Roman Eisele 2012-05-03 03:57:19 UTC
Bug is NOT reproducible anymore with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80), German langpack installed, running on MacOS X 10.6.8 German UI. It was most likely fixed in the 3.5.x development process (many DOCX related problems have been fixed now).

The only remaining issue is that the page number (now present) in the footer is not centered (like mentioned in the description) but left-aligned; but this is a separate and minor issue different from the current one. (We may create a special bug report for the mis-alignment, if necesssary).

Therefore I close this bug report. Feel free to open it again if the issue is still reproducible for you.

-- Changing 'Status' to RESOLVED/WORKSFORME.
-- Improved 'Component', 'Version' etc. according to original description.
-- Added to new meta-bug, just out of historical interest: it is not only important to see the open header/footer bugs, but also to see which header/footer bugs are fixed now.