Bug 37064 - Printing dialog settings are not persistent
Summary: Printing dialog settings are not persistent
Status: RESOLVED DUPLICATE of bug 33245
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-10 04:14 UTC by bellgardt
Modified: 2011-05-24 04:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bellgardt 2011-05-10 04:14:14 UTC
Most (it not all) of the settings in the print dialogs (tested for writer and impress) are not saved, e.g. selected printer model and most print options. This is very annoying especially in impress, because for every print again many options on several tabs must be set again (e.g. printer model, slides/handouts/notes, hidden slides and so on).

The desired behavior as in earlier versions of OOo should be to save all (!) or as many as possible of those settings not only within one editing session but also permanently together with the document. 

Before, also the settings of the printer model related dialogs (eg. resolution, color settings) were kept within an editing session. This function should also be restored and - if possible - extended to save those information also in the document.
Comment 1 Noel Power 2011-05-10 13:29:30 UTC
setting as enhancement, personally I like the idea of the setting saved in the editing session but I am not a fan of saving them in the document.
Comment 2 bellgardt 2011-05-11 00:07:09 UTC
(In reply to comment #1)
> setting as enhancement, personally I like the idea of the setting saved in the
> editing session but I am not a fan of saving them in the document.

Why this should be an enhancement, in the old printing dialog it was a feature that is lost now. All important settings in the printing dialog (printer model) including those behind the button "options" (that sub-dialog contained check boxes for slide/handout/notes, hidden slides, color and so on) were saved per document! So I would call it a bug which makes it much more troublesome than before to work with LO. I can't see a reason why that worked before but should be an implementation problem now.

I agree with you that my idea of also saving the printer model related settings to the document is too far-reaching. This would restrict the portability of the document and make it OS-dependent if not even machine dependent.
Comment 3 Noel Power 2011-05-11 07:20:51 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > setting as enhancement, personally I like the idea of the setting saved in the
> > editing session but I am not a fan of saving them in the document.
> 
> Why this should be an enhancement, in the old printing dialog it was a feature
> that is lost now. 
well from your comments I took it that this was something that existed before but was removed ( somehow I took it that the removal and change of behaviour was intentional ) a long time ago. Is that the case do you know?
Comment 4 bellgardt 2011-05-11 09:00:19 UTC
> well from your comments I took it that this was something that existed before
> but was removed ( somehow I took it that the removal and change of behaviour
> was intentional ) a long time ago. Is that the case do you know?

The new extended printing dialog replacing the "old" one was introduced somewhere in OOo/LO 3.x, but I don't remember in which x, because I skipped using the earlier version which were very buggy. May be it was version 3.2. But I don't think it was the intention to drop the function of saving the print settings. This is a very common feature in many Windows programs. This function is needed much more if you have many options as in the Impress print dialog.
Comment 5 Jaap Stolk 2011-05-24 04:31:09 UTC
I have a similar problem with landscape/portrait selection.
I found 4 bug reports (33245,33861,36591,37064) witch all seem to be a result of the printer-dialogue loosing it's settings, So I marked the last 3 as duplicates of the first one.
Also, my problem seems to be fixed in the current Beta release (LibreOffice 3.4.0 DEV300m103 (Build:5) Windows XP 32-bit), so please check if this is still a problem in the latest beta release.

*** This bug has been marked as a duplicate of bug 33245 ***