Bug 37077 - UI: Extremely annoying flickering problem in Writer
Summary: UI: Extremely annoying flickering problem in Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-10 10:28 UTC by gleppert
Modified: 2011-12-22 05:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Extremely-annoying-display-flickering.odt (359.71 KB, application/vnd.oasis.opendocument.text)
2011-05-10 10:28 UTC, gleppert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-05-10 10:28:54 UTC
Created attachment 46557 [details]
Extremely-annoying-display-flickering.odt

With several documents in Writer, I encounter a serious flickering problem. It is very annoying as it does not stop for many seconds or even minutes. It makes it simply impossible to work with Writer during that time.

Please have a look at the funny video of my screen. You can download the video via following link during the next two weeks:
https://www.wetransfer.com/dl.php?code=jUEN1q63&hash=c00c9bc09a8c0f27a15ead4d557612b166a2ad8f9003654c219c1e3c71f316d5b650e9cb9c3eb5

How to reproduce:
* Please open attached file in Writer by double clicking on the file. (The file is just an example. The problem is also there with other files).
* Click with the mouse in the first heading called "1.Introduction" (the heading just under the TOC) so that you see the cursor there.
* Open the format templates with the key F11 and the format template manager will open
* Now click on the icon "New" in order to create a new Writer file.
* Writer starts to flicker like crazy!!

Reproducible: Always


System: Ubuntu 10.10/Gnome 2, LibreOffice 3.3.2 PPA, German UI, Intel 32-Bit.
Comment 1 Noel Power 2011-05-10 13:37:48 UTC
well I can't reproduce this but then again I am testing with the 3.4 Beta4 release, perhaps you could try with that version
Comment 2 gleppert 2011-05-10 13:53:14 UTC
@Noel: Sorry I cannot test the Beta, because I need LibreOffice for everyday work. As far as I have seen, LO 3.4Beta overwrites my stable installation and there is no way to have it installed separately like it was possible with OOO-dev. Please see bug https://bugs.freedesktop.org/show_bug.cgi?id=36437

Sorry, can anyone else test this bug on a beta version of LO in Ubuntu? Thanks a lot!
Comment 3 Rainer Bielefeld Retired 2011-05-10 22:24:46 UTC
Not reproducible with "LibreOffice 3.4Beta4  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:4)]", might be Linux related.
Comment 4 Noel Power 2011-05-11 02:28:05 UTC
adding bjoern to cc ( might have some idea if this is ubuntu specific )
Comment 5 Cor Nouws 2011-05-16 07:29:20 UTC
hi guys,
Easy to reproduce for me on Ubuntu 11.04 (Unity) & 340beta5.

- Open existing writer document
  - if not yet open, start navigator
  - if not yet docked, dock the navigator
- Ctrl-N for new document
  > main tool bars + navigator toolbar are refreshed several times
    which is the flickering

Now do the same in 3.3.2
  > only one fast refresh
Comment 6 Cor Nouws 2011-05-16 07:36:47 UTC
(since beta1 and beta2 did not run for me on Ubuntu, I cannot test those)
Comment 7 Michael Meeks 2011-05-17 22:37:30 UTC
Can't reproduce around the RC1 vintage on my machine - Bjoern - is there some Ubuntu-ness that might cause this grief: perhaps the Unity menu integration stuff ?
Comment 8 Cor Nouws 2011-05-18 00:47:24 UTC
(In reply to comment #7)
> Can't reproduce around the RC1 vintage on my machine 

just tested nightly build 2011-05-17: flickering is gone there
Comment 9 Björn Michaelsen 2011-05-18 01:31:52 UTC
Not reproducable here on libreoffice-3.3.2-1ubuntu5 main (including libreoffice/build patches) on 11.04 with Unity.

(In reply to comment #7)
> Can't reproduce around the RC1 vintage on my machine - Bjoern - is there some
> Ubuntu-ness that might cause this grief: perhaps the Unity menu integration
> stuff ?

Not that I would think -- no additional vendor patching in that area. Also the original report is on 10.10, which has no Unity Desktop (also the screencast is classic Gnome). Current triage roundup:
- observable with 3.3.2 PPA (including libreoffice/build patches) on Ubuntu 10.10
- not observable with 3.3.2 main (including libreoffice/build patches) on Ubuntu 11.04 with Unity
- observable on 3.4.0 beta5 (without any vendor patches) on Ubuntu 11.04 (Unity)
- not observable on 3.4.0-nightly2011-05-17

Seems to me to be a bug introduced by libreoffice/build patches and subsequently fixed. Only my own observation does not fit this theory: if this is a Heisenbug, triaging will be a lot harder.
Comment 10 gleppert 2011-05-21 12:08:11 UTC
In LibreOffice 3.4 rc 1, this bug is still there. Extreme flickering like in the previous versions.
Comment 11 Cor Nouws 2011-05-21 14:04:04 UTC
(In reply to comment #10)
> In LibreOffice 3.4 rc 1, this bug is still there. Extreme flickering like in
> the previous versions.

Cannot reproduce it - nor the way I did it in a previous version, nor the way you give in your first description.
Comment 12 gleppert 2011-07-02 10:25:37 UTC
Tested this again on my computer. In the meanwhile I updated to Ubuntu 11.04, gnome2, and LibreOffice 1:3.3.3-1ubuntu1 from the PPA. The flickering problem is now also gone here.

As Cor was the only person who could reproduce the bug in comment 5 and now the issue of flickering is also solved on his computer, I close this bug as resolved WORKSFORME.

Thanks for testing and fixing!
Comment 13 Cor Nouws 2011-07-07 03:58:14 UTC
@gleppert: thanks for reporting back!
Comment 14 Björn Michaelsen 2011-12-22 05:53:26 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.