Download it now!
Bug 37093 - FILESAVE crash when save as
Summary: FILESAVE crash when save as
Status: RESOLVED DUPLICATE of bug 31109
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-11 01:22 UTC by dietmar.mueller
Modified: 2011-05-20 00:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
doc where lo with save as crash (50.54 KB, application/vnd.oasis.opendocument.text)
2011-05-12 00:02 UTC, dietmar.mueller
Details
backtrace (1.66 KB, application/x-tar)
2011-05-12 07:21 UTC, dietmar.mueller
Details
valgrid (3.40 KB, application/x-tar)
2011-05-12 07:27 UTC, dietmar.mueller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dietmar.mueller 2011-05-11 01:22:40 UTC
When I "save as" LO crash

kde crashmanager show:

[Thread debugging using libthread_db enabled]
[KCrash handler]
#5  0x0000003593607a38 in pthread_join () from /lib64/libpthread.so.0
#6  0x00002b95c9888a4c in ?? ()
   from /opt/libreoffice/program/../basis-link/ure-link/lib/libuno_sal.so.3
#7  0x00002b95c985f4f2 in getservbyname ()
   from /opt/libreoffice/program/../basis-link/ure-link/lib/libuno_sal.so.3
#8  0x00007fff259c2dd0 in ?? ()
#9  0x00002b95c9891f31 in getservbyname ()
   from /opt/libreoffice/program/../basis-link/ure-link/lib/libuno_sal.so.3
#10 0x0000000000000000 in ?? ()

OS: CenOs/SL 5.5

Linux kbhws18 2.6.18-238.9.1.el5 #1 SMP Tue Apr 12 18:53:46 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

libreoffice3-writer-3.3.2-202
Comment 1 gleppert 2011-05-11 23:55:15 UTC
Dear Dietmar, does it crash with any file or only with particular files? Could you please attach an example file to the bug report. Thank you.

Then, we can try to reproduce your problem.
Comment 2 dietmar.mueller 2011-05-12 00:02:22 UTC
Created attachment 46624 [details]
doc where lo with save as crash

in past this file was created from an doc in oo v 1 or 2
Comment 3 gleppert 2011-05-12 00:12:10 UTC
Tested your file on my computer. I don't have any crash.

I downloaded the attached file
I double clicked on it
I saved this file as 
I tried the same five times (odt,doc,ott,sxw,docx)
No crash here

Do you do something else to reproduce the crash?

System: Ubuntu 10.10/gnome2, LibreOffice PPA 3.3.2, German UI, 32-Bit Intel
Comment 4 dietmar.mueller 2011-05-12 00:22:30 UTC
no, exact the same way. I don't get the mask to choose the format or the filename.

The System is differ:
CentOS 5.6 with KDE and 64Bit

LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 5 dietmar.mueller 2011-05-12 00:34:28 UTC
strace ends with:

read(39, "\0\0@\17\0\0\1\21\0\0\0$\0\0\0$Alle Dateien (*."..., 1024) = 1024
write(43, "appendControl 100 \"checkbox\" \"Au"..., 68) = 68
write(43, "appendControl 101 \"checkbox\" \"~M"..., 55) = 55
write(43, "appendControl 102 \"checkbox\" \"Fi"..., 63) = 63
write(43, "appendFilter \"ODF Textdokument ("..., 47) = 47
write(43, "appendFilter \"ODF Textdokumentvo"..., 54) = 54
write(43, "appendFilter \"OpenOffice.org 1.0"..., 62) = 62
write(43, "appendFilter \"OpenOffice.org 1.0"..., 69) = 69
write(43, "appendFilter \"Microsoft Word 97/"..., 56) = 56
write(43, "appendFilter \"Microsoft Word 95 "..., 48) = 48
write(43, "appendFilter \"Microsoft Word 6.0"..., 49) = 49
write(43, "appendFilter \"Rich Text Format ("..., 47) = 47
write(43, "appendFilter \"StarWriter 5.0 (.s"..., 45) = 45
write(43, "appendFilter \"StarWriter 5.0 Vor"..., 53) = 53
write(43, "appendFilter \"StarWriter 4.0 (.s"..., 45) = 45
write(43, "appendFilter \"StarWriter 4.0 Vor"..., 53) = 53
write(43, "appendFilter \"StarWriter 3.0 (.s"..., 45) = 45
write(43, "appendFilter \"StarWriter 3.0 Vor"..., 53) = 53
write(43, "appendFilter \"Text (.txt)\" \"*.tx"..., 35) = 35
write(43, "appendFilter \"Text Kodiert (.txt"..., 43) = 43
write(43, "appendFilter \"HTML-Dokument (Ope"..., 70) = 70
write(43, "appendFilter \"AportisDoc (Palm) "..., 48) = 48
write(43, "appendFilter \"DocBook (.xml)\" \"*"..., 38) = 38
write(43, "appendFilter \"Microsoft Word 200"..., 54) = 54
write(43, "appendFilter \"Microsoft Word 200"..., 56) = 56
write(43, "appendFilter \"Office Open XML Te"..., 53) = 53
write(43, "appendFilter \"OpenDocument Text "..., 61) = 61
write(43, "appendFilter \"Pocket Word (.psw)"..., 42) = 42
write(43, "appendFilter \"Unified Office For"..., 57) = 57
write(43, "setCurrentFilter \"ODF Textdokume"..., 43) = 43
access("/home/didi", F_OK)              = 0
lstat("/home/didi", {st_mode=S_IFDIR|0700, st_size=16384, ...}) = 0
write(43, "setDirectory \"file:///home/didi/"..., 34) = 34
write(43, "setDefaultName \"urlaubsvorlage.o"..., 36) = 36
write(43, "setValue 100 noAction true\n", 27) = 27
write(43, "getValue 100 noAction\n", 22) = 22
futex(0xd15a0a4, FUTEX_WAIT_PRIVATE, 1, NULL) = -1 EINTR (Interrupted system call)
--- SIGCHLD (Child exited) @ 0 (0) ---
write(7, "\0", 1)                       = 1
rt_sigreturn(0x2)                       = -1 EINTR (Interrupted system call)
futex(0xd15a0a4, FUTEX_WAIT_PRIVATE, 1, NULL
Comment 6 Noel Power 2011-05-12 01:41:03 UTC
a better stack trace ( with all threads ) might give some better insight

http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29

but better still would be to try the latest beta from the libreoffice site to see if your problem still exists in the latest builds
Comment 7 dietmar.mueller 2011-05-12 07:21:09 UTC
the crash occure also, when I start lo and then choose open at the startscreen.

From this point I made the backtrace
Comment 8 dietmar.mueller 2011-05-12 07:21:41 UTC
Created attachment 46636 [details]
backtrace
Comment 9 dietmar.mueller 2011-05-12 07:27:30 UTC
Created attachment 46637 [details]
valgrid
Comment 10 Vikram J. Gurjar 2011-05-19 08:44:38 UTC
I installed LibreOffice 3.3.2 on Centos-5.6 with KDE

KDE crashes whenever the save button is pressed.

The solution to this is to put

OOO_FORCE_DESKTOP=gnome ; export OOO_FORCE_DESKTOP

in the file /usr/bin/libreoffice

So that it looks like this

#!/bin/sh
OOO_FORCE_DESKTOP="gnome" ; export OOO_FORCE_DESKTOP
exec /opt/libreoffice/program/soffice "$@"

And everything will be fine.

You can see the snapshots before and after at 

The crash screenshot
http://www.gurjar.com/librecrash.jpg

The modified file screenshot
http://www.gurjar.com/librecrash1.jpg

The result with the save dialog working
http://www.gurjar.com/librecrash2.jpg
Comment 11 Vikram J. Gurjar 2011-05-19 09:44:21 UTC
Another solution to the problem in Centos 5.6 KDE 3.5.4-25

Tools -> Options -> General -> Use LibreOffice dialogs

Also works without the /usr/bin/libreoffice file being modified.

The problem with this is if there are multiple users on a machine (eg the system is run as a Linux Terminal Server serving many users on thin clients) each user has to do this setting.

The previous way the users don't have to do anything.


Set the options like this
http://www.gurjar.com/librecrash3.jpg

The result with the save dialog working in the KDE mode
http://www.gurjar.com/librecrash4.jpg

*** This bug has been marked as a duplicate of bug 31109 ***
Comment 12 dietmar.mueller 2011-05-20 00:10:24 UTC
Hi,

I confirma that both workarounds works perfect.

thanks