Download it now!
Bug 37130 - Insert - Comment uses default system font instead of default Writer font
Summary: Insert - Comment uses default system font instead of default Writer font
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: VOTE target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-12 02:12 UTC by Kami
Modified: 2014-12-28 21:37 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
comment with default Tahoma font on Windows (2.63 KB, image/png)
2013-11-06 07:50 UTC, Kumāra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kami 2011-05-12 02:12:51 UTC
It seems Insert - Comment functionality in Writer uses default System font (on Ubuntu: Ubuntu) instead of default Writer font.

When I insert comment to a document on my Ubuntu box, and I open it on Windows box, it try to use Ubuntu font that does not exist after installation of LibreOffice on Windows.

Let LibreOffice use default Writer font instead of system font.
Comment 1 manj_k 2011-05-13 03:24:30 UTC
(In reply to comment #1)
> [...]
> Let LibreOffice use default Writer font instead of system font.

Isn't it a request for enhancement?

There's a similar discussion [with a statement by Christoph Noack, too] on
OOo-Bug-109773 – [Notes2] Cannot change default style of a comment (font, size, ...)
See: http://openoffice.org/bugzilla/show_bug.cgi?id=109773

Maybe a workaround:
1. Insert > Comment
2. (Before typing) Format > Character
3. Select Font etc.
Comment 2 Björn Michaelsen 2011-12-23 12:01:57 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-01-05 23:00:11 UTC
but what problem? Unreadable text? Please, attach document with example comment which creates problem on Windows. And tell locale of Windows (it is important to reproduce problem).
Comment 4 Florian Reisinger 2012-08-14 14:01:37 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:02:41 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:07:15 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:09:21 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 manj_k 2012-08-14 19:45:27 UTC
REOPENED as request for enhancement.
See also → https://issues.apache.org/ooo/show_bug.cgi?id=109773
Comment 9 Florian Reisinger 2012-08-16 10:48:54 UTC
Is this Linux only or does this also affect Windows
Comment 10 manj_k 2012-08-16 11:10:47 UTC
(In reply to comment #9)
> Is this Linux only or does this also affect Windows

See above: 'Platform'.

See above: 'See Also'.
Comment 11 rpr 2012-09-03 19:44:17 UTC
I confirm that this is also problem on MS Windows.
E.g. on Windows XP the default system font for all Latin and European languages is Tahoma (see http://support.microsoft.com/kb/823033) and it is used by default in comments in LibO Writer.

As suggested above, using the font from the Default style would be better.

Currently you cannot use styles for formatting comments in LibO Writer. If you could then it would be nice to have a new paragraph style (linked to the Default style) that comments would use by default.
Comment 12 bugquestcontri 2013-05-23 15:55:01 UTC
I can confirm the matter on XP Prof/SP3 using Writer Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539), portable

As the styles in LibO are such a great functionality, I propose to create a style for the ctrl+alt+c comments.

Please see also AskLibO discussion
http://ask.libreoffice.org/en/question/17591/how-to-change-default-font-for-alt-ctrl-c-comments/?comment=17960#comment-17960

If I am not mistaken, there are some other bug reports/enhancement request with a similar content. I just can't identify them.
Comment 14 sergio.callegari 2013-10-09 07:01:56 UTC
I certainly agree that comments should not use the default system font (that is probably not portable among different machines). But I don't really agree that comments should use default writer font.

IMHO, comments should use a style, just like everything else, only picking those features (font, size, etc.) that are actually applicable to comments.
Comment 15 Kumāra 2013-11-06 07:44:24 UTC
(In reply to comment #14)
> I certainly agree that comments should not use the default system font (that
> is probably not portable among different machines). But I don't really agree
> that comments should use default writer font.
> 
> IMHO, comments should use a style, just like everything else, only picking
> those features (font, size, etc.) that are actually applicable to comments.

What's the "default writer font"? Is there such a thing? I suppose he meant the font specified for the "Default Style", which is of course a style.

Anyway, I second allowing for paragraph style in comments, with "Default Style" as the default.
Comment 16 Kumāra 2013-11-06 07:50:47 UTC
Created attachment 88741 [details]
comment with default Tahoma font on Windows

Can you read the word?
Comment 17 Kumāra 2013-11-06 07:52:03 UTC
(In reply to comment #3)
> but what problem? Unreadable text? Please, attach document with example
> comment which creates problem on Windows. And tell locale of Windows (it is
> important to reproduce problem).

I've just posted an example of poor readability.
Comment 18 Marcus 2014-03-01 21:23:09 UTC
I definitely second that enhancement request. It is completely user unfriendly, to not let him (the user) decide, which font and size he would like to use for formatting comments. It might seem a small detail, but it has an impact.
Comment 19 Caolán McNamara 2014-04-12 12:38:10 UTC
FWIW Word uses by default a 10pt version of the font in the Normal style
Comment 20 Commit Notification 2014-04-12 12:48:32 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7228e0bdbb06de56145d1edeacfe4ede1a7a7d4

Resolves: fdo#37130 use 10pt Default style font for comments



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.