Bug Hunting Session
Bug 37161 - FILESAVE RTF: Vertical cell merging in tables not exported correctly
Summary: FILESAVE RTF: Vertical cell merging in tables not exported correctly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx, filter:rtf
Depends on: 80708
Blocks: RTF-Tables
  Show dependency treegraph
 
Reported: 2011-05-12 22:28 UTC by Christopher M. Penalver
Modified: 2019-09-07 20:29 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
new_merged_cells.odt (8.03 KB, application/vnd.oasis.opendocument.text)
2011-05-12 22:28 UTC, Christopher M. Penalver
Details
deocument containing four screenshots, confirming the bug (56.55 KB, application/vnd.oasis.opendocument.graphics)
2014-11-04 15:41 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-12 22:28:49 UTC
Created attachment 46663 [details]
new_merged_cells.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/132916

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=26964

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy unoconv
unoconv:
  Installed: 0.3-6
  Candidate: 0.3-6
  Version table:
 *** 0.3-6 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && unoconv --listener && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/132916/+attachment/132337/+files/new_merged_cells.odt && unoconv -f rtf new_merged_cells.odt && lowriter -nologo new_merged_cells.rtf new_merged_cells.odt

the .rtf document looks the same as the .odt.

4) What happens instead is it does not.
Comment 1 Jean-Baptiste Faure 2011-12-17 15:55:22 UTC
I confirm the problem with LO 3.5.0 beta-1 under Ubuntu 10.04 x86_64 (LibreOffice 3.5.0beta1+ Build ID: 6e7299d-7f15fca-8eae9f1-ca8e46d-5bcbce4)

Steps to reproduce:
1/ open the bugdoc
2/ save as RTF file and close the document
3/ reopen the RTF file

The table is broken.

Miklos: feel free to reassign if you can't handle this bug.

Best regards. JBF
Comment 2 Miklos Vajna 2012-01-01 07:18:15 UTC
This is an export problem, the created RTF doesn't contain the table cell strings, at all.
Comment 3 Miklos Vajna 2012-01-01 10:00:58 UTC
Hm, and seems to affect DOCX export as well, so probably a bug in MSWordExportBase.
Comment 4 Miklos Vajna 2012-01-03 03:36:27 UTC
So the major problem was that with the sample document only the first cell of the whole table was exported at all, this is now fixed with

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83fbebfea32b27cd722466607aa978244ac53575

on master, also cherry-picked to -3-5:

http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=99fccadd08d41e8a4abcc062d075886d4a0910be

The export result should be now on par with the DOC export, though still not perfect. If you want that improved, please file a separate bug for the DOC exporter (on which the RTF export is based).
Comment 5 Jean-Baptiste Faure 2012-03-18 10:41:28 UTC
Tested in LO 3.5.1, LO 3.5.2 rc0+ and master : probable memory leak (up to 2 Go RAM allocated by LO and very, very, very (I am not patient enough to wait the end) long time to save the file in RTF format.
Reopening the bug.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2012-03-24 05:29:16 UTC
(In reply to comment #5)
> Tested in LO 3.5.1, LO 3.5.2 rc0+ and master : probable memory leak (up to 2 Go
> RAM allocated by LO and very, very, very (I am not patient enough to wait the
> end) long time to save the file in RTF format.
> Reopening the bug.
> 
> Best regards. JBF

Or infinite loop ?
No problem when saving as MSWord97 format (unless merged cells are not merged anymore). Export as docx works but the result is incorrect (but that's probably another story).

Best regards. JBF
Comment 7 Miklos Vajna 2013-12-28 10:31:13 UTC
I just tried to reproduce this again, the file save takes about 1-2 seconds here, so closing again. Regarding correctness, please follow the advice in comment 4, that should not be handled here.

Thanks! :-)
Comment 8 Christopher M. Penalver 2013-12-28 14:13:16 UTC
Miklos Vajna, thank you for working on this. Unfortunately, the bug noted in the Description https://bugs.freedesktop.org/show_bug.cgi?id=37161#c0 is still not addressed:
lsb_release -rd
Description:	Ubuntu Trusty Tahr (development branch)
Release:	14.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.1.3-0ubuntu2
  Candidate: 1:4.1.3-0ubuntu2
  Version table:
 *** 1:4.1.3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

If you found the issue noted in the Description to be resolved, could you please post what version of LibreOffice this is fixed in, as well as a screenshot of both the .odt and .rtf proving this?

Thank you for your understanding.
Comment 9 Joel Madero 2014-11-04 03:30:37 UTC
I am closing this as FIXED once again
@Christopher - if you're seeing a similar problem please report a new bug.
Comment 10 Christopher M. Penalver 2014-11-04 07:12:12 UTC
Still reproducible in MASTER, and:
apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.2.6.3-0ubuntu1
  Candidate: 1:4.2.6.3-0ubuntu1
  Version table:
 *** 1:4.2.6.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1:4.2.3~rc3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Joel Madero, and anyone else who wants to toggle the bug report Status, let me be crystal clear here, I'm not going to file an additional, frivolous bug report as the original bug reported is still reproducible verbatim as per the Description -> https://bugs.freedesktop.org/show_bug.cgi?id=37161#c0 . Please review it in full so you understand the scope of this report.

With this in mind, this report never was, isn't now, and never will be RESOLVED FIXED until a commit for the bug noted in the Description is released, and in turn, verified by me, the original reporter. It is not fixed when a commit partially fixes, fixes something not related, or anything but fully fixes the issue as previously advised to you.

If your bug triage strategy is to close valid, and still reproducible LibreOffice bug reports when it is clearly not fixed, it would be best if you would cease toggling bug reports altogether.

Despite this, please do not toggle the status of this bug report further unless I have advised it's fixed.

Thank you for your understanding.
Comment 11 Cor Nouws 2014-11-04 08:31:21 UTC
(In reply to Christopher M. Penalver from comment #10)

> Thank you for your understanding.

So !

When Miklos writes: " The export result should be now on par with the DOC export, though still not perfect. If you want that improved, please file a separate bug for the DOC exporter (on which the RTF export is based). " that explains the logic how this works.
This issue 37161 then should have a dependency on the new bug.
Comment 12 Joel Madero 2014-11-04 15:12:16 UTC
Please stop messing with the settings if you don't know what you're doing. This bug has to be confirmed by an INDEPENDENT QA TEAM MEMBER. Reopened has a specific meaning and this doesn't meet that. Don't change it again.
Comment 13 Cor Nouws 2014-11-04 15:41:46 UTC
Created attachment 108903 [details]
deocument containing four screenshots, confirming the bug

Hi!

Managing bugs is important, but testing too!
I confirm and set to new
Comment 14 Cor Nouws 2014-11-04 15:43:44 UTC
new.. 

Hi Miklos,

Since the export to doc is fine, I think currently the result in rtf does not depend on that? Docx-export is broken too, but different.

Pls see my export result with the previous comment.

What would be your advise?

thanks,
Cor
Comment 15 Cor Nouws 2014-11-05 08:23:32 UTC
FYI: just to be sure, I tested the same document with an empty paragraph first, before the table.
Results the same.
Comment 16 A (Andy) 2015-04-06 19:05:46 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Table is almost fully broken (also compared to MSO).
Comment 17 Alexandr 2015-05-07 20:24:04 UTC
I test the issue with LibreOffice 5.0.0.0.alpha1+
Build ID: bcbf45d9f94d177c6841ccede3ff0ba69c4f22b1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-04_03:51:16

The file exported to docx is represented correctly in LibreOffice, but it can not be opened with MS Word Viewer under wine.

The rtf export is partially fixed with bug 80708, but the cells are still unmerged.
Comment 18 Robinson Tryon (qubit) 2015-12-14 06:03:31 UTC Comment hidden (obsolete)
Comment 19 Miklos Vajna 2015-12-22 22:08:04 UTC
Reset Assignee to default till I actually start looking into this.
Comment 20 QA Administrators 2017-01-03 19:57:39 UTC Comment hidden (obsolete)
Comment 21 Roman Kuznetsov 2018-09-02 17:38:37 UTC
Attention!

In LO 6.1.1.1 export from attached file to RTF gives empty RTF document! RTF doc doesn't have any table...

bug still repro and it has become more bad
Comment 22 QA Administrators 2019-09-03 16:12:06 UTC Comment hidden (obsolete)
Comment 23 Jean-Baptiste Faure 2019-09-07 20:29:29 UTC
Same observation as in comment #2: no table at all in the exported RTF file.

Tested in LO 6.3.3.0+

Best regards. JBF