Download it now!
Bug 37184 - FILEOPEN: LibreOffice always crashes while loading .odt-file
Summary: FILEOPEN: LibreOffice always crashes while loading .odt-file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 34420
  Show dependency treegraph
 
Reported: 2011-05-13 14:31 UTC by gleppert
Modified: 2015-06-25 07:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
first part of strace log of crash (921.60 KB, application/octet-stream)
2011-05-13 14:38 UTC, gleppert
Details
second part of strace log of crash (766.19 KB, application/octet-stream)
2011-05-13 14:39 UTC, gleppert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-05-13 14:31:55 UTC
I tried a document in LibreOffice 3.4Beta5 and LibreOffice always crashes while loading this file. It does not matter whether I first open LO and the open the file or whether I click on the file starting LO.

Reproducible: Always

I ran a strace log in order to display the reason for the crash via the command: strace -o /tmp/strace.log -f -tt -s 512 /opt/libreoffice3.4/program/swriter /home/gerald/Desktop/file-crashes-libreoffice-3-4-beta-5.odt

The strace.log is attached to this bug entry.

I cannot attach the original file to this bug entry, but I could send it via email upon request. Some information on the file: The file heavily relies on Graphite smart fonts (Sophia Nubian and Linux Libertinum G) and contains lots of Zotero-citations.

System: Ubuntu 10.10/gnome2. LibreOffice 3.4Beta5 debs, German UI, Intel 32-bit
Comment 1 gleppert 2011-05-13 14:38:58 UTC
Created attachment 46692 [details]
first part of strace log of crash
Comment 2 gleppert 2011-05-13 14:39:34 UTC
Created attachment 46693 [details]
second part of strace log of crash
Comment 3 Petr Mladek 2011-05-16 08:18:05 UTC
The strace includes part of the generated java backtrace:

--- cut ---
2633  23:16:23.895557 write(89, "[0xbfc42000,0xbfc92000]", 23) = 23
2633  23:16:23.895648 write(89, ",  sp=0xbfc8d050", 16) = 16
2633  23:16:23.895735 write(89, ",  free space=300k", 18) = 18
2633  23:16:23.895821 write(89, "\n", 1) = 1
2633  23:16:23.895904 write(89, "Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)\n", 80) = 80
2633  23:16:23.896234 write(89, "C", 1) = 1
2633  23:16:23.896337 write(89, "  [libvclli.so+0x3eb4b0]", 24) = 24
2633  23:16:23.896644 write(89, "\n", 1) = 1
2633  23:16:23.896943 write(89, "C", 1) = 1
2633  23:16:23.897036 write(89, "  [libvclli.so+0x3ec52c]", 24) = 24
2633  23:16:23.897345 write(89, "  _ZN9graphite22vm7Machine3runEPKPvPKhRPPNS_4SlotERNS1_8status_tE+0x3c", 70) = 70
2633  23:16:23.897460 write(89, "\n", 1) = 1
2633  23:16:23.897770 write(89, "C", 1) = 1
--- cut ---

It mentions graphite, so it might be related to the bug 34420.

gleppert@gmx.de: Just by chance. Does the document use the "Linux Libertine G" font?
Comment 4 Petr Mladek 2011-05-16 08:23:11 UTC
Anyway, the crash seems to happen just with the particular document => it should not block the 3.4.0 release => slightly reducing the severity.

Note that LO uses time based release model, see http://wiki.documentfoundation.org/Release_Criteria
Comment 5 gleppert 2011-05-16 15:26:42 UTC
@Petr: Yes, the document uses only following fonts: Sophia Nubian for all headings and Linux Libertine G for all other paragraphs.
Comment 6 Petr Mladek 2011-05-17 08:18:51 UTC
OK, I add dependency on the bug handling the graphite update.

Please, try LO-3.4.0-rc1 once it is out. This bug might be fixed there by the commit http://cgit.freedesktop.org/libreoffice/libs-extern-sys/commit/?h=libreoffice-3-4&id=2b46dd6afee72839d96d0646dbf52cfe3a9a7236
Comment 7 gleppert 2011-05-21 12:15:12 UTC
@Petr: I tried LO-3.4.0-rc1 and the problems seems to be solved. I could not reproduce the crash anymore. Thanks!

I close this bug.
Comment 8 Björn Michaelsen 2011-12-22 05:53:18 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.