Download it now!
Bug 37211 - "Ctrl+A" keys don't work in Basic IDE
Summary: "Ctrl+A" keys don't work in Basic IDE
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-05-14 14:23 UTC by clio
Modified: 2011-05-18 02:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
fixes cntrl+a & delete key problems (1.90 KB, patch)
2011-05-17 09:42 UTC, Noel Power
Details

Note You need to log in before you can comment on or make changes to this bug.
Description clio 2011-05-14 14:23:27 UTC
To reproduce:
1) Open Basic IDE (Alt F11, or though the Tools - Macros - Organize Macros... - LibreOffice Basic...)
2a) Input some test, select it and hit Del key.
2b) Press Ctrl A key combination

Result: Nothing happens.

Tested with Linux and Windows.
Was OK with LibO 3.4 beta4.
Comment 1 clio 2011-05-14 14:34:58 UTC
Please, also note Bug 36832 - "Select all" is always disabled in Basic IDE.
Comment 2 clio 2011-05-14 14:56:32 UTC
Also, please, note that Bug 36834 (Ctrl C works even when menu is disabled in Basic IDE) seems to be fixed in LibO3.4beta5 now (and it was present in LibO3.4beta4).

Patch for Bug 35706 (Ctrl F, Ctrl Alt F doesn't work in Basic IDE) seems to be related.
Comment 3 Rainer Bielefeld Retired 2011-05-14 23:08:46 UTC
Has already been reported as "Bug 37170 - Delete key does not work in BASIC IDE". Here we have more information, so I will mark that bug as EUP of this one.

Some of the reported Problems are reproducible with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:5)]"

Details:
Del key does not work
Has already been reported as "Bug 37170 - Delete key does not work in BASIC IDE". 

<ctrl+a> and also Menu 'Edit > Select all' do not work
As clio said already reported, might be related, but it isn't clear, so we should leave that bug open.

NOT Reproducibe
<ctrl+c> works although disabled.
For me that works perfect, and I do not understand what "Disabled in IDE" might mean. Greyed out because nothing is selected?

So it seems that nothing new is in this report, I close it, because a Meta-Bug for 1 or 2 Basic IDE bugs seems to be overdone.


@Clio
Although it seems that all OS might be affected: please contribute some more information concerning OS you tested. What Linux, what WIN?

Please feel free to reopen this bug as a Meta-Task for Basic IDE UI bugs, if evidence suggests that there still are several (more than 5?) similar UI bugs unfixed.
Comment 4 clio 2011-05-14 23:21:55 UTC
This is a more general bug, so I would prefer to have it reopened.

> <ctrl+a> and also Menu 'Edit > Select all' do not work
> As clio said already reported, might be related, but it isn't clear, so we
> should leave that bug open.

Don't confuse this with Bug 36832 – "Select all" is always disabled in Basic IDE
https://bugs.freedesktop.org/show_bug.cgi?id=36832
That bug is abouut Select All menu item was always disabled. Ctrl A worked fine in LibO 3.4 beta4. 

> NOT Reproducibe
> <ctrl+c> works although disabled.
> For me that works perfect, and I do not understand what "Disabled in IDE" might
> mean. Greyed out because nothing is selected?

Of course, this shouldn't be reproducibe in LibO 3.4 beta5, because this is fixed by the patch http://cgit.freedesktop.org/libreoffice/components/commit/?h=libreoffice-3-4&id=3db1a4235ac588cda2836f99091888583b461810 (see Bug 35706 – Ctrl F, Ctrl Alt F doesn't work in Basic IDE in LibO version dev300m103
https://bugs.freedesktop.org/show_bug.cgi?id=35706) Try it in beta4, if you want to reproduce it.

> 
> @Clio
> Although it seems that all OS might be affected: please contribute some more
> information concerning OS you tested. What Linux, what WIN?
> 

Ubuntu 10.04
This only bug was tested with WinXP.
Comment 5 Rainer Bielefeld Retired 2011-05-15 00:06:15 UTC
A. Sorry, I missed your hint concerning <ctrl+a> in Bug 36832
B. "Del" reported in Bug 37170, so I delete it from subject
   (but might have same roots, of course)
C. If the <ctrl+c> problem does no longer exist, Bug 36834 should be set to
   WFM (or Fixed, if you can contribute a Fix reference).

So the new problem for this report is "Ctrl+A" keys don't work in Basic IDE
I modified Subject line. That is not "critical"
Comment 6 Noel Power 2011-05-17 09:42:25 UTC
Created attachment 46831 [details]
fixes cntrl+a & delete key problems
Comment 7 Jan Holesovsky 2011-05-18 02:23:29 UTC
Reviewed & pushed to libreoffice-3-4, thank you!