Download it now!
Bug 37216 - Styles and formatting. Page styles. Enhancement request for easier applying
Summary: Styles and formatting. Page styles. Enhancement request for easier applying
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2011-05-15 02:17 UTC by addammo
Modified: 2012-05-10 06:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description addammo 2011-05-15 02:17:39 UTC
Applaying a style to a page is not intuitive. First, i must create a new page style into "Styles and formatting" dialog, then apply it from the "Format" menu. From the "Styles and formatting" dialog i can apply others styles to paragraphs, characters, frames, etc., correctly but if i attempt to apply a style to one page this style is applyed to all page. Maybe this is not a bug but a better way to do this should improve usability. A better way should be to implement this method into "Styles and formatting" dialog - page tab - with a simple double click on the style name.
Comment 1 Cor Nouws 2011-06-14 22:51:31 UTC
Insert > Break > Page break (Style) does the trick.
Applying from Styles and formatting makes the new page start from the place above the current position, that has a hard page break set.
Comment 2 Björn Michaelsen 2011-12-23 12:05:43 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 Roman Eisele 2012-05-10 02:04:26 UTC
@addammo@tiscali.it
(and @Cor Nouws):

I'm not sure if I understand this issue completely, but isn't this feature request a bit pointless, as Cor's comment #1 already pointed out?

The requested feature: applying a page style via double-clicking the name of a style in the 'Styles and formatting' window, already works fine (at least with LibreOffice 3.4.6 and 3.5.3.2): it changes the page style of all pages until (and back to) the next hard page break, and this is exactly how I would expect it to work in LibreOffice. If we want to use the page style only for a specific (new) page, Insert > Break > Page break (Style) helps, as Cor mentioned. Or insert the page break first and then double-click the style name in the 'Styles and formatting' window ...

So, what could be changed/improved here? Or can we close this feature request? I would suggest to do so ...

Please understand: Closing a bug report/feature request makes it easier to find the important, outstanding bugs and feature requests, of course, and therefore helps our developers.
Comment 4 Cor Nouws 2012-05-10 02:19:38 UTC
yes, let's just close it, since the OP didn't bother to comment or whatever.
Comment 5 addammo 2012-05-10 05:38:37 UTC
This is an enhancement request, not a bug report. Up to version 3.5.2.2 the page style is applyed also to the pages that follow the page i want to modify, until i specifie for those pages a new style (or the default style). There isn't a way to modify in a simplified way the style of a specific page.
I agree with you about the importance of this request, so close it.

Thank you and sorry for my bad english.
Comment 6 Cor Nouws 2012-05-10 06:23:03 UTC
(In reply to comment #5)
> There
> isn't a way to modify in a simplified way the style of a specific page.

Indeed, you need to set a hard break, where the changed page style starts.

> I agree with you about the importance of this request, so close it.

If you have any specific more or less realistic idea of how it could be improved, pls post it!
Isn't there something as the 'pagination' extension that makes is easier, or faster? You could have a look at that one.

> Thank you and sorry for my bad english.

It's fine, no probs :-)