Bug Hunting Session
Bug 37222 - UI: Possibility to open exported PDF in a simple way immediately after export required
Summary: UI: Possibility to open exported PDF in a simple way immediately after export...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: VOTE target:4.1.0
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2011-05-15 06:29 UTC by Rainer Bielefeld Retired
Modified: 2015-12-18 10:14 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-15 06:29:40 UTC
It would be great to have a possibility to open a PDF document immediately after creation by PDF export in the default PDF viewer, so that user can check immediately and without much work whether export is correct (for example because of "Bug 31606 - Exporting a selection of pages to PDF has pagerange wrong because of blank pages", but there are many other reasons)

Different possible solutions might be
A.: Export Option "Open after export in default viewer" 
B.: Toolbar with button "open latest PDF export" 
C.: or Toolbar with pulldown (latest 10 exports, may be incl html, ...)
D.: Additional item in file menu
E.: Export Option "Open after export in default viewer" in 'Tools > Options'
F.: may be other possibilities

A completely different approach shows 
Bug 37219 - Add exported PDF files to recent documents
Comment 1 Rainer Bielefeld Retired 2011-05-15 06:42:49 UTC
May be you want to vote for this enhancement request on the nonofficial Voting Page?
<http://wiki.documentfoundation.org/Vote_for_Enhancement#Bug_37222_-_UI:_Possibility_to_open_exported_PDF_in_a_simple_way_immediately_after_export_required>
Comment 2 Milan Bouchet-Valat 2011-10-30 02:25:13 UTC
I'd like to suggest two more solutions:
- In the export dialog, add another button next to "Export" labeled "Export and open". The drawback is that it doesn't work when using direct export from the toolbar.
- Add a pulldown to the "Direct export to PDF" toolbar button, with one item "Open exported PDF" when an export of the current document was done. I don't think it makes sense showing latest 5 exports or so, because they wouldn't be related to the current document, and thus to your current task.

Adding a new toolbar button would be too much IMHO, the general UI is already complex enough.


WRT bug 37219 - Add exported PDF files to recent documents:
As I explained on that report, these two bugs have much in common, but are not completely redundant. As I see it, bug 37219 would make the problem addressed in the present report easier to circumvent, but it wouldn't completely fix the very common use case "Export a PDF, check the result". We need a correct solution *within LO* that doesn't require the user to go and find the exported file by hand.
Comment 3 Rainer Bielefeld Retired 2011-10-30 02:45:21 UTC
@Milan Bouchet-Valat:
I agree
Comment 4 Anonymous Helper 2012-02-26 08:43:53 UTC
I have two more suggestions:

1.
Some desktop environments (like KDE[1]) allow showing notifications with buttons in it. LibO could show such a notification saying "xy.pdf saved to /whereever" and provide an "Show in Folder" button. This kind of notification is also used when a download has finished.

2.
Alternatively, a notification system somilar to IE9[2] could be implemented. So when a document has been exported, a notification is shown above the status bar. The notification should disappear automatically after a few seconds and this kind of notification might also be used for some other purposes.

[1] http://www.dedoimedo.com/images/computers_new_2/kubuntu-9-10-notifications.jpg
[2] http://www.codingbeaver.com/myblog/wp-content/uploads/2011/03/IE9DownloadInformationBar.jpg
Comment 5 Anonymous Helper 2012-03-01 09:46:36 UTC
There are already mockups of a possible information bar: http://wiki.services.openoffice.org/wiki/File:DiMaS_Document_HiddenNotesPane.png
Comment 6 Rainer Bielefeld Retired 2012-06-15 22:59:44 UTC
This should not be too difficult
This is inherited from OOo
Comment 7 Commit Notification 2013-05-17 15:53:03 UTC
anuragkanungo committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eea4a30a4332b92b5534d3d3dc0e6152108ed670

fdo#37222 and possibly fdo#37219



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Jorendc 2013-06-07 21:27:28 UTC
(In reply to comment #7)
> anuragkanungo committed a patch related to this issue.
> It has been pushed to "master":

Tested using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6; I get an error after I File > Export as PDF and check "View PDF after Export".

Error saving the document <document name>:
Write Error.
The file could not be written.

@Anurag: Can you reproduce this behavior?

Kind regards and thanks in advance,
Joren
Comment 9 Anurag Kanungo 2013-06-09 14:30:45 UTC
I did it on Open Suse and it was working fine there , as i don't have Mac OS X , so if some one else can verify the bug , that would be great .

 
Have you tried saving with some other name and was it working fine without checking the " View PDF after export " box  ?
Comment 10 Jorendc 2013-06-09 14:33:51 UTC
(In reply to comment #9)
> I did it on Open Suse and it was working fine there , as i don't have Mac OS
> X , so if some one else can verify the bug , that would be great .

@Thomas: you mind test this? Please see Comment 8 :-).


> Have you tried saving with some other name and was it working fine without
> checking the " View PDF after export " box  ?

I did. It worked without checking that box. I tried several names and folder. All with that warning.

Thanks for your time,
Joren
Comment 11 Thomas van der Meulen 2013-06-09 15:17:53 UTC
@joren: Yes I get that error wen I want to export a file.

Running LibreOffice Version: 4.1.0.0.beta2
Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6 on Mac osx 10.8.3. 

Should it be reopenend?
Comment 12 Gerry 2013-11-26 08:14:29 UTC
I mark this enhancement request as "Resolved -> Fixed", because this features actually is implemented. It also works nicely on Ubuntu 13.03 with LibreOffice 4.1.3.2. 

If you still encounter a bug related to this enhancement, I suggest that you file a new bug for it and add a note in this bug, too.
Comment 13 Maxim Monastirsky 2013-11-26 09:35:40 UTC
(In reply to comment #8)
> Tested using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.0.beta2
> Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6; I get an error after I
> File > Export as PDF and check "View PDF after Export".
> 
> Error saving the document <document name>:
> Write Error.
> The file could not be written.
@Jorendc: Could you please test with the latest dev builds? I think it should be fixed with http://cgit.freedesktop.org/libreoffice/core/commit/?id=7722a5906d8f6765395205f5074f480ad365aa19, but I don't own a Mac so I can't test it.
Comment 14 Jorendc 2013-11-26 11:34:32 UTC
(In reply to comment #13)
> (In reply to comment #8)
> > Tested using Mac OSX 10.8.3 with LibreOffice Version: 4.1.0.0.beta2
> > Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6; I get an error after I
> > File > Export as PDF and check "View PDF after Export".
> > 
> > Error saving the document <document name>:
> > Write Error.
> > The file could not be written.
> @Jorendc: Could you please test with the latest dev builds? I think it
> should be fixed with
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=7722a5906d8f6765395205f5074f480ad365aa19, but I don't own a Mac so I
> can't test it.

Still reproducible, I'll file a separate bug report for it.
Thanks for testing and pointing out it works Maxim/Gerry!

Kind regards,
Joren
Comment 15 Jorendc 2013-11-26 11:42:16 UTC
(In reply to comment #14)
> Still reproducible, I'll file a separate bug report for it.

No need to report another bug anymore :) :
Not reproducible anymore using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.alpha1+
Build ID: d93433ba1181f5d8f6ded0ed0c103df10ebb1f22
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-20_13:04:00

So probably fixed by Bug 68099.

Kind regards,
Joren
Comment 16 Robinson Tryon (qubit) 2015-12-18 10:14:30 UTC Comment hidden (obsolete)