Bug Hunting Session
Bug 37245 - Make 2nd column selection more intuitive for unchecked "Evenly distribute text"
Summary: Make 2nd column selection more intuitive for unchecked "Evenly distribute text"
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 22:14 UTC by guilfordstuff
Modified: 2016-09-21 12:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Try to select the second column of section 1 and add text (9.13 KB, application/vnd.oasis.opendocument.text)
2011-05-15 22:14 UTC, guilfordstuff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description guilfordstuff 2011-05-15 22:14:38 UTC
Created attachment 46754 [details]
Try to select the second column of section 1 and add text

I inserted a section in a .doc file with two columns, auto-width disabled, auto distribution of text disabled.  I filled the first column and am unable to select the second column to add text to it.  This bug is also present in Openoffice, so, it's either that you've hidden the selection method so well I can't find it or that it's a long-standing bug.  

I tried selecting by clicking on the second column (which I can see but not add text to).  If I allow auto-distribution of text, the second column fills fine.  There you are.  I'v attached an .odt with the same bug.
Comment 1 Rainer Bielefeld Retired 2011-05-16 06:05:46 UTC
NOT reproducible with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) German UI [DEV300m103 (Build:5)]"

Might be a user error or only 3.2.2?

I can use second column when I modify columns  settings to "Evenly distribute contents to all columns" or when I use key <ctrl+shift+enter> in first column.

I believe that's the intended behavior?

@guilfordstuff@gmail.com:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>?

Please explain why you think that you found a bug!

Can you please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide?

Thank you!
Comment 2 guilfordstuff 2011-05-16 07:44:32 UTC
(In reply to comment #1)
> NOT reproducible with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit)
> German UI [DEV300m103 (Build:5)]"
> 
> Might be a user error or only 3.2.2?
> 
> I can use second column when I modify columns  settings to "Evenly distribute
> contents to all columns" or when I use key <ctrl+shift+enter> in first column.
> 
> I believe that's the intended behavior?
> 
> @guilfordstuff@gmail.com:
> May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>?
> 
> Please explain why you think that you found a bug!
> 
> Can you please file Bug reports with status UNCONFIRMED if your are not
> absolutely sure that you contributed all required background information and
> that the problem will be reproducible with information you can provide?
> 
> Thank you!

Evenly distribute text is not an option for me.  I'm using it to have side-by-side lists.

Ctl-Shift-Enter to select a column is non-standard behavior for a WYSIWYG editor.  I say this is a bug because it violates the WYSIWYG paradigm.  I don't care if microsoft does this sort of thing; they write broken software all the time.
Comment 3 guilfordstuff 2011-05-16 07:48:45 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > NOT reproducible with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit)
> > German UI [DEV300m103 (Build:5)]"
> > 
> > Might be a user error or only 3.2.2?
> > 
> > I can use second column when I modify columns  settings to "Evenly distribute
> > contents to all columns" or when I use key <ctrl+shift+enter> in first column.
> > 
> > I believe that's the intended behavior?
> > 
> > @guilfordstuff@gmail.com:
> > May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>?
> > 
> > Please explain why you think that you found a bug!
> > 
> > Can you please file Bug reports with status UNCONFIRMED if your are not
> > absolutely sure that you contributed all required background information and
> > that the problem will be reproducible with information you can provide?
> > 
> > Thank you!
> 
> Evenly distribute text is not an option for me.  I'm using it to have
> side-by-side lists.
> 
> Ctl-Shift-Enter to select a column is non-standard behavior for a WYSIWYG
> editor.  I say this is a bug because it violates the WYSIWYG paradigm.  I don't
> care if microsoft does this sort of thing; they write broken software all the
> time.

Unless if violates some design criterion set up by the project, I would like this entered as a bug.
Comment 4 Rainer Bielefeld Retired 2011-05-16 08:25:59 UTC
I will ask Design team!

@guilfordstuff
Please do not continue useless citing complete comments. You should only cite if otherwise your comment can't be understood (because you refer to a comment 50 numbers below), and if you cite, please delete everything from cite that is not required. In most cases citation is not required if you answer to the latest comment.
Comment 5 guilfordstuff 2011-05-16 09:00:50 UTC
> @guilfordstuff
> Please do not continue useless citing complete comments.

Sorry.
Comment 6 Bernhard Dippold 2011-05-16 15:43:01 UTC
You need to define where the second column starts.

As the text is meant to float from column 1 to 2, it only moves there automatically, if the section reaches the end of the page (just add line breaks in column 1).

When you add a manual column break (Menu: Insert - Manual break - Column Break / or shortcut [Shift]+[Ctrl]+[Enter]) in column 1, text after the break starts in column 2.

This is similar clicking in the area below the text on a page (the cursor stays at the last position in the existing text), so I don't see this behavior as bug.

If you want to create a manual break when you click in the right column, I'd consider this a feature request that should be looked at among the UX team because I think there might be pitfalls in implementing it.

Feel free to join the Design team where we work on UX topics:
http://wiki.documentfoundation.org/Design#Communication

PS: Even if LibreOffice provides vast WYSIWYG features, it is not a WYSIWYG editor, but a word processor. Most WYSIWYG implementations are imperfect in any word processor (and it becomes even worse, if you want to achieve WYSIWYM).
Comment 7 guilfordstuff 2011-05-16 21:03:30 UTC
"*User experience* (UX) is about how a person feels about using a
product<http://en.wikipedia.org/wiki/Product_(business)>
, system <http://en.wikipedia.org/wiki/System> or service. User experience
highlights the experiential, affective<http://en.wikipedia.org/wiki/Affective>,
meaningful and valuable aspects of human-computer
interaction<http://en.wikipedia.org/wiki/Human-computer_interaction>
and
product ownership, but it also includes a person’s perceptions of the
practical aspects such as utility, ease of use and efficiency of the system.
User experience is subjective in nature, because it is about an individual’s
feelings and thoughts about the system"

LOL.  No thanks.  I think I see your problem.  You live in a world where
California post-normal thinking is acceptable.   Pop quiz hotshot: there are
two boxes on the screen and you what to put text into one of the boxes.
 What do you do?  First you click it.  That doesn't do anything.  Then you
read online documentation, and, that doesn't contain any answers.  Then you
search google with no luck.  Then you report it as a bug only to be told
that some cabal of post-normal thinkers who believe giving everyone a gold
star for participation will make up for the fact that their software only
works if you belong to the people's party and know the secret handshake.

SERIOUSLY!?!  I'm right.  You guys are wrong.  That's called normal
thinking.  I hate microsoft with just as much passion as I hate you guys
now, but, I need to get things done.  I'm totally serious about loading MS
Office under wine.  What an abomination.  I can't hand-hold your design team
where I'm outnumbered by people who think this sort of design is acceptible.
 It's not.  Please report this as a bug and possibly your entire design
process as a bug.  Or better yet, send out my little file to people who
aren't on your design team and see if they can figure out how to put
unbalanced text in both boxes.  It's not going to be pretty.  So, still a
bug.

On Mon, May 16, 2011 at 6:43 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=37245
>
> --- Comment #6 from Bernhard Dippold <bernhard@familie-dippold.at>
> 2011-05-16 15:43:01 PDT ---
> You need to define where the second column starts.
>
> As the text is meant to float from column 1 to 2, it only moves there
> automatically, if the section reaches the end of the page (just add line
> breaks
> in column 1).
>
> When you add a manual column break (Menu: Insert - Manual break - Column
> Break
> / or shortcut [Shift]+[Ctrl]+[Enter]) in column 1, text after the break
> starts
> in column 2.
>
> This is similar clicking in the area below the text on a page (the cursor
> stays
> at the last position in the existing text), so I don't see this behavior as
> bug.
>
> If you want to create a manual break when you click in the right column,
> I'd
> consider this a feature request that should be looked at among the UX team
> because I think there might be pitfalls in implementing it.
>
> Feel free to join the Design team where we work on UX topics:
> http://wiki.documentfoundation.org/Design#Communication
>
> PS: Even if LibreOffice provides vast WYSIWYG features, it is not a WYSIWYG
> editor, but a word processor. Most WYSIWYG implementations are imperfect in
> any
> word processor (and it becomes even worse, if you want to achieve WYSIWYM).
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 8 Stefan Knorr (astron) 2011-07-19 00:06:26 UTC
Hi,
while guilfordstuff obviously isn't the nicest person to have as a bug reporter, I think he has a valid point. If you open such a file at first blush you would think it is a table with two cells in one row. With the second cell somehow unclickable.

The lowest common denominator here seems to be an error window when double clicking on the second column. It could read something like this:
"To insert text into this column you have to insert a manual break first. [Insert Manual Break] [Cancel]"

Note, however, when there are more than two columns and the user clicks in the last one, multiple manual breaks would have to be entered with this solution. This should also be reflected in the error message, then:
"To insert text into this column you have to insert a manual breaks first. [Insert Manual Breaks] [Cancel]"
Comment 9 Björn Michaelsen 2011-12-23 12:05:57 UTC Comment hidden (obsolete)
Comment 10 sasha.libreoffice 2012-04-05 22:48:49 UTC
About attachment:
reproduced problem with second column. Steps to reproduce:
0. Open attached file
1. Place cursor into section
2. Enter some lines of text
Expected: text first fills second column of section, then section begin to increase
Actually: section increased until end of page, then begins filling second column

We should have some real world examples for determine which variant of column behaviour is better.

> Then you search google with no luck.
I entered "Iibreoffice column break"  and Google give useful information in first link
Comment 11 sasha.libreoffice 2012-04-06 03:10:33 UTC
Sorry, my previous comment is wrong!

I previously thought that option "Evenly distribute ..." means equal width of columns. Now I understand that it means equal amount of text (by hight) in all columns.

So, Writer in this situation works properly. It is not a bug.
Comment 12 Stefan Knorr (astron) 2012-04-06 04:16:45 UTC
@Sasha: It works "as expected" if you know that you activated equally distributed columns. However, it will still be rather unexpected to the casual user.

So, IMHO, keeping this open is a good idea (even if it surely is a corner case and not priority #1 on anyone's list currently).
Comment 13 Ákos 2016-09-21 12:45:32 UTC
I consider too, that is not a bug, it works "as expected".
When you fill the first column, you continue to write in second column, and if you want to switch to second column without fill the first, you can do with column brake.

You request is equivalent with click in the middle of a blank page.