Bug 37333 - EDITING: can't add rows to tables containing unique fields
Summary: EDITING: can't add rows to tables containing unique fields
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-18 14:17 UTC by negrus
Modified: 2012-08-23 18:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description negrus 2011-05-18 14:17:43 UTC
1) Create an external database with the following:

CREATE TABLE `anda` (
  `a` int(11) NOT NULL,
  `b` int(11),
  PRIMARY KEY  (`a`),
  UNIQUE KEY `b` (`b`)
);
CREATE TABLE `noanda` (
  `ab` int(11) NOT NULL,
  `c` int(11),
  PRIMARY KEY  (`ab`),
  UNIQUE KEY `c` (`c`)
);

2) Grant to a remote user.

3) Create LibreOffice database connected to it.

4) Try to add a row to the table 'noanda'. I can't do that, although I can add rows to the 'anda' table.

Contextual details:
The external database is MySql v5.0 running on a remote Debian Lenny.
LibreOffice runs on Ubuntu 11.04 with both ODBC and MySql(ODBC). I tried the version which comes with Ubuntu, then with 3.3 and then with 3.4 beta 5.
Everything on Qemu.
Comment 1 Björn Michaelsen 2011-12-23 12:03:18 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Robert Großkopf 2012-08-03 18:01:18 UTC
I tried this with LO 3.3.4 and the dircet connection to MySQL and a connection by JDBC on OpenSuSE 11.4, 32bit rpm.
I could add fields to both of the tables.
Comment 3 Jochen 2012-08-03 18:56:53 UTC
(In reply to comment #2)
> I could add fields to both of the tables.

Hi Negrus,

please comment the statement of Robert.
Are you still of the opinion that a bug exists?
Comment 4 Jochen 2012-08-23 18:54:36 UTC
@Negrus:

please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and if you can contribute requested additional information due to (especially BugReport Details)!

Set status to "RESOLVED -> WORKSFORME"