Bug 37408 - BIFF5 .xls shows non-Russian character encoding for Russian characters
Summary: BIFF5 .xls shows non-Russian character encoding for Russian characters
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-20 08:16 UTC by Christopher M. Penalver
Modified: 2016-05-19 10:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
lessons.xls (57.00 KB, application/vnd.ms-excel)
2011-05-20 08:16 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-20 08:16:06 UTC
Created attachment 46955 [details]
lessons.xls

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/262777

OOo bug may be found at:
http://openoffice.org/bugzilla/show_bug.cgi?id=95572

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) 2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen using LibreOffice Calc via the Terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/262777/+attachment/338558/+files/lessons.xls && localc -nologo lessons.xls

it displays the Russian characters correctly.

4) What happens instead is it does not. For example one has "Äèñöèïëèíà" instead of "Дисциплина".
Comment 1 Andras Timar 2011-05-20 13:39:48 UTC
This is an old known bug, see http://openoffice.org/bugzilla/show_bug.cgi?id=32785
Your file is in Excel 5.0 (BIFF5) format which is not fully supported. Nobody has implemented the CODEPAGE record in BIFF5.
Comment 2 Björn Michaelsen 2011-12-23 12:01:45 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 QA Administrators 2014-06-25 17:38:04 UTC
Please read this message in its entirety before responding.

Your bug was confirmed at least 1 year ago and has not had any activity on it for over a year. Your bug is still set to NEW which means that it is open and confirmed. It would be nice to have the bug confirmed on a newer version than the version reported in the original report to know that the bug is still present -- sometimes a bug is inadvertently fixed over time and just never closed.

If you have time please do the following:
1) Test to see if the bug is still present on a currently supported version of LibreOffice (preferably 4.2 or newer).
2) If it is present please leave a comment telling us what version of LibreOffice and your operating system.
3) If it is NOT present please set the bug to RESOLVED-WORKSFORME and leave a short comment telling us your version and Operating System

Please DO NOT
1) Update the version field
2) Reply via email (please reply directly on the bug tracker)
3) Set the bug to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 QA Administrators 2015-07-18 17:42:46 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 5 Buovjaga 2015-10-16 19:41:47 UTC
Still confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)
Comment 6 Maxim Monastirsky 2015-12-10 00:44:19 UTC
(In reply to Andras Timar from comment #1)
> This is an old known bug, see
> http://openoffice.org/bugzilla/show_bug.cgi?id=32785
> Your file is in Excel 5.0 (BIFF5) format which is not fully supported.
> Nobody has implemented the CODEPAGE record in BIFF5.
i#32785 is about BIFF5 *export*, while this bug is about BIFF5 *import*. And actually LO imports and honors the CODEPAGE record. The problem is that for this bugdoc it equals to 1252 (Latin I).

There is also additional problem with the FONT record that in BIFF5 stores the charset as well, and it equals to 1 - which corresponds to DEFAULT_CHARSET used in the LOGFONT WinAPI structure, which according to MSDN - "DEFAULT_CHARSET is set to a value based on the current system locale. For example, when the system locale is English (United States), it is set as ANSI_CHARSET." - means there is no way to know the used charset from it. (And the charset stored in the FONT record is preferred by LO over the CODEPAGE one).
Comment 7 Maxim Monastirsky 2016-05-19 10:21:33 UTC
NOTOURBUG as per comment 6 (i.e. the file has wrong codepage inside (and the 2nd paragraph of that comment is completely wrong and should be ignored).
Comment 8 Maxim Monastirsky 2016-05-19 10:22:43 UTC
*** Bug 90210 has been marked as a duplicate of this bug. ***