Bug Hunting Session
Bug 37439 - Dictionary access lost.
Summary: Dictionary access lost.
Status: CLOSED DUPLICATE of bug 37195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-21 10:17 UTC by Rainer Bielefeld Retired
Modified: 2012-05-08 05:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1: Language modules for Spelling, Hyphenation and Thesaurus unavailable (29.53 KB, image/png)
2011-05-21 13:19 UTC, manj_k
Details
Screenshot 2: All languaguage modules available (41.88 KB, image/png)
2011-05-21 13:22 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-21 10:17:15 UTC
I uninstalled Beta5 before upgrade to "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) [OOO340m1 (Build:11)]" (Custom - additional UI languages) without touching my user profile.

After Installation all of my frequently used dictionaries (German-Germany, English, French, Spanish) and also some seldom used (Hungarian, Danish) have been lost, only "German-Austria" and "Swaheli" still available
Comment 1 manj_k 2011-05-21 12:49:35 UTC
I remember Bug 37195 - no spelling after installing,
in particular: https://bugs.freedesktop.org/show_bug.cgi?id=37195#c4
'German (Austria)' and 'Swahili (Tanzania)', too. ;)

I could reproduce this bug several times  
(with different versions of LibO 3.4 Beta, and last today with the 3.4 Dev Snapshots 2011-05-19 and 2011-05-20)
as follows:
1. Uninstall/remove the older version of the program.
2. Install the new version and keep the same user profile.

My current workaround to get access to the bundled dictionary extensions:
1. Close LibO.
2. Go to your user profile: rename the folder 'bundled'
[path: '...\3\user\extensions\bundled'], e.g.: 'bundled_old'.
3. Restart LibO:
A new folder 'bundled' will be created in the user profile.
All bundled dictionaries will be available.

It seems that something with registering the bundled dictionary extensions is broken.
Comment 2 manj_k 2011-05-21 13:19:00 UTC
Created attachment 46982 [details]
Screenshot 1: Language modules for Spelling, Hyphenation and Thesaurus unavailable

Removed:
'libreoffice-3-4~2011-05-19_11.12.56_LibO_3.4.0rc1_Win_x86_install_multi.exe'.
Installed:
libreoffice-3-4~2011-05-20_23.15.42_LibO_3.4.0rc1_Win_x86_install_multi.exe

First start with the same user profile.
Comment 3 manj_k 2011-05-21 13:22:50 UTC
Created attachment 46983 [details]
Screenshot 2: All languaguage modules available

Renamed folder 'bundled' to 'bundled_old', and restarted LibO.
Comment 4 Rainer Bielefeld Retired 2011-05-21 22:54:48 UTC
Indeed, knwon problem from "Bug 37195 - no spelling after installing"

@manj_k:
thank you for finding the DUP

*** This bug has been marked as a duplicate of bug 37195 ***
Comment 5 manj_k 2012-05-08 05:35:02 UTC
Closed