Bug Hunting Session
Bug 37482 - EDITING: Selecting text box after changing text gives rotation handles
Summary: EDITING: Selecting text box after changing text gives rotation handles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Luke
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-22 20:18 UTC by Luke
Modified: 2011-07-07 00:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2011-05-22 20:18:59 UTC
Edit the text in a text box, then select the text box. The selection handles appear and are then immediately replaced with the rotation handles. This is incorrect behaviour since rotation handles should only appear on a second click of the text box.

This only happens if you are editing the text box - if you deselect everything, and then select the text box without starting the 'edit' mode, the selection handles appear as normal.
Comment 1 Yifan Jiang 2011-05-22 21:55:09 UTC
Reproduced on 3.4 RC1 / SLED 11 sp1.

This is a Impress specific issue.
Comment 2 Rainer Bielefeld Retired 2011-05-22 22:48:20 UTC
[Reproducible] with "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit)
German UI [OOO340m1 (Build:11)]" with newly created Presentations for text boxes to be filled ("Click to add text"),and for "normal" text boxes.

NOT reproducible with my existing presentation documents created with older LibO versions or OOo.

@tbehrens@novell.com
Please feel free to reassign if it's not your area!
Comment 3 Luke 2011-07-04 00:14:23 UTC
I'll take this on, if that's alright.
Comment 4 Andras Timar 2011-07-07 00:30:31 UTC
Pushed to libreoffice-3-4 branch, it will be in LibreOffice 3.4.2.