Bug Hunting Session
Bug 37501 - FILEOPEN Calc shows wrong date in Excel created .xls
Summary: FILEOPEN Calc shows wrong date in Excel created .xls
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 59692 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-23 06:47 UTC by Christopher M. Penalver
Modified: 2018-03-24 23:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
09_1011_h3g_project_report.xls (deleted)
2011-05-23 06:47 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-23 06:47:30 UTC
Created attachment 47044 [details]
09_1011_h3g_project_report.xls

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/456100

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Calc via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/456100/+attachment/857805/+files/09_1011_h3g_project_report.xls && localc -nologo 09_1011_h3g_project_report.xls

the Excel created file in cell A7 should be /22.

4) What happens instead is it is /21.
Comment 1 GerardF 2011-05-23 13:47:11 UTC
Integer 22 is the 21/01/1900.
Entering only the number 22 with a date format show the 22nd day since the origine date.

With Excel, you have 22/01/1900 cause for Excel 1900 is a leap year (false of corse).
It is an Excel bug, not a Calc bug.
So if you enter a date betxeen 1/1/1900 and 1/3/1900 you got a gap of 1 day.
Comment 2 Christopher M. Penalver 2011-05-24 09:34:28 UTC
GerardF, thanks for having a look at it. This resolution is confirmed via Microsoft's article "Excel 2000 incorrectly assumes that the year 1900 is a leap year": http://support.microsoft.com/kb/214326
Comment 3 Rainer Bielefeld Retired 2013-01-22 08:48:39 UTC
*** Bug 59692 has been marked as a duplicate of this bug. ***
Comment 4 Robinson Tryon (qubit) 2015-02-02 16:35:22 UTC
The content of attachment 47044 [details] has been deleted for the following reason:

Remove personal files