Bug Hunting Session
Bug 37510 - EDITING: screen position jumps when attempt to select row in a large table in a certain way with the mouse ...
Summary: EDITING: screen position jumps when attempt to select row in a large table in...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2011-05-23 09:39 UTC by sasha.libreoffice
Modified: 2017-06-02 21:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-05-23 09:39:41 UTC
To reproduce this problem 
create new empty Writer document
insert there thable with 2 column and 200 rows
select first column and press F12 (this not need to reproduce, just more handy)
place cursor into first row of table
scroll document to row 100 and place mouse cursor to left of table that cursor becomes like --> arrow.
Click mouse.
Row 100 selects, but table jumps that mouse cursor becomes opposite of, say, row 90. This jumping of table hinders to work with table, because it is easy to lost needed row of table and hard to select specific rows.

this bug reproduced on LibO 3.4 rc 1 on Mandriva/Fedora 64 bit and Windows XP 32 bit

From user point of view, this resembles Bug 35829 - Writer table: can not select rows by mouse
Comment 1 Rainer Bielefeld Retired 2011-05-23 22:59:27 UTC
[Reproducible] with "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) German UI [OOO340m1 (Build:11)]". Before I tested I undocked all Toolbars that might appear / disappear ans cause similar effects.

I see that 
1. if cell row 100 is nearby top of the page view will scroll when I click 
   line 100 so that new place of that row is nearby center or even bottom 
   of the screen 
2. if cell row 100 is nearby bottom of the page view will scroll when I 
   click line 100 so that new place of that row is nearby center of the screen

I'm afraid it's a feature (to get the "active" part of the table nearby visible center before additional action will be done) and not a bug?! But I believe it's a little cumbersome.

Old problem, I see the same behavior with OOo3.1.1

I believe Bug 35829 is something completely different.


@sasha: 
Can you please number the steps in your report, so that commenter can say "in step 7" instead or "where the reporter says that ..."?
Comment 2 Björn Michaelsen 2011-12-23 12:05:45 UTC Comment hidden (obsolete)
Comment 3 sasha.libreoffice 2011-12-25 07:37:16 UTC
reproduced on LibO 3.5.0 beta 1
Comment 4 Jorendc 2013-02-18 09:20:30 UTC
Hi Sasha,

I can't reproduce anymore using Linux Mint 14 x64 and LibreOffice 4.0.0. Can you confirm this? If yes, please mark this bug as RESOLVED WORKSFORME.

Thanks in advance for retesting,
Joren
Comment 5 sasha.libreoffice 2013-02-18 10:54:37 UTC
reproduced in LO 4.0.0.2 on RFR 17 64bit
Before selecting row 100 scroll document so that it appears near top or bottom of screen. Then after click it becomes in middle of screen.
Comment 6 Cor Nouws 2013-07-26 22:06:39 UTC
Hi all,

With due respect: Isn't this the common category: screen refreshment particularities ?
Comment 7 QA Administrators 2015-04-01 14:41:55 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-04-24 10:49:20 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 9 QA Administrators 2016-09-20 09:32:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920