Bug 37520 - Crash with Insert Names Labels
Summary: Crash with Insert Names Labels
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: Other Windows (All)
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4.1
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-23 13:41 UTC by Laurent BP
Modified: 2011-10-29 07:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simplified version of the previous file (9.66 KB, application/x-zip-compressed)
2011-05-23 14:36 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2011-05-23 13:41:49 UTC
Hello,

Following discussion on french discuss list
http://nabble.documentfoundation.org/QA-3-4RC1-Fichier-Calc-qui-fait-planter-tt2974743.html

This file
http://user.services.openoffice.org/fr/forum/download/file.php?id=19708
makes Calc crash. It seems to be Windows only (Ubuntu 10.04 64bits report no crash)
File is opening; when the progress bar is almost finished, Windows says application has to close.
Comment 1 Laurent BP 2011-05-23 14:36:54 UTC
Created attachment 47076 [details]
Simplified version of the previous file

This file makes crash 3.4RC1 but not 3.3.2
Comment 2 Laurent BP 2011-05-23 14:42:07 UTC
I added a simplified version of the file.
There is now only two empty sheets without macro, nor user defined style.
If you remove one of the two sheets, crash disappear. 
There are some Label defined as Insert > Names > Labels. If you remove them, crash disappear also.
Comment 3 Laurent BP 2011-05-23 14:51:40 UTC
Bug comes from labels:
Steps to reproduce the crash:
- create a new Calc file
- write two names on top of column (A1 and B1)
- select them
- Insert > Names > Labels, Add
- save file
- File > Reload => crash
Comment 4 vitriol 2011-05-23 21:58:08 UTC
Confirmed. Regression from 3.3.2
Comment 5 vitriol 2011-05-23 22:09:38 UTC
This bug makes some document unreadable by LibO 3.4. Nasty regression...
Comment 6 Michael Meeks 2011-05-24 04:11:00 UTC
Laurent - great job cutting down the document ! :-)
This is also valgrind clean under linux - which is even more annoying - we just don't have an easy edge to get at the problem. Urk.
Comment 7 Laurent BP 2011-05-24 09:29:06 UTC
I'm not sure if it could help to find the bug, but I tested all beta (except beta1) and they have all the bug. :(
Comment 8 Kohei Yoshida 2011-05-24 12:26:00 UTC
I'm looking at it right now.
Comment 9 Kohei Yoshida 2011-05-24 12:36:37 UTC
Ah, I found the cause of the crash.  I'll post my proposed patch to the list for review.
Comment 10 Kohei Yoshida 2011-05-24 14:12:56 UTC
Unfortunately my fix arrived too late for 3.4.  It will be fixed in 3.4.1.